LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-27-2016, 10:21 AM   #1
prasanth.bbnl
LQ Newbie
 
Registered: May 2015
Posts: 8

Rep: Reputation: Disabled
sound is not working in centos 7 for root user


Hi all,


please any one tell me if i log in as root user centos 7 sound is not working in my lap model (lenovo t410). for other user it is working fine.

if i want sound in root user what am i suppose to do.
 
Old 06-27-2016, 10:25 AM   #2
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 5,872

Rep: Reputation: Disabled
root is not a user, it is administrator account. There is absolutely no need for root to make sound or run GUI.
 
Old 06-27-2016, 02:05 PM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,981

Rep: Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447
in fact you should get a WARNING about the root account

a pop up about the sound not working is one
 
Old 06-27-2016, 02:58 PM   #4
notKlaatu
Member
 
Registered: Sep 2010
Location: Wellington, New Zealand
Distribution: Slackware, Fedora
Posts: 921

Rep: Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585Reputation: 585
You shouldn't run as root on a daily basis, but troubleshooting with root can sometimes be useful.

To get sound as root in CentOS, try adding root user to the audio group.
 
1 members found this post helpful.
Old 06-28-2016, 09:03 AM   #5
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,654

Rep: Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255
Quote:
Originally Posted by notKlaatu View Post
You shouldn't run as root on a daily basis, but troubleshooting with root can sometimes be useful.

To get sound as root in CentOS, try adding root user to the audio group.
Root by definition is a member of any group it wants. Adding root to random groups is an invitation for a security failure.
 
1 members found this post helpful.
Old 06-28-2016, 10:03 AM   #6
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 18,314

Rep: Reputation: 3877Reputation: 3877Reputation: 3877Reputation: 3877Reputation: 3877Reputation: 3877Reputation: 3877Reputation: 3877Reputation: 3877Reputation: 3877Reputation: 3877
Quote:
Originally Posted by jpollard View Post
Root by definition is a member of any group it wants. Adding root to random groups is an invitation for a security failure.
I agree with both jpollard and notKlaatu.

notKlaatu *DID* provide the answer to the question, but the OP is asking for something that is inherently bad. Logging in as root shouldn't be done, period, unless you're trying to fix something seriously bad. And I doubt you'd need a sound card for that.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
root user but not in root environment?? (centos 5.3) ashlyjay Linux - Newbie 2 07-12-2009 09:41 PM
Sound working as root, but not as a regular user... s2cuts Linux - General 4 06-29-2009 01:28 PM
no sound as normal user but there's sound as root on suse Sleen Linux - Hardware 4 08-27-2006 06:27 AM
user sound is fine, Root sound just squeals Doug.Gentry Linux - Newbie 1 09-05-2004 04:27 PM
sound works in root - no sound in user - Debian seanb Debian 9 02-28-2004 01:42 AM


All times are GMT -5. The time now is 06:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration