LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-27-2004, 10:59 AM   #1
LongName
Member
 
Registered: Aug 2004
Posts: 33

Rep: Reputation: 15
sound help


In the sound properties I have the arts checkbox off for both users root and another, In root I hear sound but in the other user there is no sound.

In root when playing a game there is no sound

In the other user when playing the same game I hear sound

With the arts checkbox on in root the sound for the game is delayed e.g. I jump, then in a few seconds I hear the jumping noise. and in the other user when that check box is on I get an access denied message for sound driver.

May someone please help me fix these problems.

Thanks in advance!

Edit:
I forgot to mension Im using KDE, and distribution based on Slackware Linux.

Last edited by LongName; 08-27-2004 at 11:04 AM.
 
Old 08-27-2004, 11:17 AM   #2
Crunch
Member
 
Registered: Feb 2003
Location: York, PA
Distribution: Slackware, FreeBSD, OpenBSD
Posts: 162

Rep: Reputation: 30
I and others possibly could help, although you're being pretty vague on you're description of what the program you're checking the box off in, and what game you're using. Here's my advice... you shouldn't be running a game as root though either. You should barely ever touch the root account unless you seriously have to. I can possibly help you on your permission denied error. This error might be coming from /dev/dsp, or /dev/mixer. Which ever it is, the case could be that it is chmodded so that you (and any other user other than root) can access this. You might want to try chmodding /dev/dsp to allow regular users to 'R'ead, and e'X'ecute. (I'm not 100% positive on this, although it's worth a shot.)

In shell assuming you're in the /etc/sudoers file... if not follow the commands below this one.
Quote:
$ sudo chmod og=rx /dev/dsp
Logged in as root (or su'd)
Quote:
$ su
Password:
# chmod og=rx /dev/dsp
Hope this helps your problem with the sound. As for the game, it just might be trying to process the signal coming from the soundcard so that it lags for a second then the frames catch back up with the game. Although I'm not 100% percent sure =)
 
Old 08-27-2004, 11:41 AM   #3
LongName
Member
 
Registered: Aug 2004
Posts: 33

Original Poster
Rep: Reputation: 15
Thanks for you help! That didn't work though. Here is the error message I get on the other user when enabling the arts option

Sound server informational message:
Error while initializing the sound driver:
device: default can't be opened for playback (Permission denied)
The sound server will continue, using the null output device.

I searched this and the game I play if possible communciates with the sound card directly.

Others have come accross similer problems but what I searched I could not find an answer. Iam problably searching for the wrong keywords again
 
Old 08-31-2004, 01:28 PM   #4
Joe Soap
Member
 
Registered: Sep 2001
Location: Switzerland
Distribution: Debian, Sidux
Posts: 225

Rep: Reputation: 30
Is your normal user a member of the audio group?

If not, you cab add the normal user tothe audio group via KDE's user manager: Click on K, click on System, click on user manager. You have to provide the root password. Then select the normal user with a double click and make sure the audio group checkbox is selected. Save your changes and close the user manager. Now log out of your session and log back in. Your sound should work now.

If not, check the volume settings with one of the mixer programs.

Cheers
Joe
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound coming from my sound blaster audigy 2 ZS platinum sound card msab Linux - Hardware 9 12-05-2010 05:10 AM
ALSA MIDI: Sound fonts for NVIDIA/NForce Soundstorm on-board sound vharishankar Linux - Hardware 6 09-04-2007 12:37 PM
FC2: Sound Card (SiS SI7012) Detect But Donot Play Sound rajanaeem Linux - Hardware 0 10-22-2004 03:41 PM
How to make a sound on Realtec ALC-650 card sound on a Shuttle ST62K? Laurent Linux - Hardware 0 05-30-2004 11:57 AM
No Sound : request_module: failed /sbin/modprobe -- sound-slot-0. error = 256 Mebuh Linux - General 0 01-26-2004 07:51 AM


All times are GMT -5. The time now is 10:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration