LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-20-2010, 06:56 AM   #1
@skm3nt
LQ Newbie
 
Registered: Jul 2010
Posts: 11

Rep: Reputation: 0
Sound Heard in external headphones but not in internal speakers of laptop


Hello everyone, I am new to fedora 13.
My problem is that I can not hear any sound from my laptop's internal speakers (that works f9 in windows--so no h/w probs!) but when I connect external headphones, everything is heard!



I have tried several commands from various internet sources since past one week. I would like to list a few of them:



580 rpm -ivh http://download1.rpmfusion.org/free/...ble.noarch.rpm

581 yum install vlc


583 yum install pavucontrol

584 /sbin/lspci

585 /sbin/lsusb

586 /sbin/dmesg

587 lspci | grep audio



592 rpm -Uvh adobe-release-i386-1.0-1.noarch.rpm

595 lspci | grep Audio

596 cat /proc/asound/card0/codec#* | grep Codec

597 yum --enablerepo=rawhide update alsa*

598 yum update alsa*

599 yum --enablerepo=rawhide update alsa*

600 wget "ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.17.tar.bz2"

617 tar -xjf alsa-driver-1.0.9rc4a.tar.bz2

628 cd alsa-lib-1.0.9rc4

629 ./configure

630 make && make install

652 cp -r /home/Avantika/Downloads/alsa-lib-1.0.9rc4 /usr/src/alsa

654 cd alsa-driver-1.0.9rc4a

655 ./configure --with-cards=intel8x0 --with-sequencer=yes ; make ; make install

662 chmod a+rw /dev/dsp /dev/mixer /dev/sequencer /dev/midi

663 modinfo soundcore

664 yum list | grep alsa

665 yum install alsa*

667 yum install alsa-kernel

668 yum install bluez-utils-alsa-3.32-1.fc9.x86_64

669 yum install alsa-plugins-pulseaudio.i386 1.0.17-1.fc10

670 rpm -qf /lib/modules/2.6.25.11-97.fc9.x86_64/kernel/sound/pci/hda/snd-hda-intel.ko

671 yum install pavucontrol

673 yum install xine-lib-extras-freeworld

674 yum install @sound-and-video

675 yum install phonon-backend-gstreamer

676 yum install gstreamer-plugins-ugly



679 yum install pulseaudio alsa-plugins-pulseaudio pulseaudio-esound-compat pulseaudio-libs pulseaudio-libs-glib2 pulseaudio-module-zeroconf pulseaudio-libs-zeroconf xmms-pulse pulseaudio-module-gconf wine-pulseaudio xine-lib-pulseaudio pulseaudio-utils pulseaudio-module-bluetooth gst-mixer padevchooser paman paprefs pavucontrol pavumeter



smod |grep snd

snd_hda_codec_intelhdmi 16015 1

snd_hda_codec_idt 53499 1

snd_hda_intel 24152 4

snd_hda_codec 73671 3 snd_hda_codec_intelhdmi,snd_hda_codec_idt,snd_hda_intel

snd_hwdep 6222 1 snd_hda_codec

snd_seq 50941 0

snd_seq_device 5895 1 snd_seq

snd_pcm 76131 3 snd_hda_intel,snd_hda_codec

snd_timer 19234 2 snd_seq,snd_pcm

snd 60573 16 snd_hda_codec_intelhdmi,snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq,snd_seq_devi ce,snd_pcm,snd_timer

soundcore 6198 1 snd

snd_page_alloc 7221 2 snd_hda_intel,snd_pcm



[root@localhost Avantika]# cat /proc/asound/cards

0 [Intel ]: HDA-Intel - HDA Intel

HDA Intel at 0x9c800000 irq 33



[root@localhost Avantika]# ps -ef |grep pulseaudio

Avantika 2122 1 1 Aug19 ? 00:03:51 /usr/bin/pulseaudio --start --log-target=syslog

root 10363 10298 0 05:01 pts/0 00:00:00 grep pulseaudio



[root@localhost Avantika]# cat /proc/asound/cards

0 [Intel ]: HDA-Intel - HDA Intel

HDA Intel at 0x9c800000 irq 33



[root@localhost Avantika]# ps -ef |grep pulseaudio

Avantika 2122 1 1 Aug19 ? 00:05:24 /usr/bin/pulseaudio --start --log-target=syslog

root 10805 10298 0 05:37 pts/0 00:00:00 grep pulseaudio




I don't understand many of the commands that I have run, but that has somehow helped me to run media files and hear sound on HEADPHONES....

I have checked and think nothing is muted (using instructions from forums....)

I will be very thankful if someone can help me solve this problem.....
 
Old 08-20-2010, 04:21 PM   #2
spoovy
Member
 
Registered: Feb 2010
Location: London, UK
Distribution: Slackware 14; CentOS; Vyatta
Posts: 372

Rep: Reputation: 33
if it were me, i'd erase pulseaudio, as that always caused me weird problems in fedora. Try

Code:
su -c "yum erase pulseaudio"
Also I assume you have tried all the mixer option? Try running

Code:
aumix
or

Code:
amixer
or

Code:
kmix
or whatever relevant is installed, and fiddle with all the dials. you may have speakers on mute or something.
 
Old 08-20-2010, 11:11 PM   #3
@skm3nt
LQ Newbie
 
Registered: Jul 2010
Posts: 11

Original Poster
Rep: Reputation: 0
I got a suggestion:

Have you tried to go to System -> Preferences -> Sound -> Output
Here you should see a menu named 'Connector:' Where you can choose your output, choose Analog Speakers for the sound to be played on your laptops internel speakers...

and that solved my problem!!

I would like to ask you whether pulse audio is a software(application) or driver kind of thing? Do vlc, rythembox music player, movie player and pulse audio are same category things and would be ok if I keep one of them?

I have one more problem as well if you would like to see if you could help me:
http://forums.fedoraforum.org/showth...44#post1392244

And thank you for showing interest in my problem :-)

Last edited by @skm3nt; 08-20-2010 at 11:15 PM.
 
Old 08-21-2010, 04:02 AM   #4
spoovy
Member
 
Registered: Feb 2010
Location: London, UK
Distribution: Slackware 14; CentOS; Vyatta
Posts: 372

Rep: Reputation: 33
Pulseaudio is a sound server - it kind of sits between the sound software and the hardware, the idea being that you can have multiple sound sources (such as vlc, rhythmbox etc) playing at the same time, and control the volume of them all individually. Rather than the old way, which would be to mingle all the sound sources, and have one "master" control to control the volume out. The only GUI you will see for puleaudio would be a mixer settings GUI.

It's been notoriously troublesome though, and many many people think it just adds further complexity and problems. It's very common for people to remove it altogether. Linux audio is a nightmare in my opinion; it's too complicated by far.

Withg regard to your second problem. Try the following commands to give you some more information -

Code:
service -status-all

chkconfig -list
The following command will find the httpd config file, which you should review for any obvious errors (for example lack of a valid IP address and name for your webserver) -

Code:
rpm -qc httpd
Also make sure you have the following packages installed -

Code:
yum install httpd httpd-manual httpd-devel


EDIT - I notice that httpd is in /usr/sbin, so maybe it is only controllable as root? (the sbin dir is for root-only programs, it is not in a normal users $PATH). Try the following, as root user -

Code:
chkconfig httpd on

service httpd start
The service needs a valid IP address and name or will fail, so make sure you add a ServerName entry to the configuration file as well. Then restart the service.

Last edited by spoovy; 08-21-2010 at 04:12 AM.
 
Old 08-22-2010, 05:47 AM   #5
@skm3nt
LQ Newbie
 
Registered: Jul 2010
Posts: 11

Original Poster
Rep: Reputation: 0
service -status-all --> unrecognized service
chkconfig -list --> list is unrecognized option

The packages you mentioned are already installed. I don't understand the contents of the conf file, I am attaching it here...

Status is still the same-->httpd dead but subsys locked
Attached Files
File Type: txt httpdconf.txt (32.9 KB, 2 views)
 
Old 08-23-2010, 03:41 AM   #6
spoovy
Member
 
Registered: Feb 2010
Location: London, UK
Distribution: Slackware 14; CentOS; Vyatta
Posts: 372

Rep: Reputation: 33
Are you running those first commands as root? Try with a double hyphen ie

Code:
chkconfig --list
and check their man pages.


Have you checked that you have a valid IP address and server name?
 
Old 08-24-2010, 12:58 AM   #7
@skm3nt
LQ Newbie
 
Registered: Jul 2010
Posts: 11

Original Poster
Rep: Reputation: 0
Where to check for a valid IP address and server name?
 
Old 08-25-2010, 03:14 AM   #8
spoovy
Member
 
Registered: Feb 2010
Location: London, UK
Distribution: Slackware 14; CentOS; Vyatta
Posts: 372

Rep: Reputation: 33
Blimey mate i'm trying to help out here, but you gotta meet me halfway! Have you read up on how to use Apache?
 
Old 08-28-2010, 07:26 PM   #9
@skm3nt
LQ Newbie
 
Registered: Jul 2010
Posts: 11

Original Poster
Rep: Reputation: 0
i'll do so asap n get back
 
  


Reply

Tags
httpd, locked, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Internal Speakers Don't shut off When Connecting Headphones skipjackrc4 Linux - Laptop and Netbook 17 08-21-2009 07:29 AM
No sound from external speakers in Fedora 8 (laptop speakers ok) openSauce Linux - Hardware 7 03-15-2009 03:48 PM
sound from laptop speakers although external speakers are connected! superpingu Linux - Laptop and Netbook 1 10-18-2007 06:32 AM
Laptop speakers off when plug in headphones garyozzy Linux - Hardware 8 02-04-2006 02:44 PM
Can get sound from laptop speakers but not from headphones thetremorchrist Linux - Hardware 4 02-14-2004 03:43 AM


All times are GMT -5. The time now is 01:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration