LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-27-2007, 03:38 PM   #1
Mercantez
LQ Newbie
 
Registered: Apr 2007
Posts: 3

Rep: Reputation: 0
Question Sound doesn't work, FC6 doesnt find AC97 on motherboard.


Hello.

I have a problem and i search the web for some hours but none have solved it.
So right now i have a soundblaster inside it even 2! SB Audigy and SB X-fi .

X-fi doesn't work because alsa doesn't support it,i use it to windows now.
SB Audigy because it works on FC6 but takes space.

I found on mine motherboard an input to speakers and its a intel card so i belive they are using AC97 tried to install drivers but got confused about witch to choose, and its not still working.

The thing is FC6 doesn't even see AC97 only mine Soundblaster cards.

So can someone help me on this? Would be great to get it working.
 
Old 04-27-2007, 04:45 PM   #2
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Hello,

I think there is some confusion here on terminology, as well as your description of your hardware layout. I get the feeling that you have 2 soundcards, 1 onboard soundcard, and 1 PCI soundcard. If that is the case, typically your BIOS will automatically disable the onboard sound when a PCI soundcard is installed. So if you are having problems trying to get Linux to recognize your onboard sound, you may need to remove your PCI soundcard. If it's a problem getting any sound working, you may just need to move the plug to the PCI soundcard and forget the onboard even exists.

Good luck!

Cool
 
Old 04-27-2007, 06:07 PM   #3
Mercantez
LQ Newbie
 
Registered: Apr 2007
Posts: 3

Original Poster
Rep: Reputation: 0
Ok thank you i will try it out.
I belive you picked up mine bad description pretty good.
 
Old 04-27-2007, 06:17 PM   #4
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
No need to remove any PCI cards. I have an onboard Realtek and a Soundblaster Audigy. I can switch from one to the other without a problem. It seems to me the main thing is to set have them properly set up.

Start by typing this into a terminal:

alsaconf

And follow the instructions.

Then go to the speaker icon on you menu bar, select Open Volume Control and verify
- that it is using the desired device
- that it is using the proper parameters
 
Old 04-27-2007, 07:04 PM   #5
Mercantez
LQ Newbie
 
Registered: Apr 2007
Posts: 3

Original Poster
Rep: Reputation: 0
Problem fixed!

MasterC and jay73thank you really much.

What i did was go in to Bios and enabled the onboard sound and worked! I then removed the old Sounblaster card and got space for something else in it. And changed some settings in Soundcard Detection.

I will be around the forum. I find it really interesting and informing.

Now I can sleep really good tonight.

See ya around and thanks!
 
Old 04-28-2007, 05:10 PM   #6
firedancer
Member
 
Registered: Apr 2007
Posts: 146

Rep: Reputation: 15
hi, i'm not getting any sound suddenly, when i write code aplay -l i see my soundcards

card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 0: Intel ICH [Intel 82801DB-ICH4]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 4: Intel ICH - IEC958 [Intel 82801DB-ICH4 - IEC958]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: default [USB Audio CODEC ], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 2: Solo1 [ESS ES1938 (Solo-1)], device 0: es-1938-1946 [ESS Solo-1]
Subdevices: 2/2
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1

how can i get back sound, cause i 've been busy with other stuff
 
Old 04-28-2007, 07:08 PM   #7
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Did you try the suggestions I made earlier in this thread?
 
Old 04-28-2007, 07:38 PM   #8
firedancer
Member
 
Registered: Apr 2007
Posts: 146

Rep: Reputation: 15
Thumbs up

well switching the plug worked

one questions do i have to do that everytime

when i'm recording it's actually no problem i can switch in audacity to any soundcard

but when i just want to listen having the rec material on off it does this

let me know and thanx appreciate it
 
Old 04-28-2007, 07:46 PM   #9
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Sorry, I'm afraid I can't give you the definitive answer on that. But why do you want to switch cards? Wouldn't it be a good idea to use the better card as your default?
 
Old 04-30-2007, 04:45 AM   #10
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Quote:
Originally Posted by jay73
No need to remove any PCI cards. I have an onboard Realtek and a Soundblaster Audigy. I can switch from one to the other without a problem. It seems to me the main thing is to set have them properly set up.
Definitely true in some cases. However, in other cases the BIOS will disable any onboard sound if an addon soundcard is installed at boot time. You may be able to get around this by using USB-Audio though...

-Chad
 
Old 04-30-2007, 01:04 PM   #11
Reginod
LQ Newbie
 
Registered: Apr 2007
Posts: 3

Rep: Reputation: 0
I've just recently installed Ubuntu on a Pentium 3 system that was previously running Windows XP. I've had no audio of any kind since installing Ubuntu; apparently it isn't recognizing the soundcard.

When I ran aplay -I from the command prompt this is what I got:

ALSA lib confmisc.c:670: (snd_func_card_driver) cannot find card '0'
ALSA lib conf.c:3479: (_snd_config_evaluate) function snd_func_card_driver returned error: No such device
ALSA lib confmisc.c:391: (snd_func_concat) error evaluating strings
ALSA lib conf.c:3479: (_snd_config_evaluate) function snd_func_concat returned error: No such device
ALSA lib confmisc.c:1070: (snd_func_refer) error evaluating name
ALSA lib conf.c:3479: (_snd_config_evaluate) function snd_func_refer returned error: No such device
ALSA lib conf.c:3947: (snd_config_expand) Evaluate error: No such device
ALSA lib pcm.c:2146: (snd_pcm_open_noupdate) Unknown PCM default
aplay: main:547: audio open error: No such device


Any insights on how to proceed would be appreciated. Sorry if these seem like stupid questions but so far researching the issue hasn't turned up any applicable info. I am still very new to Linux. Thx . . . .

Last edited by Reginod; 04-30-2007 at 01:07 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ALSA can't find my integrated AC97 Sound Card dr_angus Debian 25 10-27-2005 10:54 PM
No sound at all with FC4 and on board AC97 sound ATI motherboard janie Fedora 2 10-13-2005 12:50 PM
Stupid AC97 (sound doesnt work) BBB Linux - Hardware 2 10-28-2004 02:39 PM
AC97 NF7-S Sound doesn't work jollygreengiant Linux - Hardware 7 05-27-2004 10:46 PM
AC97 sound doesnt work mr_svperstar Linux - Newbie 23 10-08-2003 06:32 PM


All times are GMT -5. The time now is 05:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration