LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-31-2005, 06:30 PM   #16
Dimi Tag
LQ Newbie
 
Registered: Mar 2005
Location: Germany
Distribution: Suse 9.2
Posts: 12

Original Poster
Rep: Reputation: 0

I am trying to open the rosegarden sequencer but first I have to open the Jack server (that's what it says) or else I won't have any sound. I opened the QJackctr and pressed Start but jack doesn't open. I have a mini explanation on the first message. I just want to run the rosegarden normally!
 
Old 04-01-2005, 02:38 AM   #17
vasudevadas
Member
 
Registered: Jul 2003
Location: Bedford, UK
Distribution: Slackware 11.0, LFS 6.1
Posts: 519

Rep: Reputation: 30
JACK is a soundserver, middleware that sits between the sound driver interface and the audio application. It allows multiple applications to access the sound device simultaneously, or pass audio data between each other, and was designed for professional low-latency operation.
 
Old 04-01-2005, 02:40 AM   #18
vasudevadas
Member
 
Registered: Jul 2003
Location: Bedford, UK
Distribution: Slackware 11.0, LFS 6.1
Posts: 519

Rep: Reputation: 30
So what does it say (error messages) when you try to start the JACK daemon? If necessary, try to start the daemon from the command line.

The web site for tha JACK audio connection kit is http://jackit.sourceforge.net.
 
Old 04-01-2005, 04:26 PM   #19
Dimi Tag
LQ Newbie
 
Registered: Mar 2005
Location: Germany
Distribution: Suse 9.2
Posts: 12

Original Poster
Rep: Reputation: 0
I changed the serverpath in the QJackctr setup to jackd from jack setup and finally jack opened but with the following messages in the log window:

22:55:24.024 MIDI connection change.
22:55:36.033 Startup script...
22:55:36.035 artsshell -q terminate
sound server terminated
22:55:36.612 Startup script terminated successfully.
22:55:36.669 JACK is starting...
22:55:36.671 /usr/bin/jackd -R -dalsa -dhw:0 -r48000 -p1024 -n2
22:55:36.692 JACK was started with PID=5101 (0x13ed).
jackd 0.98.1
Copyright 2001-2003 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
loading driver ..
apparent rate = 48000
creating alsa driver ... hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
control device hw:0
configuring for 48000Hz, period = 1024 frames, buffer = 2 periods
Couldn't open hw:0 for 32bit samples trying 24bit instead
Couldn't open hw:0 for 24bit samples trying 16bit instead
Couldn't open hw:0 for 32bit samples trying 24bit instead
Couldn't open hw:0 for 24bit samples trying 16bit instead
JACK: unable to mlock() port buffers: Cannot allocate memory
cannot set thread to real-time priority (FIFO/20) (1: Operation not permitted)
cannot use real-time scheduling (FIFO/10) (1: Operation not permitted)
22:55:38.728 Server configuration saved to "/home/dimi/.jackdrc".
22:55:38.732 Statistics reset.
22:55:38.744 Client activated.
22:55:38.747 Audio connection change.
cannot lock down memory for RT thread (Cannot allocate memory)
Cannot temporarily set client to RT scheduler: Operation not permitted


from the shell with this command <jackd -d alsa hw:0> I get this

jackd 0.98.1
Copyright 2001-2003 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

loading driver ..
creating alsa driver ... hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
control device hw:0
configuring for 48000Hz, period = 1024 frames, buffer = 2 periods
Couldn't open hw:0 for 32bit samples trying 24bit instead
Couldn't open hw:0 for 24bit samples trying 16bit instead
Couldn't open hw:0 for 32bit samples trying 24bit instead
Couldn't open hw:0 for 24bit samples trying 16bit instead


**** alsa_pcm: xrun of at least 0.059 msecs

And sometimes after waiting a lot whithout the last line

I open rosegarden while jack working and:

Direct access to sound device not possible
No soundcard available or sound support not configured yet. However the application uses or requires sound support.
continue (or) abort

In Yast I still have 2 souncards detected. Ensoniq AudioPCI configured as snd-crd-0 and Creative Sound Blaster AudioPCI64V,AudioPCI128 not configured. When I try tou configure it occurs the following error:

The kernel module snd-ens1371 for sound support could not be loaded. This can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
 
Old 04-04-2005, 06:48 PM   #20
Dimi Tag
LQ Newbie
 
Registered: Mar 2005
Location: Germany
Distribution: Suse 9.2
Posts: 12

Original Poster
Rep: Reputation: 0
I don't know if that helps but I saw that when running FVWM instead of KDE I don't get the message from Rosegarden about 'direct acces to soundcard'
 
Old 04-05-2005, 01:54 PM   #21
vasudevadas
Member
 
Registered: Jul 2003
Location: Bedford, UK
Distribution: Slackware 11.0, LFS 6.1
Posts: 519

Rep: Reputation: 30
Is the soundserver really not working? Can you use any other application (say, xmms with the xmms-jack output plugin) that outputs sound through jack?
 
Old 04-05-2005, 07:02 PM   #22
Dimi Tag
LQ Newbie
 
Registered: Mar 2005
Location: Germany
Distribution: Suse 9.2
Posts: 12

Original Poster
Rep: Reputation: 0
I opened jack from Qjackctl (because it doesn't open from the shell) and then xmms.
I changed in the preferences the output plugin to 'jack Driver 0.9 (libjackout so) and then tried to play an mp3. I got two messages:

Couldn't open audio
Please check that:
Your soundcard is configured properly
You have the correct output plugin selected
No other program is blocking the soundcard.

Sample rate mismatch
Xmms is asking for a sample rate that differs from that of the jack server. Xmms 1.2.8 or later contains resampling routines that xmms-jack will dynamically load and use to perform resampling. Or you can restart the jack server with a sample rate that matches the one that xmms desires. -r is the option for the jack alsa driver so -r 44100 or -r 48000 should do.

Although the rate in qjackctl setup is 48000 and although I changed it to 44100 I still get both messages.

BUT the problems keep coming up!!!

I did all the above having logged in as a root. now I am logging in as user and I can't open qjackctl at all. it says that I don't have enough permissions! Why did this change?

It seems to me a mess.

Shall I reinstall jack? And if so how can I completely remove the previous files? Just from Yast?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Other problem with the sound in Mandrake - onboard sound card Swetko Linux - Hardware 24 06-19-2006 04:27 PM
Sound problem with intel8x0 sound card. ivopz Linux - Hardware 2 03-28-2005 06:01 AM
Tv card + Sound Card = Audio Problem? kak Slackware 2 01-02-2005 02:18 AM
No sound, problem with sound card install? ak4me Linux - Hardware 2 03-06-2004 05:01 PM
Sound card and Graphics card problem abcdef3 Linux - Software 2 07-31-2001 05:20 AM


All times are GMT -5. The time now is 09:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration