LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-30-2005, 03:20 AM   #1
obstinatesod
Member
 
Registered: Apr 2005
Location: Shetland
Distribution: PClinuxOS, Suse 10.0, Mandriva, Alinux,
Posts: 126
Blog Entries: 1

Rep: Reputation: 15
sound card


Hi I have Suse 10.0 and its great but I can't get it to store the sound settings. this is what I have to do each time I reboot: alsaconf, follow steps and save by typeing " alsactl store" is this right? this was the same when I had Suse 9.3 can you help. thank you, Adrian
 
Old 11-30-2005, 04:35 AM   #2
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,487

Rep: Reputation: 88
Re: sound card

Quote:
Originally posted by obstinatesod
Hi I have Suse 10.0 and its great but I can't get it to store the sound settings. this is what I have to do each time I reboot: alsaconf, follow steps and save by typeing " alsactl store" is this right? this was the same when I had Suse 9.3 can you help. thank you, Adrian
I assume you have tried

alsactl -f configfile restore in /etc/rc.local

after doing

alsactl -f configfile store

after using your mixer to set the card up like your want?

This should have the effect of restoring the saved configuration in configfile each time you start up your system.
 
Old 11-30-2005, 08:36 AM   #3
obstinatesod
Member
 
Registered: Apr 2005
Location: Shetland
Distribution: PClinuxOS, Suse 10.0, Mandriva, Alinux,
Posts: 126
Blog Entries: 1

Original Poster
Rep: Reputation: 15
sound card

Thanks rylan76, just tried that and just the same after re-boot. I went into Yast and clicked on sound and it says not configured, so I tried to set it up and got the error " The Kernel module can not be loaded. This can be caused by incrrect module parameters incuding invalid io and IRQ parameters."

The error I got in Konsole was alsactl load state: 1250: can not find soundcard in'...

The card is listed as VIA Technologies inc. VT8233/A/8235/8237 AC97 Audio control
also it says
Legacy probe legacy ISA (non pnp) chips
any help in easy to follow steps much appriciated, thanks Adrian
 
Old 12-01-2005, 02:39 AM   #4
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,487

Rep: Reputation: 88
Re: sound card

Quote:
Originally posted by obstinatesod
Thanks rylan76, just tried that and just the same after re-boot. I went into Yast and clicked on sound and it says not configured, so I tried to set it up and got the error " The Kernel module can not be loaded. This can be caused by incrrect module parameters incuding invalid io and IRQ parameters."

The error I got in Konsole was alsactl load state: 1250: can not find soundcard in'...

The card is listed as VIA Technologies inc. VT8233/A/8235/8237 AC97 Audio control
also it says
Legacy probe legacy ISA (non pnp) chips
any help in easy to follow steps much appriciated, thanks Adrian
Hi Adrian,

ERm... no idea man! If that didn't work I don't know what next - there should logically be no difference between doing what you do by hand (i. e. the module stuff) and putting them in /etc/rc.local... are you sure that alsactl found the stored settings file? Use an absolute path, i. e. if your user home directory is "adrian" you will reference the stored settings file with

/usr/home/adrian/strored.settings.file

(This was a problem I ran into when I tried this the first time - I didn't specify the complete path)

Hope this helped a bit, at least!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound card Issues in Suse 9.3 with a ??Conexant?? Sound card in Gateway laptop hackerarchangel Linux - Hardware 3 12-31-2005 12:35 AM
sound card help ESS1978 Sound Card - maestro driver fatrandy13 Linux - Hardware 1 05-03-2005 02:43 AM
If you have a PCI sound card, should you disable the on-board sound card? jtp51 Linux - Newbie 1 10-06-2004 11:42 AM
keep onboard sound card enabled when a second sound card has been added ViralHex Linux - Hardware 0 06-08-2004 02:06 PM
Diabling onboard sound card and enabling pci slot sound card abhatia Linux - Hardware 4 01-12-2004 03:10 AM


All times are GMT -5. The time now is 04:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration