Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 09-05-2004, 11:22 AM   #1
LQ Newbie
Registered: Sep 2004
Location: Nottingham, England
Distribution: OpenSuse 10.2
Posts: 21

Rep: Reputation: 15
Question Sound card 'appears' to have been detected but still no sound


I have onboard sound (Via Technologies VT82C686 AC97)

I have ran alsaconf and found the sound card.

ran alsamixer to increase the volume

ran alsactl store to store the volume settings

checked the speakers work even!

Please put this Linux newbie out of his week long misery and tell him what he is missing!


Old 09-05-2004, 12:31 PM   #2
Andrew Benton
Senior Member
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
When you (as root) ran alsamixer did you unmute all the channels by typing m for each channel? Also, are you getting any error messages, or is it just simply that you don't get any sound when you run Xmms or whatever?
Old 09-07-2004, 02:06 AM   #3
LQ Newbie
Registered: Sep 2004
Location: Nottingham, England
Distribution: OpenSuse 10.2
Posts: 21

Original Poster
Rep: Reputation: 15
Thanks, I'll check the mute in alsamixer.
No i didn't get any error messages, just a distinct lack of sound!
Old 09-07-2004, 04:16 AM   #4
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 469Reputation: 469Reputation: 469Reputation: 469Reputation: 469
Check also the volume controls in your desktop - kmix and the suchlike. They are normally muted by default.
Old 09-07-2004, 05:08 AM   #5
LQ Newbie
Registered: Nov 2003
Location: netherlands
Distribution: suse & slackware
Posts: 1

Rep: Reputation: 0
do you have sound when you login at kde with root?
then the rights at your devices aren't correct.

try then:
chmod 0666 /dev/mixer
chmod 0666 /dev/dsp or /dev/audio

so you can use your sound card as user to.
Old 09-07-2004, 10:50 AM   #6
Registered: Aug 2004
Location: Kouvola, Finland
Distribution: SimplyMEPIS 2004.06
Posts: 34

Rep: Reputation: 15
I had the same problem, and the solution was that I had to disable IEC958 Capture Monitor from KMix (since I'm using KDE). Don't have a clue of why it blocked the sound but now I hear stuff through ALSA You just have to put it so that you can see all the options, I don't know what it is in the English KDE but I think something like 'more options'. Damnit, it took me two weeks to get the sounds working...
Old 09-07-2004, 04:34 PM   #7
LQ Newbie
Registered: Sep 2004
Location: Nottingham, England
Distribution: OpenSuse 10.2
Posts: 21

Original Poster
Rep: Reputation: 15
OK here I go.....

Checked Alsamixer and the channels were not muted, nor were they in the KDE Mixers.

I have the same problem as root as well.

Not entirely sure what "IEC958 Capture Monitor " is....but I muted the capture channel in KMix but that didn't help either!

So far I've spent over a week trying to get it working! It took a week just to get get the screen at the right refresh rate! (How was I to know Slackware 10 used Xorg not XFree86)

Maybe I'd have more luck trying to get the Modem and Network working
Old 09-07-2004, 05:06 PM   #8
Jay Smith
Registered: Aug 2004
Distribution: Mandrakelinux 10, KDE desktop
Posts: 38

Rep: Reputation: 15
I have the same problem and so does another guy. I checked troubleshooting and tried the commands, most i dont understand and i tried "aumix -q" it said command not found which is irritating.
Old 01-28-2006, 09:37 AM   #9
LQ Newbie
Registered: Jan 2006
Location: Semarang, Central Java, Indonesia
Distribution: Ubuntu 7.10 (Gutsy Gibbon)
Posts: 17

Rep: Reputation: 0
What is your ALSA version? Did you compile it from source? Did your sound card detected twice when you run alsaconf?


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
creative lab sound card not detected, no sound at all snakeo2 Fedora 6 08-21-2005 09:12 PM
No Mixer Detected, Sound Card IS detected, No Sound? one.sick.tzim Linux - Software 3 03-11-2005 11:54 PM
No sound, but sound card is detected =( DesyphER Linux - Newbie 2 12-19-2004 09:24 PM
no sound card detected with integrated sound jojotx0 Red Hat 3 11-09-2004 03:00 PM
Sound card not detected by Fedora Core 2 and no sound. jgr00 Fedora 4 08-19-2004 12:05 PM

All times are GMT -5. The time now is 09:15 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration