LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-04-2005, 11:23 AM   #1
sgold7878
LQ Newbie
 
Registered: Oct 2004
Posts: 8

Rep: Reputation: 0
sound but no picture with .avi files


hey guys, ive recently installed suse 9.3 on my computer, and i dled something that id really love to watch, but its in .avi format. when i click it, i can hear the sound but all i see is a black screen.
thanks in advance for your help
 
Old 07-04-2005, 02:35 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
care to actaully tell us what app this is???
 
Old 07-04-2005, 06:18 PM   #3
RockmanExe
Member
 
Registered: Aug 2003
Distribution: Mandriva, Slackware
Posts: 265

Rep: Reputation: 30
Also, is it a regular avi file of is it a divx avi? if that's the case, you'll need aditional codecs to watch it properly
 
Old 07-04-2005, 11:09 PM   #4
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
you probably need the w32codecs. Or, from the Mplayer homepage (where they came from).
 
Old 07-05-2005, 07:21 AM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
avi is not a format, it's a container. the "format" of the video would be divx, mpeg2 etc...
 
Old 07-05-2005, 01:34 PM   #6
sgold7878
LQ Newbie
 
Registered: Oct 2004
Posts: 8

Original Poster
Rep: Reputation: 0
ive tried with a bunch of different apps such as totem xine noatun and kaffiene
with all of them i just get a black screen, but when i try to play it with xine it says:
the stream '/home/gold/Family.Guy.avi' use an unsupported codec :
Video Codec: XVID format (XVID)
start playback anyway?
if i click yes i just get sound and the black screen.
i installed the xvid codec, but that hasnt changed anything.
how do i find out what format or other information about the file? id give better descriptions but i dont even know what is important or how to access the information
thanks
 
Old 07-05-2005, 06:07 PM   #7
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Again, get the w32codecs from the mplayer home page and follow the instructions to install them. Then try again.
 
Old 07-06-2005, 12:48 PM   #8
sgold7878
LQ Newbie
 
Registered: Oct 2004
Posts: 8

Original Poster
Rep: Reputation: 0
hey guys thanks for the help ive got the files playing now, but can somebody tell me how to make mplayer run with its gui, it only has command line right now
thanks
 
Old 07-07-2005, 03:11 PM   #9
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Try gmplayer (it should have come with mplayer, I think)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xawtv has picture but no sound FreakWent Mandriva 9 04-26-2007 08:09 AM
Doom 3 - No Picture, But Sound BarfBag Linux - Games 2 09-02-2005 07:46 PM
change uploaded files from filename.avi to filename.avi.html like www.rapidshare.de latheesan Linux - Newbie 3 06-16-2005 04:33 AM
avi files... audibel Linux - Software 1 04-03-2005 11:56 PM
problems with JPG-picture files rappe Linux - Networking 1 10-22-2003 07:50 AM


All times are GMT -5. The time now is 01:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration