LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-28-2012, 04:59 AM   #1
werner291
Member
 
Registered: Feb 2012
Distribution: Debian (Ans soon Ubuntu and Android)
Posts: 48

Rep: Reputation: Disabled
Sound broken


Hello, I believe I messed up my sound settings.

When I log in to my account, there is no sound at all, although the login screen and my other test account do have sound.

Giving these commands fixes the problem for the current session:
pulseaudio --kill
pulseaudio --start

But the next session is broken again and I have to give the two commands again if I want sound.

My system uses Debian Squeese with gnome 2.
 
Old 10-28-2012, 03:43 PM   #2
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,387
Blog Entries: 6

Rep: Reputation: Disabled
Hi:

I'm not the sound expert but it might just be that some of the things in your alsa mixer are muted-

Open the terminal and type:
Code:
alsamixer
The window will open and you'll see a black background with columns. At the bottom of each column you'll see the sound either muted or not muted (oo) this is not muted (mm) this is muted. Try muting and un-muting each and raise the volume up on each column.
http://linux.die.net/man/1/alsamixer
This is the video that I followed. After I closed the terminal I had sound.
http://www.youtube.com/watch?v=wWmXG-e6yzI

Hope this helps
 
Old 10-29-2012, 06:41 AM   #3
werner291
Member
 
Registered: Feb 2012
Distribution: Debian (Ans soon Ubuntu and Android)
Posts: 48

Original Poster
Rep: Reputation: Disabled
Nope, sorry, I checked it, and nothing was muted.

I really wonder what the problem could be. As far as I can remember, this started after touching the gnome sound settings, maybe a bug in the config dialog?
Is there maybe a way to completely reset all sound settings to default?

This is my sound card: lspci | grep audio
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)

Could it be a problem with the sound card, and that those two pulseaudio commands switch the sound from the hardware card to a virtual sound card?

Last edited by werner291; 10-29-2012 at 06:44 AM.
 
Old 10-29-2012, 06:48 AM   #4
cascade9
Senior Member
 
Registered: Mar 2011
Location: Brisneyland
Distribution: Debian, aptosid
Posts: 3,718

Rep: Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906
Squeeze uses alsa by default. Why are you running pulseaudio?
 
Old 10-30-2012, 02:12 AM   #5
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,387
Blog Entries: 6

Rep: Reputation: Disabled
Since you are running pulseaudio I suspect that it could be causing conflict with alsa.

Afterall Cascade said; "Squeeze uses alsa by default"
 
Old 10-30-2012, 04:14 AM   #6
werner291
Member
 
Registered: Feb 2012
Distribution: Debian (Ans soon Ubuntu and Android)
Posts: 48

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by cascade9 View Post
Squeeze uses alsa by default. Why are you running pulseaudio?
I'm a total sound noob. After the sound stopped working, I just tried different commands and these two turned the sound back on.

What is pulseaudio anyway? Does it play the same role as ALSA?

I noticed these two commands in the commands ran after login: "start-pulseaudio-kde" (I'm using gnome) and "start-pulseaudio-x11" (why start it twice?).

I'll throw them out and see what happens.

EDIT:
The "start-pulseaudio-x11" disappeared by itself, and throwing out the kde one didn't do anything.

Is pulseaudio supposed to be in /etc/init.d ?

Last edited by werner291; 10-30-2012 at 04:20 AM.
 
Old 10-30-2012, 04:31 AM   #7
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,387
Blog Entries: 6

Rep: Reputation: Disabled
PulseAudio is a sound system for POSIX OSes, meaning that it is a proxy for your sound applications.
http://www.freedesktop.org/wiki/Software/PulseAudio
http://en.wikipedia.org/wiki/PulseAudio

I looked in /etc/initid and found my Alsa file so yes that would be the correct place for Pulseaudio if it's on your OS-

Do you now have sound?
 
Old 10-30-2012, 04:40 AM   #8
werner291
Member
 
Registered: Feb 2012
Distribution: Debian (Ans soon Ubuntu and Android)
Posts: 48

Original Poster
Rep: Reputation: Disabled
No... still no sound, except once again of I run "pulseaudio --kill" and "pulseaudio --start"

A Ubuntu help page (Yes, I'm on Debian) suggested I should try this command to test the sound. It didn't work before the two commands, it did after, but maybe the terminal output is interesting?

werner@WernerPC:~$ aplay /usr/share/sounds/alsa/Front_Center.wav
ALSA lib pcm_dmix.c:1018snd_pcm_dmix_open) unable to open slave aplay: main:654: audio open error: Apparaat of hulpbron is bezig

Could anyone tell me, if thei're running Debian with Gnome (or something similar) which audio-related commands there are in the commands ran at login?

EDIT:
I Just noticed that my other test user has a completely different sound config dialog. I get some strange "Intel ICH5 mixer" while the test user gets the default gnome sound configuration screen.

Last edited by werner291; 10-30-2012 at 04:48 AM.
 
Old 10-30-2012, 04:51 AM   #9
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,387
Blog Entries: 6

Rep: Reputation: Disabled
Running this command will show which sound card you have:
Code:
lspci -v
Once you know the card # and manufacturer you can look for a driver for your sound card.
I'm starting to wonder that your card just might need a driver.

I'm not sure which command you would use for audio at login.

This is a Debian Wiki page for help with sound:
http://wiki.debian.org/SoundFAQ

Last edited by Ztcoracat; 10-30-2012 at 04:52 AM.
 
Old 10-30-2012, 05:00 AM   #10
cascade9
Senior Member
 
Registered: Mar 2011
Location: Brisneyland
Distribution: Debian, aptosid
Posts: 3,718

Rep: Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906
Quote:
Originally Posted by werner291 View Post
A Ubuntu help page (Yes, I'm on Debian) suggested I should try this command to test the sound. It didn't work before the two commands, it did after, but maybe the terminal output is interesting?
Not a good idea to use ubuntu commands with debian. It worked, this time, though I have no idea why. Sometimes trying ubuntu commands with debian can break your system.

Start with the debian wiki-

http://wiki.debian.org/ALSA

Try chaging to root (su) then run this command-

alsactl init
 
Old 10-30-2012, 05:08 AM   #11
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,387
Blog Entries: 6

Rep: Reputation: Disabled
werner291:

Cascade9 has always given me wise counsel so I would run what he recommends.
Code:
alsactl init
As root
 
Old 10-30-2012, 06:15 AM   #12
werner291
Member
 
Registered: Feb 2012
Distribution: Debian (Ans soon Ubuntu and Android)
Posts: 48

Original Poster
Rep: Reputation: Disabled
"alsactl init" didn't fix the problem either.

Any ideas what those two commands "pulseaudio --kill" and "pulseaudio --start" might be doing? Could it be that the other user, who does have sound, uses some kind of virtual sound card and that my user is trying to use the hardware one? How do I check that?

Quote:
Not a good idea to use ubuntu commands with debian. It worked, this time, though I have no idea why. Sometimes trying ubuntu commands with debian can break your system.
It was only the "aplay" command that I tried from that page, and I wasn't logged in as root.

EDIT: I found the problem: My test user uses the onboard audio device, and my own account tries to use the PCI audio card!
REEDIT: No, there aren't two sound cards on my system, I mistook the onboard card for a seperate sound card.

How do I reconfigure my account to use the onboard device? (It isn't listed in alsamixer, but the BIOS says it's there.)

Last edited by werner291; 10-30-2012 at 11:30 AM.
 
Old 10-30-2012, 07:43 AM   #13
cascade9
Senior Member
 
Registered: Mar 2011
Location: Brisneyland
Distribution: Debian, aptosid
Posts: 3,718

Rep: Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906Reputation: 906
I have no idea what 'pulseaudio --XXXXXX' is doing on your system. As far as I know, it shouldnt do anything unless you have pulse installed.....

Quote:
Originally Posted by werner291 View Post
It was only the "aplay" command that I tried from that page, and I wasn't logged in as root.
I guessed that you must have got the pusleaudio command from some ubuntu site, or from previous experience with ubuntu.

Quote:
Originally Posted by werner291 View Post
EDIT: I found the problem: My test user uses the onboard audio device, and my own account tries to use the PCI audio card!
Errr.....if you have a soundcard, its well worth shutting off the onboard sound in your BIOS.

Besides the sound card being (in most cases) 'cleaner' than onboard sound, it also makes things easier with the mixer (if you only have one sound card, its normally used by defult) and should get you a tiny bit of resources back.

Quote:
Originally Posted by Ztcoracat View Post
Cascade9 has always given me wise counsel so I would run what he recommends.
Thansk fro the vote of confidence. I was actually hoping that werner291 would run lspc (with or without the -v switch). Its a handy copmmand in these sorts of situations.

Quote:
Originally Posted by werner291 View Post
How do I reconfigure my account to use the onboard device? (It isn't listed in alsamixer, but the BIOS says it's there.)
Hmmm....let me get this straight.

You've got your audio jacks hooked up to the onboard sound, when you login you get sounds, a 2nd account gets sound, but when you login to your account, you get no sounds at all?

That means to me that your onboard sound is working, and its something you have done that has killed the sound.
 
Old 10-30-2012, 11:47 AM   #14
werner291
Member
 
Registered: Feb 2012
Distribution: Debian (Ans soon Ubuntu and Android)
Posts: 48

Original Poster
Rep: Reputation: Disabled
This command did the trick: "apt-get remove pulseaudio".

I didn't try that at first since I totally do not remember at all installing pulseaudio,
so I supposed it was part of the operating system or a dependency of some package.

But now, nothing seems to be wrong anymore. Thanks a lot for your help.
 
Old 10-31-2012, 12:22 PM   #15
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,387
Blog Entries: 6

Rep: Reputation: Disabled
Your welcome Cascade-

So everything is ok now werner291?

You have sound?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound with a broken sound card Vinter Linux - Hardware 1 05-26-2012 09:42 PM
[SOLVED] How do I know if my sound card is broken? briandc Linux - Hardware 2 05-26-2012 11:46 AM
[SOLVED] Broken sound (only rattling sound) marian57 Linux - Software 1 08-24-2010 06:03 AM
[SOLVED] broken sound card darksaurian Linux - Hardware 4 06-07-2010 10:15 PM
KDE 3.2 - Sound Broken!! muzicman82 Linux - Hardware 4 02-16-2004 11:56 AM


All times are GMT -5. The time now is 04:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration