LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 11-29-2002, 06:38 PM   #1
notoneword
LQ Newbie
 
Registered: Oct 2002
Location: Twin Cities
Distribution: RedHat 7.3
Posts: 12

Rep: Reputation: 0
Sound Blaster LIve card on RedHat 8.0


I have a dual boot partition, and my sound card works fine for XP. But for RH 7.3 and the recently-upgraded-to 8.0, hte sound card doesnt work. Running sndconfig it seems to find it, anyway it brings up the right name for the driver - EMU10K1 - but I get no sound during the test.

Anybuddy have a good resource page for troubleshooting this, or setting it up correctly?
 
Old 11-29-2002, 08:01 PM   #2
KevinJ
Member
 
Registered: Feb 2001
Location: Colorado Springs, CO
Distribution: Redhat v8.0 (soon to be Fedora? or maybe I will just go back to Slackware)
Posts: 857

Rep: Reputation: 30
I don't have v8.0, but all versions of 6.x and 7.x have worked fine for me.

Try booting into runlevel 3, with no Xwindows running, and running sndconfig, then go back to runlevel 5.

-K.
 
Old 11-30-2002, 05:42 AM   #3
Amerist
Member
 
Registered: Apr 2002
Location: Germany
Distribution: RedHat & SuSE
Posts: 106

Rep: Reputation: 15
Re: Sound Blaster LIve card on RedHat 8.0

Quote:
Originally posted by notoneword
I have a dual boot partition, and my sound card works fine for XP. But for RH 7.3 and the recently-upgraded-to 8.0, hte sound card doesnt work. Running sndconfig it seems to find it, anyway it brings up the right name for the driver - EMU10K1 - but I get no sound during the test.

Anybuddy have a good resource page for troubleshooting this, or setting it up correctly?
I dual boot redhat 8 and XP and I use a Sound Blaster Live!. I can attest that it works great in this situation.

Your problem must be that the card is misconfigured somehow in redhat... If I go to "system settings -> Soundcard detection" I see that my soundcard is detected as:

Vendor: Creative Labs
Model: SB Live! EMU10k1
Module: EMU10k1

Clicking on the "test sound" button produces a sound of a concert guitar. It's a bit quiet so you may have to turn up your speakers to hear it.

You do have the option to do a fresh install of redhat 8 which should configure your sound card correctly (unless there is a more serious problem with your system i.e. crappy mobo.) . Maybe someone else has a less destructive suggestion, but if you have no data or settings to lose then this might be the easiest option.
 
Old 11-30-2002, 08:00 AM   #4
mhearn
Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
Make sure the volume (in Linux) is not set to zero, some drivers start the sound muted by default, I have no idea why
 
Old 11-30-2002, 10:04 AM   #5
notoneword
LQ Newbie
 
Registered: Oct 2002
Location: Twin Cities
Distribution: RedHat 7.3
Posts: 12

Original Poster
Rep: Reputation: 0
Soundcard detection brings up the same info as yours, but I never hear the test sound. I made sure the volume wasnt muted, or at zero.

I would rather not reinstall 8.0 clean, but may have to. What is "crappy mobo"??? The card does work fine for the windows partition.

Can anybuddy suggest a good resource for double-checking the configuration of a sound card? Is there a .conf file somewhere that I need to check?
 
Old 11-30-2002, 08:03 PM   #6
Amerist
Member
 
Registered: Apr 2002
Location: Germany
Distribution: RedHat & SuSE
Posts: 106

Rep: Reputation: 15
Quote:
Originally posted by notoneword
What is "crappy mobo"??? The card does work fine for the windows partition.
That would be a motherboard that doesn't do PCI to specification, or shares IRQs that should be dedicated to CPU tasks. In general the newer the motherboard the better. Each generation seems to have fixed oversights from the series before it.
 
Old 12-01-2002, 06:09 AM   #7
hammerstein02
LQ Newbie
 
Registered: Dec 2002
Location: Leeds, UK
Distribution: Redhat 8.0
Posts: 15

Rep: Reputation: 0
It does work...

Hey,
I just had the same problem as you.. I finally got it working. Firstly I opened a terminal (As root)...

modprobe emu10k1 (You might hear a click on your speakers)

cd /dev

ls -al ds*

This on my system returned

dsp
dsp0
dsp1
dsp2
dsp3
dsp4

dsp was linked to dsp0..

I then tried..

cat /dev/urandom > /dev/dsp1

(If this works.. there will be a lot of static)

Press CTRL+C to get out of it.

then type:

ln -sf /dev/dsp1 /dev/dsp

Then open up the soundcard detection and try playing the sound. If this doesn't work then the drivers aren't installed properly I would say. If you need some help, feel free to e-mail me.. I will see if I can help you out further.
 
Old 12-01-2002, 10:00 AM   #8
notoneword
LQ Newbie
 
Registered: Oct 2002
Location: Twin Cities
Distribution: RedHat 7.3
Posts: 12

Original Poster
Rep: Reputation: 0
Wow, maybe I have bigger problems than I thought. I got command not found when I tried to run modprobe. So I gave it an explicit path - i.e. /sbin/modprobe - and didnt get the click.

All I had in my /dev directory was dsp, dsp1 and dsp56.

I tried the 'cat /dev/urandom..' step but didnt get any static, created the link, but sndconfig had same results as before.

Cheers for the tips though!
 
Old 12-01-2002, 10:49 AM   #9
KevinJ
Member
 
Registered: Feb 2001
Location: Colorado Springs, CO
Distribution: Redhat v8.0 (soon to be Fedora? or maybe I will just go back to Slackware)
Posts: 857

Rep: Reputation: 30
dude... are you logged in as "root"?

-K.
 
Old 12-01-2002, 11:21 AM   #10
notoneword
LQ Newbie
 
Registered: Oct 2002
Location: Twin Cities
Distribution: RedHat 7.3
Posts: 12

Original Poster
Rep: Reputation: 0
dood, indeed I am...

for some reason, /sbin (where I found modprobe) was not in root's path.
 
Old 12-17-2002, 10:55 PM   #11
notoneword
LQ Newbie
 
Registered: Oct 2002
Location: Twin Cities
Distribution: RedHat 7.3
Posts: 12

Original Poster
Rep: Reputation: 0
Seems this is a problem with my Gateway box. Apparently the OEM card uses the same port(?) for analog and digitial sounds, which the linux driver does not support. So I get beeps (analog) when I get mail, but no tunes (digital). ::sigh::
 
Old 12-18-2002, 07:06 AM   #12
orakin
LQ Newbie
 
Registered: Dec 2002
Posts: 5

Rep: Reputation: 0
Bios Option May work

I went into the Bios and turned the option for Plug-N-Play OS to NO. Once I rebooted, then then Linux saw my card and ran beautifully.
 
Old 12-22-2002, 11:53 PM   #13
CrushGruve
LQ Newbie
 
Registered: Jun 2002
Posts: 14

Rep: Reputation: 0
im currently running redhat 8.0 and am also having the same problem. however i have found that when in root my sound works fine and also if i log into kde instead of gnome and then go to the kde control center<sound<sound server....and change a setting then hit aply i will hear all those little guitar sounds over and over and over again. then when i colse it will work fine..but when i restart same problem again and again....grrrrrr oh and im runnin and amd1.7 with a new asus board and a pci soundblaster 128 so its not old hardware......anyway i hope maybe someone has an idea....Cg
 
Old 12-23-2002, 12:24 AM   #14
CrushGruve
LQ Newbie
 
Registered: Jun 2002
Posts: 14

Rep: Reputation: 0
ok not sure if anyone cares anymore but i think i have cured atleast my own problem...lol well the current one atleast... i have been hackin away at this and i tried turning the arts sound server in kde control center to not start on start up and it seems to have cured the problem. just figured id post i hope it helps someone else...of to find my next challenge....Cg
 
Old 12-23-2002, 02:49 AM   #15
KnightAbel
Member
 
Registered: Sep 2002
Location: Kaysville, UT USA
Distribution: Red Hat Linux, Slackware
Posts: 242

Rep: Reputation: 30
Re: Bios Option May work

Quote:
Originally posted by orakin
I went into the Bios and turned the option for Plug-N-Play OS to NO. Once I rebooted, then then Linux saw my card and ran beautifully.
lol, too bad I didn't get here sooner, I would have suggested the same thing, that's what I had to do to get it to work on my box.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ALSA not working for Creative Sound Blaster Live 24 Bit sound card vishalsonu Linux - Hardware 7 08-20-2005 01:02 PM
Sound Blaster Live! Not working in Redhat 9 newjuan Linux - General 1 04-27-2004 01:10 PM
Sound Blaster Live on RedHat brentos Linux - Hardware 4 02-18-2004 06:12 PM
Problems with Sound Blaster live in redhat 9 i 8 piglet Linux - Software 5 05-06-2003 09:31 PM
Sound blaster Live config with onboard sound card HChan Linux - Hardware 1 04-30-2003 01:47 AM


All times are GMT -5. The time now is 05:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration