LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-12-2004, 09:32 AM   #1
wprauchholz
LQ Newbie
 
Registered: Oct 2004
Location: Madrid
Distribution: Suse 9.1 Professional
Posts: 24

Rep: Reputation: 15
Sound & Multimedia


I m running suse 9.1 professional. I have 2 small issues I cannot overcome: when I put a CD in the drive, the application KsCD starts inmediatly and in the display you see that is is really playing, but there is no tone! The 2nd question is that I need to test/calibrate the microphone. Is there a program in linux for that purpose?
 
Old 10-12-2004, 09:47 AM   #2
Linux24
Member
 
Registered: Aug 2004
Distribution: Mandrake 10.1
Posts: 204

Rep: Reputation: 30
Suse 9.1 Pro? What desktop are you running? KDE or Gnome?

Have you tried clicking on all the icons in the menu to see what each program does? One of them is a sound control panel.
 
Old 10-12-2004, 09:57 AM   #3
drowstar
Member
 
Registered: Apr 2004
Location: Germany
Distribution: Slackware, Gentoo, Fedora
Posts: 205

Rep: Reputation: 30
Hi wprauchholz,
if your sound works and the cd seems to play but produces no sound that's usually because there is no connection between the CD-drive and the sound card. If you have more than one drive, try putting the cd in the other.

Sorry, can't help you with the microphone issue. Try some apps from the multimedia part of your menu.

Good luck,
- drowstar
 
Old 10-12-2004, 10:21 AM   #4
wprauchholz
LQ Newbie
 
Registered: Oct 2004
Location: Madrid
Distribution: Suse 9.1 Professional
Posts: 24

Original Poster
Rep: Reputation: 15
KDE desktop, soundcard is a SB Live5.1 digital. The story concerning the micro is that I want to use my PC to make phone calls. I opurchase a headset and plugged it into SB5.1. Whilst I hear sound, I cannot get the micro working.
 
Old 10-12-2004, 10:23 AM   #5
wprauchholz
LQ Newbie
 
Registered: Oct 2004
Location: Madrid
Distribution: Suse 9.1 Professional
Posts: 24

Original Poster
Rep: Reputation: 15
I forgot, I configured the sound card and the value of "mic" is 83 (100 is max)
 
Old 10-12-2004, 10:31 AM   #6
Linux24
Member
 
Registered: Aug 2004
Distribution: Mandrake 10.1
Posts: 204

Rep: Reputation: 30
Quote:
Originally posted by wprauchholz
KDE desktop, soundcard is a SB Live5.1 digital. The story concerning the micro is that I want to use my PC to make phone calls. I opurchase a headset and plugged it into SB5.1. Whilst I hear sound, I cannot get the micro working.
Yeah, that is definitely not going to work.


A microphone headset like a customer service person wears is not going to work plugged into the stereo audio out port on the back of a soundblaster sound card.

Your headset needs a separate microphone jack from the headset in order to work, and should plug into two places. The sound card's output port for speakers cannot be used for input for a microphone.
 
Old 10-12-2004, 10:32 AM   #7
Linux24
Member
 
Registered: Aug 2004
Distribution: Mandrake 10.1
Posts: 204

Rep: Reputation: 30
Quote:
Originally posted by drowstar
Hi wprauchholz,
if your sound works and the cd seems to play but produces no sound that's usually because there is no connection between the CD-drive and the sound card. If you have more than one drive, try putting the cd in the other.

Hmmm... good point. Try opening up the box and see if you have connected the CD's little tiny analog output cable to the sound card's input. If not, CD's won't play - and your CD player is little more than a data reader/writer.

Can you play MP3's or other audio?
 
Old 10-12-2004, 11:05 AM   #8
wprauchholz
LQ Newbie
 
Registered: Oct 2004
Location: Madrid
Distribution: Suse 9.1 Professional
Posts: 24

Original Poster
Rep: Reputation: 15
KsCD, no sound

Sound works fine with files on the hard disk. I am going to open the box no to see whether the cable is plugged. Thanks Wolfgang
 
Old 10-12-2004, 11:07 AM   #9
wprauchholz
LQ Newbie
 
Registered: Oct 2004
Location: Madrid
Distribution: Suse 9.1 Professional
Posts: 24

Original Poster
Rep: Reputation: 15
Microphone

The headset has a separate microphone jack which is plugged into the correspondent input for the microphone as depicted in the user manual of the sound card. Wolfgang
 
Old 10-27-2004, 11:36 AM   #10
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
and it still won't work? hmm...I was planning to buy one of those headsets with small earphones and a small mic...but first I'd like to know if this issue is solved and how and why didn't the mic work I don't want to pay for a non-working device, no matter how much or little it costs..

are you surely unmuted and raised the volume of your microphone, with some mixer app? if you're unsure, there's a program called aumix for console.. (for X might be too?) it's super.
 
Old 10-27-2004, 12:13 PM   #11
wprauchholz
LQ Newbie
 
Registered: Oct 2004
Location: Madrid
Distribution: Suse 9.1 Professional
Posts: 24

Original Poster
Rep: Reputation: 15
No, still not working. everybody is teling me that it must work, so I do not loos hope, but.... I tried aumix too. Thanks for the idea
 
Old 10-29-2004, 04:48 PM   #12
pmbnl
LQ Newbie
 
Registered: Oct 2004
Posts: 1

Rep: Reputation: 0
Use the digital direct playback

I came to the forum looking for the same answer... but meanwhile I found a solution:

1. Just to be sure in kmix have the volume on :-)
2. Open KsCD. Stop the CD playing.
3. On KsCD go to extras -> Configure KsCD
4. On the third group of items: CD-ROM device check the box "USe direct digital playback"
5. Press OK (you probably should leave arts as the audio backend)...
6. Play the CD.

It looks like a work around but just was enough to have the CD sound.

Good Luck
 
Old 10-29-2004, 09:29 PM   #13
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 52
all of this might be also just the trials of trying to learn alsa
to say alsa is kind of cryptic is an understatement
and at least for me kmix or even alsamixerGUI DON"T actually work alsa correctly !
get used to the command "amixer"
alone it will show you all the settings
to use the microphone you need to enable "capture" with the command
amixer set Capture cap 8
(15 is max if you want)
and then to set the capture device to the Mic with
amixer set Mic cap
it might be also you need to
amixer set AC97 cap 100

for the analog cd out try
amixer set CD 31

hope this helps
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound card issue: nVIDIA Multimedia Audio Controller not supported Shadowy Linux - Hardware 6 03-05-2004 01:07 AM
kde-3.1.4 & artswrapper & no ac3-sound passtrough BlinkEye Linux - Software 0 12-05-2003 04:00 PM
xine1_rc2 & kxine source install problems in RH 9.0 & SB live found but no sound Dominik Linux - Software 2 12-02-2003 03:15 AM
Multimedia applications does not work/Sound is there mwj Linux - Hardware 0 09-26-2003 05:51 AM
Sound: How to use a multimedia monitor? Joe Soap Linux - Newbie 2 08-22-2003 01:56 AM


All times are GMT -5. The time now is 08:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration