LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-14-2003, 11:09 PM   #1
Ethos
LQ Newbie
 
Registered: Mar 2003
Location: U.S.A.
Distribution: Slackware 9
Posts: 21

Rep: Reputation: 15
Sound and drivers on Slackware 9


I'm running Slackware 9, using a VIA chipset for sound. When I do that thing that lists hardware, I can see the audio controllers as /dev/dsp and /dev/dsp1, but nothing in X seems to find them. (Nor can I cat /dev/urandom > /dev/dsp) I tried the ALSA drivers, but they were impossible to build. The makefiles that were generated simply did not work, even after following the directions that had been posted on their site. If anyone has suggestions, please let me know.

Last edited by Ethos; 05-15-2003 at 10:16 AM.
 
Old 05-15-2003, 10:05 AM   #2
Ethos
LQ Newbie
 
Registered: Mar 2003
Location: U.S.A.
Distribution: Slackware 9
Posts: 21

Original Poster
Rep: Reputation: 15
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233 AC97 Audio Controller (rev 50)
Subsystem: FIRST INTERNATIONAL Computer Inc: Unknown device 9012
Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Interrupt: pin C routed to IRQ 11
Region 0: I/O ports at ec00 [size=256]
Capabilities: [c0] Power Management version 2
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-


When I try to modprobe i810_audio (suggestion from another thread), I get an error about 'no such device', however modprobe ac97_codec does work, though I still have no sound.

Last edited by Ethos; 05-15-2003 at 10:15 AM.
 
Old 05-15-2003, 11:33 AM   #3
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
modprobe via82cxxx_audio

Or variations of that. Also, can you post up the error messages from ALSA when you try to build?
Also, I am not sure what page you were looking at for your sound card on ALSA, so here's the link I found for you on your card:
Via 8233

Cool
 
Old 05-15-2003, 12:28 PM   #4
Ethos
LQ Newbie
 
Registered: Mar 2003
Location: U.S.A.
Distribution: Slackware 9
Posts: 21

Original Poster
Rep: Reputation: 15
ALSA did build with the modified parameters, that modprobe brought up the same error about 'no such device'. ALSA built successfully, the install seemed to work, but I still have no sound.
 
Old 05-15-2003, 09:56 PM   #5
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Well...

In the alsa build instructions you should have seen something about ./snddevices That file exists in the alsa-driver directory. That creates the necessary devices that ALSA uses. However, you should also notice a section on changing ownership to them as well. If not, let me know and I'll be glad to copy and paste it here for you.

Cool
 
Old 05-15-2003, 11:26 PM   #6
Ethos
LQ Newbie
 
Registered: Mar 2003
Location: U.S.A.
Distribution: Slackware 9
Posts: 21

Original Poster
Rep: Reputation: 15
I did run the ./snddevices, and (as root) attempted to use sound with still no luck. I've no idea what else can be done.
 
Old 05-15-2003, 11:47 PM   #7
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Do you have your active kernel source at /usr/src/linux? To find out:
uname -r
Whatever kernel version that is, look at:
ls -l /usr/src
And notice a linux entry (if at all). Does it point to the same kernel that uname -r returns? If not, symlink it:
ln -sf /usr/src/linux-2.4.20 /usr/src/linux
Or whatever version you are using.
If nothing is there at all, then whatever uname -r returned should be downloaded from the www.kernel.org and unpacked in /usr/src and symlinked as shown above.

Also, you will need "sound" compiled as module. However, info on that is also included at the alsa site. (modinfo soundcore)

Cool
 
Old 05-16-2003, 09:07 AM   #8
Ethos
LQ Newbie
 
Registered: Mar 2003
Location: U.S.A.
Distribution: Slackware 9
Posts: 21

Original Poster
Rep: Reputation: 15
The soundcore module is running already, and uname -r returns '2.4.20' where my source directory is '/usr/src/linux-2.4.20'. If you wouldn't mind explaining, why would the source path be relevant to this?
 
Old 05-17-2003, 12:26 AM   #9
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
ALSA compiles against a running kernel. To do this, it uses info obtained from your current kernels config. It does this by looking at /usr/src/linux which (on a lot of systems) is symlinked to the running kernel's source.

Can you post the actual error you are getting, and at what time you are getting it (not time of day, but what you are doing when the error is spit out).

Cool
 
Old 05-17-2003, 10:26 AM   #10
Ethos
LQ Newbie
 
Registered: Mar 2003
Location: U.S.A.
Distribution: Slackware 9
Posts: 21

Original Poster
Rep: Reputation: 15
As far as I can tell, there are no more errors excepting the modprobe of via82cxxx_audio, which returns no such device. The ALSA driver has built for my card and installed fine, but sound is still not working.
 
Old 05-17-2003, 04:27 PM   #11
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Remove the c:
modprobe via82xxx_audio

Try variations of that:
via82xxxx_audio
via82cxxx
via82xxxx
via82xxx

And so on.

Cool
 
Old 05-17-2003, 05:24 PM   #12
Ethos
LQ Newbie
 
Registered: Mar 2003
Location: U.S.A.
Distribution: Slackware 9
Posts: 21

Original Poster
Rep: Reputation: 15
All right, I modprobe'd every via thing and still don't have working sound.
 
Old 05-17-2003, 08:58 PM   #13
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Ok, let me start from the top, and move down:

Here's what I'd do when configging sound:
(After making sure the permissions are all cool)
First: Try modprobing for my module. To find out which module that is, I will either look through /etc/rc.d/rc.modules or plug through a current kernel to the sound portion and read the help file there.

IF that doesn't work I'd move onto either 1: reconfig kernel to add support for that module, OR 2: install alsa.

Installing alsa is as straight forward as it comes. There is a page dedicated to MANY many sound cards out there, and I'd follow the step by step directions from them.

After that I've never had a soundcard not work. If I did, it's usually because I either missed a step in the alsa instructions, or I chose the wrong one for my soundcard.

How might I find out what soundcard I have? I look at lspci. It shows me in the multimedia section. At the very end, if I have nothing working, I will (and have only once) just go get a new soundcard. Obviously things aren't working too well with the one I have been trying. SB Live's work great. So that's what I got.

Anyway, hope that helps.

Cool
 
Old 05-17-2003, 09:01 PM   #14
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Just reading over another post on this, check your BIOS. In there you might have an option for your onboard soundcard. Either enable or disable, the opposite of what is happening right now.

Cool
 
Old 05-22-2003, 12:17 PM   #15
Mr.Scum
LQ Newbie
 
Registered: Jan 2003
Location: Singapore
Distribution: Red Hat 9
Posts: 14

Rep: Reputation: 0
Sorry for the late reply, just browsing through the posts.

I had the same problem with my Via AC97 with Red Hat 8, just could not get it working. Red Hat 9 picked it up straight away at the install, no prob!

May be worth trying if you're not fussy about the distro and are still having the problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
sound drivers toolapc22 Linux - Newbie 3 10-17-2005 08:17 PM
Proprietary nvidia drivers vs. generic intel sound and ethernet drivers vharishankar Linux - Hardware 2 02-22-2005 06:32 AM
Prowler Sound card drivers installed, but get sound errors? MDK9.2 RHLinuxGUY Mandriva 1 03-11-2004 10:26 PM
Can I load both oss (kernel sound drivers) and alsa in 2 sound cared system? cmisip Linux - General 0 04-12-2003 02:27 AM
Sound drivers jun Linux - General 2 10-23-2001 04:16 AM


All times are GMT -5. The time now is 12:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration