LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Sorry to disturb with mouse (http://www.linuxquestions.org/questions/linux-newbie-8/sorry-to-disturb-with-mouse-170871/)

abhijitpethkar 04-16-2004 07:33 AM

Sorry to disturb with mouse
 
I just want a small information about mouse and linux. Do the scrolling property of mouse work in linux? I hv got linux 7.2 (Enigma).

meldar 04-16-2004 07:42 AM

Yes, but you have to activate it manually. Open the file (as root) /etc/X11/XF86Config and skip to the section that looks like this:
Code:

Section "InputDevice"

# Identifier and driver

    Identifier  "Mouse1"
    Driver      "mouse"
    Option "Protocol"    "IMPS/2"
    Option "Device"      "/dev/usbmouse"

Append the line Option "ZAxisMapping" "4 5" in this section, and restart the X-Server (log out and in again).

BTW you are not using linux 7.2 but Red Hat Linux 7.2, a distribution of linux.

LinuxLala 04-16-2004 07:43 AM

You should have searched LQ before asking. This has been asked on numerous occasions and has been discussed to shreds. With that said, Yes it does.

Is your mouse ps2 or usb

if it is ps2 then all you need to do is

open up /etc/X11/XF86Config in any editor(vi etc)
move down to the section on mouse

Change the line
Option "Protocol" "PS/2"
to
Option "Protocol" "IMPS/2"

Also add the line
Option "ZAxisMapping" "4 5"

abhijitpethkar 04-17-2004 12:13 AM

Thanks Meldar and LinuxLala for posting, But I am not able to find the section "input Device".
There is a section "pointer"
protocol "PS/2"
device "/dev/psaux"
ZAxisMapping 4 5

I changed PS/2 to IMPS/2
still I do not find any change.

Can u help me out

LinuxLala 04-17-2004 10:00 AM

Yes the pointer section is the one i was talking about.

IMPS/2 is fine but you see the ZAxisMapping thing

First of all, there should be an Option before it. Next, it along with the values, 4 and 5 should be in quotes, like this
Option "ZAxisMapping" "4 5"

Make this change and then see.

And oh, you will need to restarrt the X server to get those changes to take effect. A simple logout into the command line and then again a startx :)


All times are GMT -5. The time now is 09:17 AM.