LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-26-2008, 12:57 AM   #1
xiongzhongkai
LQ Newbie
 
Registered: Aug 2008
Posts: 2

Rep: Reputation: 0
somebody can tell me why . tell me how i can slove this problem


arm-linux-gcc: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by arm-linux-gcc)
 
Old 08-26-2008, 02:02 AM   #2
ehawk
Senior Member
 
Registered: Jul 2003
Posts: 1,257

Rep: Reputation: 48
What linux distribution are you using? If you are Chinese, perhaps this page will help:

http://www.arm9bbs.com/archiver/tid-1787.html

http://www.100ask.net/showtopic-289.aspx
 
Old 08-26-2008, 02:36 AM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,825

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
and please do not double post
this is the same post that is in "Linux - Embedded"
 
Old 08-26-2008, 02:43 AM   #4
pinniped
Senior Member
 
Registered: May 2008
Location: planet earth
Distribution: Debian
Posts: 1,732

Rep: Reputation: 50
Quote:
Originally Posted by xiongzhongkai View Post
arm-linux-gcc: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by arm-linux-gcc)
That's easy - your linker is attempting to link to the i686 version of libc6; it can't possibly work. You need to set up your environment so that you use the correct compiler, linker, assembler and that they use the ARM libraries and not the libraries on the computer you are using to build.
 
Old 08-26-2008, 02:51 AM   #5
megerdin
Member
 
Registered: Jul 2007
Location: London
Distribution: FC11,FC10,FC7,FC4,Centos 5.1,Ubuntu,Mandrake Linux,puppy.LinuxMint.Opensuse
Posts: 181

Rep: Reputation: 31
install following library...
Quote:
yum install glibc

Last edited by megerdin; 08-26-2008 at 02:54 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to slove these questions badrat Linux - General 2 10-08-2006 01:04 AM
perl problem? apache problem? cgi problem? WorldBuilder Linux - Software 1 09-17-2003 08:45 PM


All times are GMT -5. The time now is 12:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration