LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-01-2009, 09:47 AM   #1
gitecravirs
Member
 
Registered: Mar 2009
Posts: 40

Rep: Reputation: 15
Lightbulb some problem with cacti graph


i have insatalled cacti-0.8.7d onto my ubuntu-8.04.i installed it in /opt/lampp/htdocs/ directory by using xampp (it comes with mysql,php,apache) installation method(go to site http://www.in2dwok.com/indawok/?page_id=18).but im getting empty rra file and also im getting following errors if i try to plot cacti graph----
[1]when i run php /opt/lampp/htdocs/cacti/poller.phpPHP then im getting----->
Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613/msql.so' - /usr/lib/php5/20060613/msql.so: cannot open shared object file: No such file or directory in Unknown on line 0
FATAL: Cannot connect to MySQL server on 'localhost'. Please make sure you have specified a valid MySQL database name in 'include/config.php'
[2]when i try to create graph by using cacti window (http://localhost/cacti)then im getting----->

RRDTool Command:
/usr/bin/rrdtool graph - \
--imgformat=PNG \
--start=-86400 \
--end=-300 \
--title="localhost - Traffic" \
--rigid \
--base=1000 \
--height=120 \
--width=500 \
--alt-autoscale-max \
--lower-limit=0 \
--vertical-label="bits per second" \
--slope-mode \
--font TITLE:12: \
--font AXIS:8: \
--font LEGEND:10: \
--font UNIT:8: \
CDEF:cdefa=a,8,* \
CDEF:cdefe=a,8,* \
AREA:cdefa#00CF00FF:"Inbound" \
GPRINT:cdefa:LAST:" Current\:%8.2lf %s" \
GPRINT:cdefa:AVERAGE:"Average\:%8.2lf %s" \
GPRINT:cdefa:MAX:"Maximum\:%8.2lf %s\n" \
LINE1:cdefe#002A97FF:"Outbound" \
GPRINT:cdefe:LAST:"Current\:%8.2lf %s" \
GPRINT:cdefe:AVERAGE:"Average\:%8.2lf %s" \
GPRINT:cdefe:MAX:"Maximum\:%8.2lf %s\n"

RRDTool Says:
ERROR: invalid rpn expression in: a,8,*
>>>> when i search on the net then i come to know that-- DEF or CDEF "a" does not exist, thus "a" is not a valid number or variable, thus the expression is invalid.
but the problem is if DEF or CDEF "a" does not exist then how to get them exist...
plz give me proper solution and it will be better if u provide me step by step method right from the 'adding of devices' to 'plotting of graph' in cacti.
thanks alot....
 
Old 05-01-2009, 10:10 AM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,926

Rep: Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690Reputation: 3690
Quote:
Originally Posted by gitecravirs View Post
i have insatalled cacti-0.8.7d onto my ubuntu-8.04.i installed it in /opt/lampp/htdocs/ directory by using xampp (it comes with mysql,php,apache) installation method(go to site http://www.in2dwok.com/indawok/?page_id=18).but im getting empty rra file and also im getting following errors if i try to plot cacti graph----
[1]when i run php /opt/lampp/htdocs/cacti/poller.phpPHP then im getting----->
Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613/msql.so' - /usr/lib/php5/20060613/msql.so: cannot open shared object file: No such file or directory in Unknown on line 0
FATAL: Cannot connect to MySQL server on 'localhost'. Please make sure you have specified a valid MySQL database name in 'include/config.php'
[2]when i try to create graph by using cacti window (http://localhost/cacti)then im getting----->

RRDTool Says:
ERROR: invalid rpn expression in: a,8,*
>>>> when i search on the net then i come to know that-- DEF or CDEF "a" does not exist, thus "a" is not a valid number or variable, thus the expression is invalid.
but the problem is if DEF or CDEF "a" does not exist then how to get them exist...
plz give me proper solution and it will be better if u provide me step by step method right from the 'adding of devices' to 'plotting of graph' in cacti.
thanks alot....
Does this question go along with the other Cacti/graphing questions you posted too??
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cacti graph not coming gitecravirs Linux - Newbie 5 05-01-2009 10:06 AM
Cacti installation on Debian Sarge: create cacti database error Yahweee Debian 2 08-26-2008 07:35 AM
cacti graph not showing jdpl Linux - Server 2 09-06-2007 03:18 AM
Debian : Cacti graph coming up as blue Yahweee Debian 0 03-06-2007 09:14 AM
Cacti problem #2 Braynid Linux - Newbie 2 10-05-2006 11:32 AM


All times are GMT -5. The time now is 04:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration