LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 04-06-2009, 02:27 AM   #16
ODJ
LQ Newbie
 
Registered: May 2007
Location: Brussels, Belgium
Distribution: Debian GNU/Linux
Posts: 11

Original Poster
Rep: Reputation: 0

repo, ifconfig gives
Code:
eth0      MTU:1500  

lo       MTU:16436
(not crazy about giving out private info, so i omitted the rest seeing you asked for the MTU. (lo = loopback))

Tried the fix from the other thread suggested by mrclisdue; woohoo!! Finally it works! Even hotmail and facebook! I'm spinning around in my chair with joy! :P Thanks to all who've helped! Seeing it was the fix suggested in the other thread, i can only assume it had to do with the ip4_window_scaling=0. Will see now if undoing my earlier actions have any effect, so my situation might be of help to anyone in the future with a similar problem.

(i now used the method of "echo 0 > /proc/sys/net/ipv4/tcp_window_scaling", so i'll probably have the same problem after a reboot..? Will see and report back on that)

The fix given in that thread:

Quote:
Originally Posted by hobbsc
Greetings, folks.

My name is Christopher M. Hobbs, I'm the Network Administrator for the City of Siloam Springs a member of the openSUSE Community and a member of the openSUSE-GNOME team.

The issue posted here is a known issue and has nothing to do with our webserver. The problem we're having is with our firewall and it has been on the table for some months now. The firewall will soon be replaced, so in order to fix things on your end (at least until we have a new firewall), you will need to adjust your TCP Window Scaling options.

In order to do this temporarily, you can issue the following command (as root):

sysctl -w net.ipv4.tcp_window_scaling=0

Should that command fail, give this one a shot:

echo 0 > /proc/sys/net/ipv4/tcp_window_scaling

To permanently disable TCP Window Scaling, issue the following command as root and reboot:

echo '"net.ipv4.tcp_window_scaling=0" >> sysctl.conf'

I'll personally write the original author of this post from my City account should he not return to this thread.

Thank you for your diligent efforts.
cmh
FYI: i have not installed nscd, so that played no role in fixing my problem.

Last edited by ODJ; 04-06-2009 at 02:47 AM.
 
Old 04-07-2009, 09:18 AM   #17
ODJ
LQ Newbie
 
Registered: May 2007
Location: Brussels, Belgium
Distribution: Debian GNU/Linux
Posts: 11

Original Poster
Rep: Reputation: 0
After reboot, i indeed have the same problem, so (for now or untill there's a fix) i'll disable it permanently..
 
Old 04-07-2009, 10:36 AM   #18
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Slackware 14.0
Posts: 8,464

Rep: Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877
You know this has to do with the firewall?
Perhaps you can talk with the IT people.

Last edited by repo; 04-07-2009 at 10:37 AM.
 
Old 04-08-2009, 01:55 PM   #19
ODJ
LQ Newbie
 
Registered: May 2007
Location: Brussels, Belgium
Distribution: Debian GNU/Linux
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by repo
You know this has to do with the firewall?
Perhaps you can talk with the IT people.
I did not know that, repo (haven't had time to dive deeper into it after the initial relief of finding a solution).

If it's too technical to get into here just say so, but how come something like that does affect Linux, but not Windows? And what setting should be changed in our firewall to solve this issue?

Last edited by ODJ; 04-09-2009 at 03:01 AM. Reason: you know why! ;)
 
Old 04-08-2009, 02:14 PM   #20
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Window Scaling is an automated function of the TCP protocol implemented in 1992... he should know about it..

This issue has been around for a while
http://lwn.net/Articles/92727/

Quote:
The TCP window field, however, is only 16 bits wide, allowing for a maximum window size of 64KB. The TCP designers must have thought that nobody would ever need a larger window than that. But 64KB is not even close to what is needed in many situations today. The solution to this problem is called "window scaling." It is not new; window scaling was codified in RFC 1323 back in 1992. It is also not complicated: a system wanting to use window scaling sets a TCP option containing an eight-bit scale factor. All window values used by that system thereafter should be left-shifted by that scale factor; a window scale of zero, thus, implies no scaling at all, while a scale factor of five implies that window sizes should be shifted five bits, or multiplied by 32. With this scheme, a 128KB window could be expressed by setting the scale factor to five and putting 4096 in the window field.

To keep from breaking TCP on systems which do not understand window scaling, the TCP option can only be provided in the initial SYN packet which initiates the connection, and scaling can only be used if the SYN+ACK packet sent in response also contains that option. The scale factor is thus set as part of the setup handshake, and cannot be changed thereafter.

The details are still being figured out, but it would appear that some routers on the net are rewriting the window scale TCP option on SYN packets as they pass through. In particular, they seem to be setting the scale factor to zero, but leaving the option in place. The receiving side sees the option, and responds with a window scale factor of its own. At this point, the initiating system believes that its scale factor has been accepted, and scales its windows accordingly. The other end, however, believes that the scale factor is zero. The result is a misunderstanding over the real size of the receive window, with the system behind the firewall believing it to be much smaller than it really is. If the expected scale factor (and thus the discrepancy) is large, the result is, at best, very slow communication. In many cases, the small window can cause no packets to be transmitted at all, breaking TCP between the two affected systems entirely.
 
Old 04-09-2009, 03:30 AM   #21
ODJ
LQ Newbie
 
Registered: May 2007
Location: Brussels, Belgium
Distribution: Debian GNU/Linux
Posts: 11

Original Poster
Rep: Reputation: 0
Thanks, farslayer. I've given this info to our IT dept. as a startingpoint.

I don't expect they'll do much with it (seeing Windows (and Mac, seemingly) is preconfigured for this and i'm the only one in the office on Linux).

Last edited by ODJ; 04-09-2009 at 03:31 AM.
 
Old 04-09-2009, 07:11 AM   #22
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
They may not be able to do anything on their side.. the link provided earlier by mrclisdue shows an issue with a firewall, that can't be fixed until the firewall vendor does something about it.. in the mean time disabling it on your box is the only recourse.

Best of luck !!
 
  


Reply

Tags
connection, iceweasel


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pages not loading, DSN problem? lcruz007 Linux - Networking 12 08-03-2008 03:41 PM
Firefox now iceweasel on Debian jstephens84 Debian 10 06-07-2007 11:03 AM
internet connecting but pages not loading jajabinks Linux - Networking 3 02-10-2007 11:42 AM
Problem loading web pages Tim60 Mandriva 2 02-02-2006 11:08 PM
slow loading pages kwickcut Mandriva 3 03-18-2005 10:42 PM


All times are GMT -5. The time now is 02:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration