LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 10-09-2004, 01:11 PM   #1
chongluo
Member
 
Registered: Mar 2004
Location: uk
Distribution: fedora2, slackware10
Posts: 54

Rep: Reputation: 15
some keys are not functinal on keyboard


I'm just installed slackware on my pc, and put it on the corner as a file server.
so I use ssh to get access to the linux box. Everything is working fine, apart from some keys are not functional in an editor, such as in vi, or vim, like the "delete" key, "backspace key", "up arrow" keys , etc. however it is producing working fin in the console.

any idea how to correct this problem, otherwise it is painful if I want to edit something in vi or vim
 
Old 10-09-2004, 05:45 PM   #2
timsoft
Member
 
Registered: Oct 2004
Location: scotland
Distribution: slackware 13.1,13.37,14.0,14.1 64 and 32bit and arm
Posts: 121

Rep: Reputation: 18
when you are logged in, check the term shell variable.
it is likely to be ascii or vt100. make sure your ssh/stelnet client is running the same emulation.
that may sort out the problem
 
Old 10-09-2004, 08:53 PM   #3
chongluo
Member
 
Registered: Mar 2004
Location: uk
Distribution: fedora2, slackware10
Posts: 54

Original Poster
Rep: Reputation: 15
can you tell me more in details, many thanks
 
Old 10-10-2004, 06:38 AM   #4
timsoft
Member
 
Registered: Oct 2004
Location: scotland
Distribution: slackware 13.1,13.37,14.0,14.1 64 and 32bit and arm
Posts: 121

Rep: Reputation: 18
when you are logged in to your file server, type
echo $TERM

that will show you the terminal that that session thinks is emulating.
if you want to set it to vt100 for your current session then you would type

TERM=vt100

if you use konsole on the client to access, go to settings - keyboard
and set it to the same value.
most client ssh/telnet programs, or shells which provide them will let you set up the terminal type.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Some keys in keyboard do NOT work bmccorm2 Linux - Newbie 1 11-08-2005 11:16 AM
Keyboard is swapping keys jamiem Linux - Newbie 7 06-23-2005 09:50 PM
Assigning keyboard shortcuts to keyboard keys the who Linux - Hardware 3 02-20-2004 10:36 PM
Keyboard Shortcut Keys Odd_Bloke Linux - Newbie 2 08-26-2003 10:44 PM
Bind keyboard keys DigitalTygrrr Linux - Hardware 1 07-24-2003 11:23 PM


All times are GMT -5. The time now is 06:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration