LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-08-2004, 01:22 AM   #1
colabus
Member
 
Registered: Mar 2004
Distribution: Debian Sarge, FC4
Posts: 100

Rep: Reputation: 15
Some help with LILO


Howdy, I just decided to install Debian to my mum's machine for a little messa round with lilo and partions. Anyhow I got it working fine but I wanted to make a few minor tweaks..

I'd like it to default to the Windows XP partitiion and no include the storage partition which hasn't got an OS to boot into anyway.

So I was messing around with /etc/lilo.conf and though I had it right.. I deleted the extra image text which pointed to the WinNT storage drive and named the remaining 2 partitions (Linux and Windows XP), and also made the Windows partition be the default to boot.

But I gave it a reboot and had the same thing come up as what came up before my tweaking. Then I tried lilo -C /etc/lilo.conf in hope that it might refresh or something but no luck.

What am I doing wrong?
 
Old 10-08-2004, 01:29 AM   #2
Malice132
Member
 
Registered: Sep 2004
Location: U.S.
Distribution: Mandrake 10.1
Posts: 41

Rep: Reputation: 15
After you change the lilo.conf, you have to run /sbin/lilo in order to actually apply the changes.

Check out this site for more about lilo.
http://www.control-escape.com/linux/lilo-cfg.html
 
Old 10-08-2004, 01:34 AM   #3
colabus
Member
 
Registered: Mar 2004
Distribution: Debian Sarge, FC4
Posts: 100

Original Poster
Rep: Reputation: 15
OK forget all that I worked it out.. liloconfig
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Switching from grub to lilo, messed up Lilo.conf, rescuing via Knoppix. SonicGT Debian 2 08-21-2005 02:15 PM
Upgraded kernel, lilo.conf, didn't run /sbin/lilo dtashima Linux - Newbie 4 10-18-2004 12:21 PM
Lilo lost, Install disk failing to restore Lilo on dual boot? Dobie Linux - Newbie 2 05-05-2004 06:00 PM
new kernel causes lilo crash; /sbin/lilo = Warning: device 0x0305 exceeds 1024 cylind dandysf Linux - Software 0 08-26-2003 05:50 PM
Made a bootdisk with RedHat 7.1 to boot: Gave me SYSLINUX, not LILO:Want to use LILO Colonel Panic Linux - Software 0 08-17-2001 07:21 PM


All times are GMT -5. The time now is 06:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration