LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-26-2009, 11:12 AM   #1
cynicalpsycho
Member
 
Registered: Mar 2009
Location: America
Distribution: Debian/Arch
Posts: 134

Rep: Reputation: 16
<SOLVED> Can't run firefox as a regular user.


---------------------Solution-------------------------------------
Code:
sudo chown -R cynicalpsycho /home/cynicalpsycho/.mozilla
I had failed to insure that /home/user/.mozilla owner was me instead of root, once I changed the owner of that directory, my firefox booted up without a problem.

-----------------------------------------------------------------------


what gives, i just setup a new arch system. if i need to run a program from the terminal ie. firefox, I've got to sudo or switch into root before I can run them... what's the problem here?

Last edited by cynicalpsycho; 12-26-2009 at 01:14 PM. Reason: problem was resolved.
 
Old 12-26-2009, 11:15 AM   #2
cynicalpsycho
Member
 
Registered: Mar 2009
Location: America
Distribution: Debian/Arch
Posts: 134

Original Poster
Rep: Reputation: 16
...eh, trying to change the permisions in /usr/bin
 
Old 12-26-2009, 11:15 AM   #3
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Rep: Reputation: 129Reputation: 129
Your groups maybe? What's the o/p of:

Quote:
groups $USER
ls -la ~/.mozilla
 
Old 12-26-2009, 11:22 AM   #4
dracofhc
Member
 
Registered: Dec 2005
Location: Kalamazoo, MI, US
Distribution: Gentoo
Posts: 44

Rep: Reputation: 16
Two options come to mind right off the bat. First, firefox isn't in your $PATH as regular user, second you don't have execute permissions on firefox.

Open up a terminal then:
Code:
$ su
# whereis firefox
This will tell you where the firefox binary is (in my case it's /usr/bin/firefox). Now ls -l on that path and check the permissions line to make sure that all users have execute permission. In my case:
Code:
# ls -l /usr/bin/firefox
 -rwxr-xr-x. 1 root root 4715 2009-12-16 11:25 /usr/bin/firefox
You need to make sure that the last three are set to r-x. If not, run:
Code:
# chmod 755 /usr/bin/firefox
Second theory is that it's not in your current path. Run:
Code:
echo $PATH
and check to make sure that the location (/usr/bin) is listed in that output. If not you need to add it: (as user)
Code:
$ PATH=/usr/bin/:$PATH
$ export PATH
Then you need to add those lines to the appropriate set up file (like ~/.profile) depending on your shell.
 
Old 12-26-2009, 11:30 AM   #5
dreamwalking
Member
 
Registered: Dec 2005
Distribution: Slackware 14
Posts: 106

Rep: Reputation: 30
What about the permissions in your /home/user/.mozilla/firefox?
 
1 members found this post helpful.
Old 12-26-2009, 11:32 AM   #6
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Quote:
Originally Posted by cynicalpsycho View Post
what gives, i just setup a new arch system. if i need to run a program from the terminal ie. firefox, I've got to sudo or switch into root before I can run them... what's the problem here?
A good start would be to post the command you use, and the error messages you receive.
 
Old 12-26-2009, 12:30 PM   #7
cynicalpsycho
Member
 
Registered: Mar 2009
Location: America
Distribution: Debian/Arch
Posts: 134

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by ~sHyLoCk~ View Post
Your groups maybe? What's the o/p of:
groups cynicalpsycho:
Code:
lp wheel video audio optical sorage power cynicalpscyho
ls -la ~/.mozilla
Code:
total 16
drwx------ 4 root        root
drwx------ 13 cynicalpsycho cyncalpsycho
drwx------ 3 root        root
 
Old 12-26-2009, 12:40 PM   #8
cynicalpsycho
Member
 
Registered: Mar 2009
Location: America
Distribution: Debian/Arch
Posts: 134

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by dracofhc View Post
Two options come to mind right off the bat. First, firefox isn't in your $PATH as regular user, second you don't have execute permissions on firefox.

Open up a terminal then:
Code:
$ su
# whereis firefox
This will tell you where the firefox binary is (in my case it's /usr/bin/firefox). Now ls -l on that path and check the permissions line to make sure that all users have execute permission. In my case:
Code:
# ls -l /usr/bin/firefox
 -rwxr-xr-x. 1 root root 4715 2009-12-16 11:25 /usr/bin/firefox
You need to make sure that the last three are set to r-x. If not, run:
Code:
# chmod 755 /usr/bin/firefox
Second theory is that it's not in your current path. Run:
Code:
echo $PATH
and check to make sure that the location (/usr/bin) is listed in that output. If not you need to add it: (as user)
Code:
$ PATH=/usr/bin/:$PATH
$ export PATH
Then you need to add those lines to the appropriate set up file (like ~/.profile) depending on your shell.
Hmmm, I tried both of your suggestions.
echo $PATH shows:
/bin:/usr/bin:/sbin...etc

and ls -l /usr/bin/firefox shows:
lrwx-rwx-rwx 1 root root 28 dec 16 07:21 /usr/bin/firefox -> /usr/lib/firefox-3.5/firefox
 
Old 12-26-2009, 12:45 PM   #9
cynicalpsycho
Member
 
Registered: Mar 2009
Location: America
Distribution: Debian/Arch
Posts: 134

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by repo View Post
A good start would be to post the command you use, and the error messages you receive.
When i type:
firefox &
in the terminal it outputs:
[1] 1703

and fails to do anything else.

It's obvously a permissions problem as I have no trouble loading it if I sudo first. I'm still just not sure where the problem is.
 
Old 12-26-2009, 12:49 PM   #10
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Quote:
When i type:
firefox &
in the terminal it outputs:
[1] 1703
try run
Code:
firefox
to see the errormessages
 
Old 12-26-2009, 12:49 PM   #11
cynicalpsycho
Member
 
Registered: Mar 2009
Location: America
Distribution: Debian/Arch
Posts: 134

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by dreamwalking View Post
What about the permissions in your /home/user/.mozilla/firefox?
well if you mean: /home/user/.mozilla/bin/firefox
I still show lrwx-rwx-rwx
 
Old 12-26-2009, 12:51 PM   #12
cynicalpsycho
Member
 
Registered: Mar 2009
Location: America
Distribution: Debian/Arch
Posts: 134

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by repo View Post
try run
Code:
firefox
to see the errormessages
there is no error message... it jus brings me back to my prompt as if it had executed the command.

Code:
[cynicalpsycho@keystone]$ firefox
[cynicalpsycho@keystone]$
 
Old 12-26-2009, 01:01 PM   #13
cynicalpsycho
Member
 
Registered: Mar 2009
Location: America
Distribution: Debian/Arch
Posts: 134

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by dreamwalking View Post
What about the permissions in your /home/user/.mozilla/firefox?
actually you got it i think...
the problem was thatI didn't own that file...lol...
so yeah I did a chown and it works fine now, thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I run Firefox as a different user? GuruPrasad Linux - Desktop 3 01-15-2007 09:38 AM
I can't run Firefox from my single user(only from a super user) nightrider Linux - Newbie 14 10-24-2006 09:35 PM
Cannot run call of duty as regular user aeruzcar Linux - Software 1 06-03-2005 08:23 AM
Suddenly can't run OpenOffice.org as regular user--or install for one jonr Linux - Software 2 05-20-2005 01:49 PM
The_Sims for Linux doesnt run in regular User, but in Root. Slackware issue. RHLinuxGUY Linux - Games 4 11-02-2004 10:35 PM


All times are GMT -5. The time now is 04:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration