LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-31-2005, 06:59 PM   #1
ivancauso
Member
 
Registered: Aug 2005
Location: Moscow
Distribution: Slackware 10.2
Posts: 33

Rep: Reputation: 15
Software installation problem (configure error)!?!


I am having trouble to install a program in my Mandriva 2005 LE (KDE). When I type ./configure I get this error message:

[root@ivan ctsim-4.4.1]# ./configure
checking whether to enable maintainer-specific portions of Makefiles... no
configure: error: cannot find install-sh or install.sh in . ./.. ./../..

Has anyone seen this before?! Any clues on what the problem might be?!
Thanks!
 
Old 08-31-2005, 07:02 PM   #2
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 58
what program? did you read the manual? do you have whatever prerequisites are necessary? can u find a package (.rpm) for the program so u can use your package manager to easily install/manage the software?
 
Old 08-31-2005, 07:13 PM   #3
ivancauso
Member
 
Registered: Aug 2005
Location: Moscow
Distribution: Slackware 10.2
Posts: 33

Original Poster
Rep: Reputation: 15
The program is called CTsim, its a computer tomography simulator (http://www.ctsim.org/download.html). I have read the manual, it says I need to have wxWindows toolkit, which I have downloaded. In the website they say the program has been tested with Debian Linux and Windows XP, both worked. It doesn't say anything about Mandrake... The manual doesn't have much instruction for installation. I downloaded the .rpm file of this program and when I try to install I get this message:

unable to register rpm file!

Thanks for helping!

Last edited by ivancauso; 08-31-2005 at 07:27 PM.
 
Old 09-01-2005, 12:59 PM   #4
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 58
hmm.. i just booted into linux and tried it and it (at least the configure) worked fine.
did you make sure you have all dependancies? also, check for a file: /usr/bin/ginstall, do you have it? or try typing 'man install' does something come up?
can you configure other programs from source?
 
Old 09-02-2005, 01:49 PM   #5
ivancauso
Member
 
Registered: Aug 2005
Location: Moscow
Distribution: Slackware 10.2
Posts: 33

Original Poster
Rep: Reputation: 15
I could not find this file "ginstall", at least not trough this path. When I type man install in the terminal program I get a list of commands and what they do. I think I have the dependancies, but not 100% sure... As with other programs I use to have similar problems before I installed some libraries, now it works fine. Only having trouble with this program... Someone in this forum told me before that this type of problems is only a Mandrake thing and that Slackware works fine with all programs. Is that right?
 
Old 09-03-2005, 06:25 PM   #6
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 58
not sure about that, im nowhere near a guru.
i dont think there would be a difference in compiliing from source, the same program, from distro to distro... compiling from source is universal in the way things are done.. more or less.
however, in this case, yes, it did work for me as i said.. thats probabaly because i have all the required dependancies, which came installed by default in my distro, and maybe not in mandriva.
read the readme file again it came with.. go through the list of dependancies and BE 100% sure you do have them all. if you do, then its obviously another odd problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
configure: error: installation or configuration problem: C++ compiler cannot create e abirami Linux - Software 28 01-23-2008 11:35 AM
Error message in ./configure during the installation of Rosegarden-4-1.0 King_Loz Linux - Software 5 10-11-2005 07:07 PM
software configure:3474: error: cannot run /bin/sh ./config.sub jialin Debian 0 10-01-2005 07:38 PM
configure: error: when trying to install / configure new software ? met tomfer007 Linux - Software 1 07-25-2004 03:52 PM
Software Installation - ./configure Help Luddite Linux - Newbie 0 11-21-2003 10:00 AM


All times are GMT -5. The time now is 01:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration