LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-23-2008, 05:08 AM   #1
morfeus80
Member
 
Registered: Mar 2006
Distribution: OpenSUSE 10.3
Posts: 38

Rep: Reputation: 15
Software installation


Hallo, I'm trying to install a program, but I have a problem:

in the readme file there is this instruction:

"Source the .OpenFOAM-1.4.1/bashrc file by adding the following line to the end of your $HOME/.bashrc file:
. $HOME/OpenFOAM/OpenFOAM-1.4.1/.OpenFOAM-1.4.1/bashrc
Then update the environment variables by sourcing the $HOME/.bashrc file by typing in the terminal:
. $HOME/.bashrc "

It's the first time I use Linux: what have I to do?
 
Old 01-23-2008, 05:44 AM   #2
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
.bashrc is a hidden file in your home directory. You can make it visible from your desktop menu bar. For example, Gnome has the option under "View".

Open the file and put the line in at the end.

Finally, you need to source the file. You can do that from the command line but simply logging out and back in works just as well.
 
Old 01-23-2008, 06:09 AM   #3
morfeus80
Member
 
Registered: Mar 2006
Distribution: OpenSUSE 10.3
Posts: 38

Original Poster
Rep: Reputation: 15
OK, I added the command line, but when I type $HOME/.bashrc in the shell, I have the following error:

bash: ./.bashrc: Permission denied

Why?

Furthermor have I to type at end of the file:
$HOME/OpenFOAM/OpenFOAM-1.4.1/.OpenFOAM-1.4.1/bashrc
or
. $HOME/OpenFOAM/OpenFOAM-1.4.1/.OpenFOAM-1.4.1/bashrc
as in the istructions?
 
Old 01-23-2008, 06:54 AM   #4
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
No, that's not right. Sourcing is really simple, you just enter this into your terminal:

source .bashrc

But you need to make sure that you are not working as root; if you do, you'll source the root's .bashrc instead of your own. That wouldn't break anything but neither would it help to get your application going.

As for the other question, I looked it up:
Quote:
Installation
After unpacking, the user should consult the $HOME/OpenFOAM/OpenFOAM-1.4.1/README file for installation instructions.

gcc installation
OpenFOAM should work with most recent system distributions of the gcc compiler so installation of a binary pack is optional. The binary pack was compiled using SuSE Linux version 10.1+ and is known to be incompatible with system utilities for earlier versions of SuSE Linux.
JAVA installation
JAVA is required to run the FoamX case manager only; if you donít use FoamX, you donít need JAVA. Recent releases of the Linux operating system should contain a version of JAVA that is compatible with FoamX. To use the JAVA supplied with the system, you need to set the $JAVA_HOME environment variable to the path of the installation, e.g. Ď/usrí. This is set in the $HOME/OpenFOAM/OpenFOAM-1.4.1/.bashrc (or .cshrc) file.
Hmm, that last part looks awfully confusing. Can you tell me whether there is a hidden bashrc or a cshrc file inside your extracted /openFoam/OpenFoam-1.4.1.?
 
Old 01-23-2008, 10:33 AM   #5
morfeus80
Member
 
Registered: Mar 2006
Distribution: OpenSUSE 10.3
Posts: 38

Original Poster
Rep: Reputation: 15
I solved the problem: i had to put the "." (dot) before the command lines!

Now I have another problem: the program says I don't have remote shell available and I need an ssh or rsh.
What have I to do?
 
Old 01-23-2008, 10:53 AM   #6
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
If neither is installed yet, install openssh-server/client and/or rsh. Just use Yast to search and install. Btw, rsh is less secure than ssh.
 
Old 01-23-2008, 11:57 AM   #7
morfeus80
Member
 
Registered: Mar 2006
Distribution: OpenSUSE 10.3
Posts: 38

Original Poster
Rep: Reputation: 15
I have both installed, but I have always that message! It says that they are not available and that telnet is not running!
 
Old 01-23-2008, 12:30 PM   #8
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Have you been able to take a look at Appendix A of the README yet? I'm not sure whether it isn't too much techno babble but it does explain what needs to be done. It would appear that you need rsh-server rather than telnet. Bear in mind that most Linux distributions do not automatically enable a service (such as ssh or rsh) after install - you need to do that yourself. That may explain why your application doesn't find ssh or rsh. And there is some configuration to do as well . As I haven't used Suse for quite a long time, you'd better post any questions on this subject in the Suse forum. Of course, you can also use google. It's often faster than waiting for an answer.

Last edited by jay73; 01-23-2008 at 12:31 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installation Software for Custom Developed Java/Perl Software donkey123 Linux - Software 0 06-15-2005 06:26 PM
software installation sanjay2004 Linux - Software 7 04-25-2005 08:18 AM
Software Installation magus1ghz Linux - Software 4 02-05-2004 07:53 PM
Software Installation Help!! Sabeer Linux - Software 3 10-07-2003 10:47 AM
Software installation; where has it gone? sealevel Mandriva 4 09-08-2003 10:25 PM


All times are GMT -5. The time now is 10:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration