LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-28-2009, 06:35 AM   #1
Raakh
Member
 
Registered: May 2007
Posts: 128

Rep: Reputation: 15
SMTP problem


OS=centOS Enterprise linux 5.x
Qmail


-bash-3.1# telnet localhost smtp
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 system1 - Welcome to Qmail ESMTP
ehlo host
250-system1 - Welcome to Qmail
250-STARTTLS
250-PIPELINING
250-8BITMIME
250-SIZE 20971520
250 AUTH LOGIN PLAIN CRAM-MD5
mail from: webmaster
250 ok
rcpt to: webmaster@domain.com
553 sorry, your envelope sender has been denied (#5.7.1)


JavaMail throwing the following error:
javax.mail.SendFailedException: Invalid Addresses; nested exception is: com.sun.mail.smtp.SMTPAddressFailedException: 553 sorry, that domain isn't in my list of allowed rcpthosts (#5.5.3 - chkuser)

Thanks & best regards
 
Old 03-28-2009, 09:10 AM   #2
Mogget
Member
 
Registered: Dec 2008
Location: Norway
Distribution: Debian
Posts: 43

Rep: Reputation: 15
I'm thinking you might have forgotten to remove the # infront of mynetworks_style for your host.

Choose host if you only want localhost to be able to connect. Also you could specify specific machines ip adresses that should be able to connect and use the relay function.

Anyway i think you should be able to telnet in and get it working by removing the hash in front of mynetworks_style of your choise asuming you have configured everything else correct.

Last edited by Mogget; 03-28-2009 at 09:13 AM.
 
Old 03-28-2009, 09:37 AM   #3
Raakh
Member
 
Registered: May 2007
Posts: 128

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Mogget View Post
I'm thinking you might have forgotten to remove the # infront of mynetworks_style for your host.

Choose host if you only want localhost to be able to connect. Also you could specify specific machines ip adresses that should be able to connect and use the relay function.

Anyway i think you should be able to telnet in and get it working by removing the hash in front of mynetworks_style of your choise asuming you have configured everything else correct.
Thanks for your reply

This is my /etc/tcprules.d/tcp.smtp
127.:allow,RELAYCLIENT="",DKSIGN="/var/qmail/control/domainkeys/%/private"
:allow,BADMIMETYPE="",BADLOADERTYPE="M",CHKUSER_RCPTLIMIT="50",CHKUSER_WRONGRCPTLIMIT="10",DKSIGN="/var/qmail/control/domainkeys/%/private"


I am not finding here any "mynetworks_style" words or I believe I not understand. can you please be more specific

Thanks again & best regards
 
Old 03-28-2009, 10:28 AM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,764

Rep: Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587Reputation: 1587
This is strange. The errors you get mean 2 different things:
Quote:
553 sorry, your envelope sender has been denied (#5.7.1)
This means that you have somehow blacklisted the sender address. Try to use webmaster@domain.com as the "mail from:" subject and see if it works. And better use "ehlo host.domain.com" instead of "ehlo host".
Also check for the existence of badmailfrom file and its contents just in case.
Quote:
553 sorry, that domain isn't in my list of allowed rcpthosts (#5.5.3 - chkuser)
That means that domain.com is not listed in rcpthosts file. I guess this is your local domain name you're trying to send mail.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PHP SMTP connection to gmail SMTP protocol violation ratcateme Programming 9 02-23-2009 03:58 AM
smtp auth with sendmail through smtp.sbcglobal.yahoo.com woodson2 Fedora 0 10-23-2008 02:55 PM
Binding SMTP service into IP tables, and redirecting SMTP to port 366 bamquest6 Linux - Software 1 09-24-2008 02:48 AM
smtp problem ttestty Fedora 1 09-20-2008 05:31 AM
SMTP problem pave Linux - Networking 3 10-13-2004 05:52 AM


All times are GMT -5. The time now is 04:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration