LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 11-19-2003, 10:37 PM   #1
pepino
LQ Newbie
 
Registered: Oct 2003
Posts: 7

Rep: Reputation: 0
SMBMOUNT problem


hey there !

got the following problem:

got a Red Hat 8 box and a win 2000 box in a home network. and when i try to mount a windows share the following error is displayed:

[root@night mnt]# smbmount //Eres/sonido /mnt/sonido
Password:
Anonymous login successful
3981: tree connect failed: ERRDOS - ERRnoaccess (Access denied.)
SMB connection failed


As you can see it says Anonymous login successful, so it is not a login problem...

Any suggestions?

thanks.
 
Old 01-27-2004, 08:58 PM   #2
pembo13
Member
 
Registered: May 2003
Location: Caribbean
Distribution: Fedora Core2
Posts: 403

Rep: Reputation: 30
shouldn't you be specifing a username?
 
Old 01-27-2004, 11:01 PM   #3
Netizen
Member
 
Registered: Sep 2003
Location: Texas
Distribution: Slackware and Ubuntu
Posts: 355

Rep: Reputation: 30
Re: SMBMOUNT problem

Quote:
Originally posted by pepino
As you can see it says Anonymous login successful, so it is not a login problem...
Actually it appears it is. What OS is the windows box running? Pembo13 is correct about a user name. You need an account on the windows box to use. Right now with the command as you typed it, using root, samba is attempting to access the windows share with an account named "root" on your windows box with the password you supplied. I'm going to guess you don't have a account called root on your windows box...

Netizen
 
Old 01-27-2004, 11:07 PM   #4
jeopardyracing
Member
 
Registered: Sep 2003
Posts: 175

Rep: Reputation: 30
Firewall?

Got the same message 1,000 times when I realized I needed to have the security level set to Medium, not High on my RH 9.0 machine
 
Old 01-28-2004, 01:40 AM   #5
Onemessedupjedi
Member
 
Registered: Sep 2003
Location: Oregon
Distribution: Slackware 9.1
Posts: 194

Rep: Reputation: 30
Quote:
Got the same message 1,000 times when I realized I needed to have the security level set to Medium, not High on my RH 9.0 machine
That is why I believe that geeks should never use an easy distro...there must have been a ton of other security features turned off that you never knew about when you only needed to maybe change a few lines of your smb.conf file.
 
Old 01-28-2004, 12:50 PM   #6
pembo13
Member
 
Registered: May 2003
Location: Caribbean
Distribution: Fedora Core2
Posts: 403

Rep: Reputation: 30
Well Onemessedupjedi,

I would have to disaggree with you. 12 months ago two things turned me to Linux....my hatred for Windows and RedHat 8. Since then I've gone from not knowing how to copy a file to recompiling my Kernel...all with lots of howto's of course..
 
Old 01-28-2004, 01:25 PM   #7
jeopardyracing
Member
 
Registered: Sep 2003
Posts: 175

Rep: Reputation: 30
Onemessedupjedi,

Let's try to remember we're all on the same side here. I run a Mac and my Linux Dell 99% of the time and we're all working toward the same goal. I've only run these Unix platforms for a couple of months, so I'm a newbie. Cut the newbies some slack or the community will never grow.
 
Old 01-29-2004, 01:45 PM   #8
Onemessedupjedi
Member
 
Registered: Sep 2003
Location: Oregon
Distribution: Slackware 9.1
Posts: 194

Rep: Reputation: 30
I give newbs slack, heck, I give them lycoris if they want it. I believe that ease of use is the only way linux will take control of the desktop market. I really only stated that geeks, the people who arn't just using linux because microsoft sucks, shouldn't be using the easier distros.
I think this because I know that when I used mandrake I had no idea what was going on, but heck, I had samba working. Now I have went back to slackware and gotten a pocket reference to samba and have a much better home network setup and am working on a schema for a 30-40 person company network.

I think slackware just makes you dig into your system more. Redhat is just fine if you want something that just plain works though, it's all personal preference.
 
Old 01-29-2004, 03:21 PM   #9
jeopardyracing
Member
 
Registered: Sep 2003
Posts: 175

Rep: Reputation: 30
Fair enough. Can you help a RH using geek out, then, and help me learn how to get my Apple to mount my Dell (RH 9.0)'s shares with the firewall on 'medium' or 'high' then? Right now I have disable the firewall to get the samba shares mounted. I ONLY do this behind my Linksys ethernet firewall and only for a few minutes to synch my school files to the Mac as a backup. Then I have to open a terminal, su, turn off Samba and enable the firewall again in order to feel secure. This all might be overkill given that I'm behind the Linksys but I'm paranoid. So what ports do I need to open with the firewall up in order for SAMBA to hear the Mac calling? I tried a few ports using a shell script like

/sbin/iptables -A INPUT -p udp --dport 67 -j ACCEPT

trying various ports but have had no luck. Any ideas?
 
Old 02-02-2004, 05:11 PM   #10
andrewstr
Member
 
Registered: Oct 2003
Location: WA--USA
Distribution: Red Hat 9, Suse 10.2
Posts: 144

Rep: Reputation: 15
Try this: http://info.ccone.at/INFO/Mail-Archi.../msg00317.html
 
Old 02-04-2004, 08:35 PM   #11
Onemessedupjedi
Member
 
Registered: Sep 2003
Location: Oregon
Distribution: Slackware 9.1
Posts: 194

Rep: Reputation: 30
I assume you have it working after he posted that link so I have one thing to say..
Pepino13: Ever get it to work? you should really post back results bad or good for future searches.
 
Old 02-04-2004, 09:11 PM   #12
jeopardyracing
Member
 
Registered: Sep 2003
Posts: 175

Rep: Reputation: 30
I haven't gotten my Linux Red Hat Dell to work as server with the firewall on yet. The iptables entries in the above link didn't work for me so I am still forced to turn off the firewall in order to get my Mac to mount the Linux Dell's shares. When I try to mount the Apple's SAMBA shares I can do it with the firewall on 'medium.'

NOTE: I'm not an idiot: I ONLY do this when I'm at home behind a Linksys firewall Router on my ETHERNET network. The only other machine on that network is my Mac. Because of a heavy classload I haven't been able to find the time to fix the issue. My work around is I have two shell scripts: one disables the firewall and turns on samba. The other turns the firewall back on and turns off SAMBA. This way I am only exposed when I move files. It's a pain and I want to find the answer but I don't have time right now.

I know I sound like a hack to the experienced users on this board but guess what: we need to get Linux to be easier to use than this if we are going to expand this community to the consumer XP and one of RH 9.0, and I run a Mac in OS X as well as Windows. And yet I can't get a handle on this problem. How much time will an 'average' user spend on issues like these before giving up? We'll never take down Windows untill we get some basic things to the point where they're easier than this.
 
Old 02-05-2004, 12:21 PM   #13
andrewstr
Member
 
Registered: Oct 2003
Location: WA--USA
Distribution: Red Hat 9, Suse 10.2
Posts: 144

Rep: Reputation: 15
jeopardyracing,

I too had trouble getting Samba to work on 2 Red Hat 9 machines. I used the info from the link I posted above but that didn't work for me either. After doing some more searching, I discovered another thread dealing with Samba and found out that it is important that the IPTable enteries be placed in a certain order. I don't really understand why but I followed the directions in this post (http://www.linuxquestions.org/questi...629#post354629) and it has worked fine ever since.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange problem with SMBMOUNT and LAN Browser 1kyle Linux - Software 0 07-14-2004 01:58 PM
I have no smbmount! Vincent_Vega Linux - Networking 4 03-15-2004 01:22 PM
Problem with smbmount running as root linxtc Linux - Networking 2 10-18-2003 05:52 PM
smbmount problem / question hildog Linux - Networking 8 10-12-2003 06:17 PM
smbmount etc GrayLOK Linux - Networking 5 07-21-2002 03:37 AM


All times are GMT -5. The time now is 02:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration