LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-10-2011, 06:36 AM   #1
SriniKlr
LQ Newbie
 
Registered: Dec 2010
Posts: 13

Rep: Reputation: 0
smb service start fails


hi,

I am using the FC 14. When I try to start the smb service it fails. Following is the output of the terminal:

[root@srini samba]# service smb start
Starting SMB services: [FAILED]

this is what I get in the /var/log/messages when smb service fails:

*************************************************
Jun 10 15:49:21 srini smbd[7712]: [2011/06/10 15:49:21.398660, 0] lib/messages_local.c:112(messaging_tdb_init)
Jun 10 15:49:21 srini smbd[7712]: ERROR: Failed to initialise messages database: Permission denied
Jun 10 15:49:21 srini smbd[7712]: [2011/06/10 15:49:21.400377, 0] lib/messages.c:204(messaging_init)
Jun 10 15:49:21 srini smbd[7712]: messaging_tdb_init failed: NT_STATUS_ACCESS_DENIED
Jun 10 15:49:21 srini smbd[7712]: [2011/06/10 15:49:21.400736, 0] smbd/server.c:67(smbd_messaging_context)
Jun 10 15:49:21 srini smbd[7712]: Could not init smbd messaging context.

***************************************************

I did the testparm on my smb.conf files, didn't notice any error.

Please help !!!
 
Old 06-10-2011, 06:55 AM   #2
divyashree
Senior Member
 
Registered: Apr 2007
Location: bbsr,orissa,India
Distribution: RHEL5 ,RHEL4,CENT OS5,FEDORA,UBUNTU
Posts: 1,362

Rep: Reputation: 135Reputation: 135
If you have selinux enabled, disable it try if it works.
 
1 members found this post helpful.
Old 06-10-2011, 07:55 AM   #3
SriniKlr
LQ Newbie
 
Registered: Dec 2010
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by divyashree View Post
If you have selinux enabled, disable it try if it works.
After disabling the Selinux it worked !!! thanks a lot for the reply.

I have other problem with the samba not sure I can continue here my apologies if it is a mistake

I get the following error when I try to get the list all the folder shared in my PC.

****************************************************
[root@srini srini]# smbclient -L 192.168.254.128
WARNING: The "share modes" option is deprecated
Enter srini's password:
session setup failed: NT_STATUS_LOGON_FAILURE
***************************************************

this is how my smb.conf looks like

smb.conf
*****************************************
; guest account = nobody
log file = /var/log/sambai/log.%m
lock directory = /var/lock/samba
share modes = yes
interfaces = 192.168.254.128/24
encrypt passwords = yes
smb passwd file = /etc/smbpasswd
workgroup = corpusinc.corp
netbios name = SCS-12

[homes]
comment = Home Directories
browseable = no
read only = no
create mode = 0750

[tmp]
comment = Temporary file space
path = /tmp
read only = no
public = yes

[public]
comment = Public Stuff
path = /home/srini/Vmtools
public = yes
writable = yes
printable = no
***********************************************

thanks in advance.
 
Old 06-10-2011, 11:12 PM   #4
divyashree
Senior Member
 
Registered: Apr 2007
Location: bbsr,orissa,India
Distribution: RHEL5 ,RHEL4,CENT OS5,FEDORA,UBUNTU
Posts: 1,362

Rep: Reputation: 135Reputation: 135
Quote:
Originally Posted by SriniKlr View Post
After disabling the Selinux it worked !!! thanks a lot for the reply.
It worked, but its not a god practice to run smb by disabling selinux. Get the selinux contexts of samba and try to enable those.
 
Old 06-10-2011, 11:49 PM   #5
divyashree
Senior Member
 
Registered: Apr 2007
Location: bbsr,orissa,India
Distribution: RHEL5 ,RHEL4,CENT OS5,FEDORA,UBUNTU
Posts: 1,362

Rep: Reputation: 135Reputation: 135
Quote:
Originally Posted by SriniKlr View Post
After disabling the Selinux it worked !!! thanks a lot for the reply.

I have other problem with the samba not sure I can continue here my apologies if it is a mistake

I get the following error when I try to get the list all the folder shared in my PC.

****************************************************
[root@srini srini]# smbclient -L 192.168.254.128
WARNING: The "share modes" option is deprecated
Enter srini's password:
session setup failed: NT_STATUS_LOGON_FAILURE
***************************************************

this is how my smb.conf looks like

smb.conf
*****************************************
; guest account = nobody
log file = /var/log/sambai/log.%m
lock directory = /var/lock/samba
share modes = yes
interfaces = 192.168.254.128/24
encrypt passwords = yes
smb passwd file = /etc/smbpasswd
workgroup = corpusinc.corp
netbios name = SCS-12

[homes]
comment = Home Directories
browseable = no
read only = no
create mode = 0750

[tmp]
comment = Temporary file space
path = /tmp
read only = no
public = yes

[public]
comment = Public Stuff
path = /home/srini/Vmtools
public = yes
writable = yes
printable = no
***********************************************

thanks in advance.
There is no hosts allow or host deny option in your smb.conf file.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
when i try to start samba pdc's smb service nmbd failed to start . sandeepchau123 Linux - Newbie 2 10-20-2007 02:59 PM
I had start smb service but in chkconfig it closed boy_to_man Linux - Newbie 6 12-19-2006 10:41 AM
Smb service fails after an update with yum neddis Linux - Newbie 4 07-18-2006 04:59 PM
cups Printing Service Fails to Start Harry Seldon Linux - Software 2 09-01-2005 05:04 PM
NEWBIE: The boot is locked on 'start SMB service'. Please HELP ME! edika Linux - General 2 05-06-2004 03:26 AM


All times are GMT -5. The time now is 08:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration