LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-17-2006, 12:36 AM   #1
edavis6678
LQ Newbie
 
Registered: Oct 2006
Posts: 2

Rep: Reputation: 0
slow to boot, slow dns resolution after host name change FC5


I'm new to linux, and last week installed Fedora Core 5. (i've been very pleased, but having some troubles)

I had noticed some latency on my internet browsing, as well as some latency doing some updates through yum, but figured it was my ISP screwing up. (however I was corrected when I booted up a Windows machine and noticed no delays in DNS lookups and browsing net)

I Googl'd and found a bunch of articles about people complaining about the same issues with FedCore 5, (slow dns resolves, etc.), but the "fixes" I've found still havne't resulted in better results, in fact, it's made them worse. (now it's painfully to go on the Internet, opening a terminal session is slow, and even booted is drastically slower. (It really started acting up when I changed the hostname

My best guess is that I have some type of bad DNS configuration and me fiddling with too many settings at once. (this all seemed to happen when I changed my hostname)

Some of the things I did to try to speed up DNS times:

I did this:

edit the /etc/modprobe.conf file and add these 2 lines to the end.

alias net-pf-10 off
alias ipv6 off

and

Try adding these lines to your /ect/sysctl.conf

net.ipv4.tcp_moderate_rcvbuf=0
net.ipv4.tcp_default_win_scale=0
-----------------------

This did NOT resolve the issue.

My current settings are as follows:

resolve.conf

option timeout:1
; generated by /sbin/dhclient-script
search localdomain
nameserver 24.205.1.14
nameserver 66.215.64.14

sysctl.conf

# Kernel sysctl configuration file for Red Hat Linux
#
# For binary values, 0 is disabled, 1 is enabled. See sysctl(8) and
# sysctl.conf(5) for more details.

# Controls IP packet forwarding
net.ipv4.ip_forward = 0

# Controls source route verification
net.ipv4.conf.default.rp_filter = 1

# Do not accept source routing
net.ipv4.conf.default.accept_source_route = 0

# Controls the System Request debugging functionality of the kernel
kernel.sysrq = 0

# Controls whether core dumps will append the PID to the core filename.
# Useful for debugging multi-threaded applications.
kernel.core_uses_pid = 1

# Controls the use of TCP syncookies
net.ipv4.tcp_syncookies = 1

modprobe.conf

alias eth0 via-rhine
alias snd-card-0 snd-via82xx
options snd-card-0 index=0
options snd-via82xx index=0
remove snd-via82xx { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-via82xx

EDIT: It seems things are back to what they were originally (double checked all my work and rebooted a few times)- working better, but still slow on DNS resolution.

DNS does eventually resolve, just super slow. (nslookup is using the 1st DNS server)

Any other things I should check?

Last edited by edavis6678; 10-17-2006 at 01:46 AM.
 
Old 10-17-2006, 01:37 AM   #2
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
I'm not a network guru, but I found a similar problem long ago. After changing the hostname, boot was slow. In don't use dhcp, but in my case it was 'caused by' sendmail. I just 'disabled' it. I assume that it wanted to do a reverse lookup and could not find the hostname.

With the risk of saying something stupid:
Maybe you have to add something to resolve.conf to include /etc/hosts in the search
 
Old 10-17-2006, 12:14 PM   #3
edavis6678
LQ Newbie
 
Registered: Oct 2006
Posts: 2

Original Poster
Rep: Reputation: 0
>> Maybe you have to add something to resolve.conf to include /etc/hosts in the s

Thanks for the response. From what I understand, the resolv.conf file gets created on everyboot when using DHCP. I made it "read only", as suggested by another forum post, (and hard-coding in known dns servers), but this didn't help. It's not that things aren't resolved, it's slow resolving them.
 
Old 01-03-2007, 06:26 PM   #4
Slickwillie39
LQ Newbie
 
Registered: Jan 2007
Posts: 1

Rep: Reputation: 0
I am not sure if this is proper Linux networking, but I noticed a similar issue and I remarked out the search localdomain line from my resolv.conf and it seems to be working much faster on my machine. My resolv.conf looks like this now:

; generated by /sbin/dhclient-script
nameserver 192.168.15.1
; search localdomain

Regards,

William
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Comcast DNS very slow under FC5 dmcmahon Linux - Networking 1 09-04-2006 01:47 AM
Slow DNS search +firefox +FC5 Kosmaty Linux - Networking 8 06-02-2006 10:44 AM
Slow DNS Resolution intargc Slackware 1 01-12-2006 12:56 PM
Extremely Slow DNS Host Resolution longsword84 Linux - Networking 3 04-01-2005 04:19 PM
DNS resolution suddenly became slow.. please help Sheado Linux - Networking 3 11-14-2004 02:53 PM


All times are GMT -5. The time now is 12:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration