LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-22-2005, 01:18 AM   #1
badgerbox76
Member
 
Registered: Dec 2005
Location: USA
Distribution: Ubuntu, and other Live-CDs
Posts: 156

Rep: Reputation: 30
Thumbs down Slow performance!!! System using a lot of Physical Memory SLOW HELP!


I am wondering why Linux is so much slower then my windows box which runs off the same machine. Could some one tell me why Ubuntu is using so much Physical memory and so little swap. I am tired of the sad and sluggish performance, i am not even runing any damanding software.

here is some of my system stats and info which I pulled off of my phpsysinfo page:

Memory Usage
Type Percent Capacity Free Used Size

Physical Memory 90% 25.77 MB 225.01 MB 250.78 MB

Disk Swap 14% 630.57 MB 98.90 MB 729.47 MB


Hardware Information
Processors 1
Model Intel(R) Celeron(TM) CPU 1300MHz
Chip MHz 1297.32 MHz
Cache Size 256 KB
System Bogomips 2572.28
PCI Devices 0000:00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE
0000:00:07.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 AC97 Audio Controller
0000:00:08.0 VGA compatible controller: nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro]
0000:00:09.0 Communication controller: Conexant: Unknown device 2f14
0000:00:0a.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC
0000:00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+
IDE Devices hda: ST330621A (Capacity: 27.96 GB)
hdb: Maxtor 5T060H6 (Capacity: 57.27 GB)
hdc: CD-W58E
SCSI Devices HP photosmart 7200 (Direct-Access)
USB Devices Linux 2.6.12-10-386 uhci_hcd VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (#2) 0000:00:07.3
Linux 2.6.12-10-386 uhci_hcd VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller 0000:00:07.2
hp photosmart 7200 series CN38B2B65CI5

Network Usage
Device Received Sent Err/Drop
lo 5.50 MB 5.50 MB 0/0
eth0 0.00 KB 0.00 KB 0/0
ath0 196.54 MB 87.00 MB 230537/0
sit0 0.00 KB 0.00 KB 0/0

Mounted Filesystem
Type Partition Percent Capacity Used Size
ext3 /dev/hda1 10% 22.70 GB 2.75 GB 26.81 GB
tmpfs tmpfs 0% 125.39 MB 0.00 KB 125.39 MB
tmpfs tmpfs 10% 113.10 MB 12.29 MB 125.39 MB
Totals : 10% 22.93 GB 2.77 GB 27.06 GB

Last edited by badgerbox76; 12-22-2005 at 01:20 AM.
 
Old 12-22-2005, 02:41 AM   #2
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,604

Rep: Reputation: 47
Did you look at the command "top" to see which process is taking so much memory / ressources ?

I believe Linux generally use "little swap", so it is a normal behaviour.

You may want to try another desktop manager that uses less memory.

Can you clarify, is this the live distro you are talking about?
If yes, it is normal it is sluggish.
 
Old 12-22-2005, 11:51 AM   #3
sundialsvcs
Guru
 
Registered: Feb 2004
Location: SE Tennessee, USA
Distribution: Gentoo, LFS
Posts: 5,425

Rep: Reputation: 1159Reputation: 1159Reputation: 1159Reputation: 1159Reputation: 1159Reputation: 1159Reputation: 1159Reputation: 1159Reputation: 1159
No, "thrashing around at it," guessing at the problem and guessing at solutions, won't help.

First, double or triple the amount of RAM in the machine.

Then, as root do "/sbin/hdparm -Tt /dev/hda" and post the numbers here.

Also "/sbin/hdparm -I /dev/hda" and post here. I'm a gamblin' man that you don't have DMA turned on.
 
Old 12-22-2005, 02:23 PM   #4
badgerbox76
Member
 
Registered: Dec 2005
Location: USA
Distribution: Ubuntu, and other Live-CDs
Posts: 156

Original Poster
Rep: Reputation: 30
I am useing an installed verson of Ubuntu, and i cant see any real mem hogs so i just dont know why it is so slow

Here is what i got from hdparm command:

nos@ubuntu:~$ su
Password:
root@ubuntu:/home/nos# hdparm -Tt /dev/hda
/dev/hda:
Timing cached reads: 284 MB in 2.02 seconds = 140.89 MB/sec
Timing buffered disk reads: 30 MB in 3.17 seconds = 9.46 MB/sec
root@ubuntu:/home/nos#

Here is what i get from the top command:

top - 09:23:55 up 57 min, 3 users, load average: 1.63, 1.29, 1.21
Tasks: 95 total, 1 running, 94 sleeping, 0 stopped, 0 zombie
Cpu(s): 6.2% us, 0.7% sy, 0.0% ni, 92.8% id, 0.0% wa, 0.3% hi, 0.0% si
Mem: 256800k total, 235196k used, 21604k free, 6412k buffers
Swap: 746980k total, 81236k used, 665744k free, 95048k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
6430 root 15 0 75888 19m 6452 S 6.6 7.6 12:52.35 Xorg
11056 nos 15 0 39840 15m 9772 S 1.3 6.1 0:06.73 gnome-terminal
11149 root 16 0 2128 1104 844 R 0.6 0.4 0:01.62 top
7450 nos 15 0 21336 11m 8168 S 0.3 4.5 0:07.86 gnome-panel
7461 nos 15 0 19388 9812 7768 S 0.3 3.8 0:14.41 wnck-applet
11047 root 15 0 43972 29m 16m S 0.3 11.7 0:42.01 synaptic
1 root 16 0 1560 488 452 S 0.0 0.2 0:01.42 init
2 root 34 19 0 0 0 S 0.0 0.0 0:00.00 ksoftirqd/0
3 root 10 -5 0 0 0 S 0.0 0.0 0:00.25 events/0
4 root 13 -5 0 0 0 S 0.0 0.0 0:00.02 khelper
5 root 10 -5 0 0 0 S 0.0 0.0 0:00.00 kthread
7 root 20 -5 0 0 0 S 0.0 0.0 0:00.00 kacpid
70 root 10 -5 0 0 0 S 0.0 0.0 0:00.32 kblockd/0
100 root 14 -5 0 0 0 S 0.0 0.0 0:00.00 aio/0
99 root 15 0 0 0 0 S 0.0 0.0 0:01.10 kswapd0
685 root 15 0 0 0 0 S 0.0 0.0 0:00.00 kseriod
1870 root 15 0 0 0 0 S 0.0 0.0 0:00.00 khubd
2982 root 15 0 0 0 0 S 0.0 0.0 0:00.57 kjournald
3116 root 11 -4 1656 492 444 S 0.0 0.2 0:00.27 udevd
5205 root 18 0 0 0 0 S 0.0 0.0 0:00.00 kgameportd
5910 dhcp 15 0 2332 556 556 S 0.0 0.2 0:00.00 dhclient3
6261 root 16 0 1820 468 468 S 0.0 0.2 0:00.01 acpid
6293 root 15 0 1564 336 320 S 0.0 0.1 0:00.23 dd
6295 klog 15 0 2456 508 464 S 0.0 0.2 0:00.34 klogd
6308 messageb 16 0 2144 576 576 S 0.0 0.2 0:00.03 dbus-daemon
6321 hal 16 0 5060 2060 1524 S 0.0 0.8 0:00.56 hald
6326 hal 18 0 1864 408 408 S 0.0 0.2 0:00.00 hald-addon-acpi
6335 hal 16 0 1868 536 448 S 0.0 0.2 0:00.54 hald-addon-stor
6375 root 15 0 10604 2280 1956 S 0.0 0.9 0:00.00 gdm
6377 root 16 0 10932 2572 2268 S 0.0 1.0 0:00.18 gdm
6467 hplip 16 0 20808 1036 928 S 0.0 0.4 0:00.00 hpiod
 
Old 12-22-2005, 06:26 PM   #5
Gsidious
Member
 
Registered: Nov 2005
Location: Oregon
Distribution: SuSE
Posts: 59

Rep: Reputation: 16
I would have to agree with sundialsvcs, I doubt you have DMA enabled on the hard drive... the numbers you have posted above are poor. My laptop does way better,
Timing buffered disk reads: 82 MB in 3.07 seconds = 26.73 MB/sec
Timing cached reads: 1408 MB in 2.00 seconds = 703.96 MB/sec
and I would expect better numbers on a Desktop system unless it is getting old... I have a newer desktop system here that does 55.41MB/sec for buffered disk reads. Could you post the output of "hdparm /dev/hda", it should report drive settings, & "using_dma" should be "1 (on)" or you will be disapointed with the results. I wouldn't be worried about seeming high memory usage as Linux will use most of the available memory for caching and free it up as needed. More memory would almost surely help, but I would make sure DMA is enabled on the hard drive first.
 
Old 12-23-2005, 02:17 AM   #6
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,604

Rep: Reputation: 47
This was a good gamble. Yes HD performance look poor. Nothing odd from top.
There is plenty about hdparm, e.g. http://www.linux-1u.net/Disks/hdparm.txt
Try below for example
hdparm -c3 -d1 -X69 /dev/hda
 
Old 12-24-2005, 11:48 AM   #7
badgerbox76
Member
 
Registered: Dec 2005
Location: USA
Distribution: Ubuntu, and other Live-CDs
Posts: 156

Original Poster
Rep: Reputation: 30
Here are the read outs from the commands you guys gave me:
What els can i do to help make this thing faster?

nos@ubuntu:~$ su
Password:
root@ubuntu:/home/nos# hdparm /dev/hda

/dev/hda:
multcount = 0 (off)
IO_support = 1 (32-bit)
unmaskirq = 1 (on)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 256 (on)
geometry = 58168/16/63, sectors = 58633344, start = 0
root@ubuntu:/home/nos# hdparm -c3 -d1 -X69 /dev/hda

/dev/hda:
setting 32-bit IO_support flag to 3
setting using_dma to 1 (on)
setting xfermode to 69 (UltraDMA mode5)
IO_support = 3 (32-bit w/sync)
using_dma = 1 (on)
root@ubuntu:/home/nos# hdparm /dev/hda

/dev/hda:
multcount = 0 (off)
IO_support = 3 (32-bit w/sync)
unmaskirq = 1 (on)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 256 (on)
geometry = 58168/16/63, sectors = 58633344, start = 0
root@ubuntu:/home/nos#
 
Old 12-25-2005, 06:14 AM   #8
gunnix
Member
 
Registered: Apr 2004
Distribution: Arch, Debian and FreeBSD
Posts: 243

Rep: Reputation: 30
so dma is enabled.

I also find default Ubuntu with gnome very slow.
Ubuntu is not made to be a speed deamon but to be easy to use.

If you want something faster I suggest you try to remove gnome and install icewm, ede or even xfce. Icewm is fastest though (and I much prefer it ).

I wrote a little article about a lightweight linux desktop:
http://www.linuxquestions.org/questi...d.php?t=395426

Your computer hardware is fast, but default Ubuntu isn't. There's a project called Ubuntu Lite which tries to bring a fast and easy desktop.
http://www.ubuntulite.org/

And if you want to try out a linux distro which is meant to be fast, try arch linux:
http://www.archlinux.org

It boots double as fast as ubuntu. And runs faster. Plus I think it's really simple.

I hope this was of any help,
gunnix
 
Old 12-26-2005, 08:15 PM   #9
badgerbox76
Member
 
Registered: Dec 2005
Location: USA
Distribution: Ubuntu, and other Live-CDs
Posts: 156

Original Poster
Rep: Reputation: 30
HEY Thanks alot you where a big help I think i am going to try out Ubuntulite and see if i can get better performace

Last edited by badgerbox76; 12-26-2005 at 08:18 PM.
 
Old 12-27-2005, 01:42 AM   #10
nitinatindore
Member
 
Registered: Dec 2004
Location: India
Distribution: Mandrake, Mandriva, PclinuxOS
Posts: 114

Rep: Reputation: 15
You should try out Mandriva (formerly Mandrake), i bet it has best performance out of all possible Linuxez i have seen,I was facing similar problem with Redhat then.

One more tip: try using KDE, its cool,smart & faster ;-D
 
Old 12-29-2005, 12:10 PM   #11
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,604

Rep: Reputation: 47
add memory, stop not used services. And all the other suggestions before
 
Old 12-31-2005, 08:44 PM   #12
badgerbox76
Member
 
Registered: Dec 2005
Location: USA
Distribution: Ubuntu, and other Live-CDs
Posts: 156

Original Poster
Rep: Reputation: 30
Could so list some of the defult services that dont need to be used
 
Old 01-01-2006, 12:47 PM   #13
Haiyadragon
Member
 
Registered: Sep 2003
Location: Gorredijk, Netherlands
Distribution: Arch Linux
Posts: 400

Rep: Reputation: 30
Quote:
Originally Posted by sundialsvcs
First, double or triple the amount of RAM in the machine.
This really bothered me but I can't think of a way to respond to it... But I had to say something. Sorry. Anyway, poster sounds like a Windows user.
 
Old 01-01-2006, 01:15 PM   #14
davcefai
Member
 
Registered: Dec 2004
Location: Malta
Distribution: Debian Sid
Posts: 771

Rep: Reputation: 32
A few thoughts on this:

I've run Mandrake up to 10.1 quite happily on a 1000MHz celeron with 256MB so I cannot believe that RAM is an issue.

Possibly subjectively (no flames please) I think KDE is faster tham Gnome but not enough to merit the complaint.

90% memory usage is not in itself a problem. A lot of it is buffers. Run free and see what it says.

One possibility worth checking is the memory timings in CMOS setup. Although Windows is running OK the settings may be non-optimal and Linux is more aggresive towards hardware than Windows is. This comment can be valid for both too slow and too fast timings. I once had a situation (under Windows) where I set the timings too fast and the machine slowed down dramatically, probably because of missed accesses.
 
Old 01-01-2006, 01:40 PM   #15
V!NCENT
Member
 
Registered: Dec 2005
Location: The Netherlands
Distribution: Kubuntu 8.10 KDE4
Posts: 208

Rep: Reputation: 30
I have the same problem too. I am running Xardros (KDE 3.?). When doing absolutely nothing it consumes almost ALL memory (AMD athlon 2800, 1 gig mem). It claims to run on a p2 450mhz with 64mb mem, recommend.

How do I turn it on? I have read articles about doing it but I can't get it to work. Please explain it to me like I am your grandmother who wants to know how to send an email beacause I am still so newbish *arg!* :P
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 9.2 & SATA - Slow, Slow, Slow jess1975 Suse/Novell 6 01-28-2007 01:17 PM
System Using a lot of memory hamish Linux - Software 4 11-14-2004 05:20 AM
System uncleanly shut down, ran e2fsck, very slow start & slow desktop brakthepoet Linux - Newbie 1 07-02-2004 02:55 PM
Slow performance satinet Slackware 9 06-15-2004 05:54 PM
slow performance dominant Linux - Newbie 20 03-16-2004 10:56 AM


All times are GMT -5. The time now is 06:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration