LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-31-2000, 02:59 PM   #1
bfloeagle
Member
 
Registered: Jun 2000
Location: Upstate New York
Distribution: Ubuntu
Posts: 158

Rep: Reputation: 30
Question


When booting my machine, my nic for eth0 loads very slow. It eventually comes up (after 3 minutes) but it's a little annoying. If I remove the eth0 configuration from the network control panel in XWindows RedHat 6.2, and then add it using 'netconfig' from the prompt, it loads in a couple of seconds just like the other services. After a couple of reboots, it's back to being slow again. I have no idea as to why.

Couple of things that might (or might not) be helpful...

When I do the above, I have to manually change the nameservers back to what I need them to be to access the internet. If I change it using a text editor on the file 'resolv.conf', the above happens. A couple of boots and it will be slow again. If I do it in the network control panel of XWindows, it will be slow right away...

I used to have two nic's in my Linux box but I removed the second one to try and configure the first. Lilo does not try to bring up eth1 but for some reason, no matter how many times I remove the eth1 config in the GUI network control panel, eth1 remains. Does this matter?

One time I ran netconfig when the second nic card was not present and it sat at "Determining hostname and configuration" (I think...) for about the same time as it takes the eth0 to come up when Lilo boots. It did not do this when the card was present. Does this help?

The card is having no problems at all and is working perfectly for everything that I need it to do. I am just trying to learn how to tweak my linux box and it seems like a 486 66mhz with Windows and 8mbs of RAM on it every time I reboot. ;-)

While I am on a roll, one more question about the ethernet card settings. What is the file that you can modify to change the settings for eth0, eth1, etc... directly so I don't have to use the Xwindows network control panel?

Thanx for your help making this newbie a little bit better at using Linux!
 
Old 07-31-2000, 03:24 PM   #2
jeremy
root
 
Registered: Jun 2000
Distribution: Debian, Red Hat, Slackware, Fedora, Ubuntu
Posts: 11,956

Rep: Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108
Thumbs up

amiller,
Let me start this off by saying that I am glad to see that you are interested in learning how things work and not just relying on the GUI config tools.
Go into /etc/sysconfig/network-scripts and remove all references to eth1 (should be a file called ifcfg-eth1). Then open up ifcfg-eth0 and make sure all settings are correct. Finally open /etc/conf.modules and see if there is an alias setup for eth1 - If there is remove it.
 
Old 08-01-2000, 02:07 PM   #3
bfloeagle
Member
 
Registered: Jun 2000
Location: Upstate New York
Distribution: Ubuntu
Posts: 158

Original Poster
Rep: Reputation: 30
Talking That did it!

Thanx for the suggestions, Jeremy. I removed the configs and setup the nic card again. It loads up fine just like I wanted it to! Thanx for your help!
 
Old 08-08-2000, 02:56 PM   #4
bfloeagle
Member
 
Registered: Jun 2000
Location: Upstate New York
Distribution: Ubuntu
Posts: 158

Original Poster
Rep: Reputation: 30
Unhappy Spoke too soon...

Guess what???? It did it again... Three mins to bring up eth0 and now another three mins to bring up eth1!!!

I know what is causing this because I added a second eth card and the 'resolv.conf' file was reset by the 'netconfig' program. DNS addresses of an ISP cause the problem. Without them, it started working again.

The file lists the ip address of the eth0 (192.168.0.1) in the 'resolv.conf' file and both cards come up right away like I want them to. The problem is that now I cannot browse the internet (or ping for some reason???) without having to add the nameservers and removing them every time I connect and disconnect.

If I list my ISP's DNS addresses in 'resolv.conf' the cards load slower again but I can browse the internet (and ping places???).

(I thought the nameservers were only used for domain names and not ip addresses??????)

I can't figure out how to stop this!!! Is there a way I can work around this? Maybe fix it?

I would think there was a way to change the 'resolv.conf' file by adding a line to the connect script for ppp0 but I don't know how to do it and would like to try another way before looking into this. Or is this not possible???

Thanx again!
 
Old 08-08-2000, 03:18 PM   #5
jeremy
root
 
Registered: Jun 2000
Distribution: Debian, Red Hat, Slackware, Fedora, Ubuntu
Posts: 11,956

Rep: Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108
You should be able to put the nameservers in /etc/ppp/resolv.conf so they are only used when you are connected via ppp.
 
Old 08-17-2000, 01:43 PM   #6
bfloeagle
Member
 
Registered: Jun 2000
Location: Upstate New York
Distribution: Ubuntu
Posts: 158

Original Poster
Rep: Reputation: 30
Unhappy It's there but no luck.....

I have the 'resolv.conf' file in there with all the correct DNS addresses but I get a response saying "host not reachable." The original 'resolv.conf' in the etc directory only lists the ip address of the loopback device (127.0.0.1). Is it still using the original conf file? How do I make the ppp0 connection use the conf file in the ppp directory so my 2 nics operate normally?
 
Old 08-18-2000, 01:25 AM   #7
jeremy
root
 
Registered: Jun 2000
Distribution: Debian, Red Hat, Slackware, Fedora, Ubuntu
Posts: 11,956

Rep: Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108
amiller,
OK. Try this. (I have not used pppd in a long time, so bear with me). If these settings do not work please post the files in question. Note: I have not listed every line that should be in the files, just the relevant ones.

/etc/host.conf
order hosts,bind

/etc/hosts
127.0.0.1 localhost localhost.domain
your.ip your.host.name

Put your nameservers in /etc/resolv.conf. I have a feeling you may not have your ip/hostname in /etc/host (or bind is before hosts in /etc/host.conf) so the machine is hanging trying to lookup it's name from a server it cannot reach.




 
Old 08-18-2000, 03:45 PM   #8
bfloeagle
Member
 
Registered: Jun 2000
Location: Upstate New York
Distribution: Ubuntu
Posts: 158

Original Poster
Rep: Reputation: 30
Cool It's working again!

I checked the info you told me to and everything looks ok. I found another thing to try and so far it is working! ;-)
So far...

I was messing around in Linuxconf because I could not think of anything else to try and found a section on DNS. In there is an option that says something to the effect of "DNS is required for normal operation." I unchecked that and BINGO! Normal bootup even with the isp's DNS addresses in the resolv.conf file.

If anyone knows what file was modified by that little change I made, or if anyone has found a decent place to explain what Linuxconf actually does and what it modifies, please email me!

Thanx for helping this Linux Newbie!
 
Old 08-18-2000, 06:15 PM   #9
jeremy
root
 
Registered: Jun 2000
Distribution: Debian, Red Hat, Slackware, Fedora, Ubuntu
Posts: 11,956

Rep: Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108Reputation: 3108
hmm

The only change it appears to make is in a file called /etc/conf.linuxconf (which obviously is linuxconf specific). The weird part is that it updates the time stamp (put does not alter) /etc/resolv.conf (I tried checking/unchecking the box with local and non-local name servers). This is why I don't ever use linuxconf. Atleast it fixed the problem.
BTW the line that was changed was
[netclient]
DNSCONF.dnsneeded 0
 
Old 10-12-2004, 08:42 PM   #10
qUox
LQ Newbie
 
Registered: Oct 2004
Posts: 7

Rep: Reputation: 0
thx
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
slow boot when no ethernet connection hyperriven Mandriva 2 04-10-2005 10:05 PM
Ethernet card not working when '/etc/rc.d/init.d/network restart'. brynjarh Linux - Newbie 1 08-11-2004 01:17 PM
FC2 with grub boot/init very slow zipo13 Fedora 9 08-03-2004 02:15 PM
Ethernet card on laptop: I installed my D-Link ethernet card into Redhat 9, not detec brighamr Linux - Hardware 0 05-18-2004 01:33 AM
Ethernet connection running WAY slow XODeuce Linux - Networking 3 03-20-2004 12:29 PM


All times are GMT -5. The time now is 10:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration