LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-08-2003, 03:04 AM   #1
MG-Cloud
Member
 
Registered: Nov 2003
Distribution: Gentoo
Posts: 30

Rep: Reputation: 15
Slow DVD Playing, CD Burning - Cant enable DMA


Hi
I just installed Linux around Halloween, but I am trying my best to learn. However, I've run into a few problems that I couldn't fix by reading the documentation, and I was hoping that someone could give me a few pointers as to the correct course of action to take.

First, for DVD playing. I've installed mplayer, totem, and gxine, and they all are having problems playing DVDs. Mplayer just doesn't work - sometimes it'll play the movie trailer (quite smoothly actually, but without sound), and sometimes it won't play anything. Totem and Gxine both play the DVDs fine, but with a huge amount of skipped frames. I tried using hdparm -d1 /dev/hdd (my dvdrom drive), but it said:

Quote:
root@nebula dev # hdparm -d1 /dev/hdd

/dev/hdd:
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
using_dma = 0 (off)
Also, when I boot up, I receive an error about DMA on my hard drive. It tells me that DMA is not enabled on my hard drive, and that the fsck process would be slow. I've done some reading, and I've found out that if dma can't be enabled, then there is likely a problem with kernel settings. I've checked them over, and I can't seem to find anything wrong. Here are the settings I'm using: (this is kernel 2.6.0-test9-mm2)

Quote:
<*> ATA/ATAPI/MFM/RLL support
<*> Enhanced IDE/MFM/RLL disk/cdrom/tape/floppy support
--- Please see Documentation/ide.txt for help/info on IDE drives
[ ] Use old disk-only driver on primary interface
<*> Include IDE/ATA-2 DISK support
[ ] Use multi-mode by default
[ ] Auto-Geometry Resizing support
<*> Include IDE/ATAPI CDROM support
< > Include IDE/ATAPI TAPE support (EXPERIMENTAL)
<*> Include IDE/ATAPI FLOPPY support
<*> SCSI emulation support
[ ] IDE Taskfile Access[*] IDE Taskfile IO (EXPERIMENTAL)
--- IDE chipset support/bugfixes
[ ] CMD640 chipset bugfix/support[*] PNP EIDE support[*] PCI IDE chipset support[*] Sharing PCI IDE interrupts support
[ ] Boot off-board chipsets first support[*] Generic PCI IDE Chipset Support
< > OPTi 82C621 chipset enhanced support (EXPERIMENTAL)
< > RZ1000 chipset bugfix/support[*] Generic PCI bus-master DMA support
[ ] Force enable legacy 2.0.X HOSTS to use DMA[*] Use PCI DMA by default when available
[ ] Enable DMA only for disks
[ ] ATA Work(s) In Progress (EXPERIMENTAL)
Following the ATA Work(s) in Progress item, there is a list of different chipsets to support. I couldn't find mine in there. Just in case though, my motherboard is the EPoX 8KHA+. I had a link ready for quick reference, but unfortunately I can't post it until I get more posts Also, I noticed while I was looking this over that I had mistakenly overlooked a default chipset choice - the Intel PIIXn was checked. Could this be what's causing the problem? It wouldn't be a huge deal for me to recompile my kernel to remove support for this chipset if that's all that's wrong.

On a somewhat related note, I'm also having problems with CD-burning performance. when trying to use xcdroast, I'm experiencing much lower transfer speeds than my drives can support. It says that I shouldn't be using ATAPI; that I should be using SCSI Emulation. However, I've read somewhere on the internet that the new 2.6 series of kernels includes ATAPI support (and I guess it does -- it works, but much more slowly). Should I remove ATAPI Support from the kernel and add SCSI Emulation (the docs say they are mutually exclusive)? Or is this just a fault of xcdroast and/or a problem due to the above DMA problem? Any suggestions?

Thanks so much in advance for any help.

Last edited by MG-Cloud; 11-08-2003 at 03:05 AM.
 
Old 11-08-2003, 03:18 AM   #2
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
you could try to have your dvd drive scsi-emulated on boot. what bootloader are you using? grub or lilo? i'm using grub, so adding the option to the line in bold will use scsi emulation for that drive. in my grub.conf, my dvd drive is /dev/hdc and my cdrw is /dev/hdb.

Code:
title Red Hat Linux 7.3 (2.4.18-10)
	root (hd0,10)
	kernel /boot/vmlinuz-2.4.18-10 ro root=/dev/hda11 hdb=ide-scsi hdc=ide-scsi
	initrd /boot/initrd-2.4.18-10.img


now doing this will wreak havoc with your /dev links as this device will no longer mount as /dev/hdd, but as /dev/scd0 (if this is the only cd/dvd/cdrw/dvdrw drive you have) or as /dev/scd1 (if you have let's say a cdburner or cdrom on your first ide channel). also if kudzu is running at boot, it will most likely add /dev/cdrom3 which will point to this new device label (/dev/scd0 or /dev/scd1). anyway, you can figure out which dvd/cdromX (where X is a differentiating number) points to which device by right clicking on the link and going into it's properties where it will have a "Points to" field. you need to delete the /dev/cdromX that points to the old device, /dev/hdd and rename the /dev/cdromY (the other cdrom device where Y is it's number) pointing to the /dev/scd1 (or scd0, but my guess is because it's on the second ide channel, it will be /dev/scd1) to /dev/cdromX. you'll then need to delete your /dev/dvd link and create a new link to /dev/cdromX that points to /dev/scd1.

after doing this, now try to enable dma the same way you did before (hdparm -d1 /dev/hdd).

anyway, this technique works for laptops whose cd/cdrw/dvd/etc.. peripherals won't enable dma.

Last edited by megaspaz; 11-08-2003 at 04:08 AM.
 
Old 11-08-2003, 03:33 AM   #3
MG-Cloud
Member
 
Registered: Nov 2003
Distribution: Gentoo
Posts: 30

Original Poster
Rep: Reputation: 15
Thanks so much for the quick reply! I appreciate it greatly

Sorry, I think I should have been a little more specific though
In addition to my dvdrom drive, I can't enable DMA on my hard disk (ide) nor my cdrw drive.

Would scsi-emulation allow me to then enable DMA when I couldn't before?
 
Old 11-08-2003, 03:39 AM   #4
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
for you cdrw it would. i'm not so sure about your hard drive, though. usually ide hard drives should enable dma just fine. it could be that you don't have enable dma in your kernel, in which case you'd have to create a custom kernel. i would wait on suggestions for that though before doing anything like the scsi emulation thingy. although, if you do the scsi emulation and you still can't enable dma on your dvd or cdrw drive, then i'm apt to think your kernel version doesn't have dma support set.
 
Old 11-08-2003, 04:02 AM   #5
MG-Cloud
Member
 
Registered: Nov 2003
Distribution: Gentoo
Posts: 30

Original Poster
Rep: Reputation: 15
Thanks

Yeah I agree with you... I think I'll wait to make sure my kernel is configured correctly (it *should* be, but I've been know to make mistakes ). If that doesn't work, then at least I know I have a backup solution that should work for my peripherals.

So .. is there any more info needed on my kernel configuration besides what I've given above?
 
Old 11-09-2003, 02:33 AM   #6
MG-Cloud
Member
 
Registered: Nov 2003
Distribution: Gentoo
Posts: 30

Original Poster
Rep: Reputation: 15
Any other solutions?
Also, could it possibly be a setting in the BIOS? Windows worked fine with these drives, however.
 
Old 11-10-2003, 10:55 AM   #7
Joey.Dale
Member
 
Registered: Jun 2003
Location: Tampa, Fl
Distribution: Gentoo, Slackware
Posts: 828

Rep: Reputation: 30
if it worked with winblows it is a problem with your linux config
 
Old 02-07-2004, 08:09 AM   #8
Daliz
Member
 
Registered: Feb 2004
Distribution: Mandrake 10.1, Ubuntu 5.04
Posts: 75

Rep: Reputation: 15
Hi,

I've been trying to enable the SCSI emulation on my plextor DVD-rom drive. I have plextor dvd+/-rw (scsi emulated, hdc) and my dvd-rom drive is hdd. I just wanted to ask where I should add the "hdd=ide-scsi"-line? My lilo.conf:

boot=/dev/hda
vga=normal
default="Mandrake9.2"
keytable=/boot/fi-latin1.klt
prompt
nowarn
timeout=50
message=/boot/message
menu-scheme=wb:bw:wb:bw
disk=/dev/hdg bios=0x83
disk=/dev/hde bios=0x82
image=/boot/vmlinuz-2.4.22-10mdk
label="Mandrake9.2"
root=/dev/hdb1
initrd=/boot/initrd-2.4.22-10mdk.img
append="devfs=mount splash=silent hdc=ide-scsi acpi=ht resume=/dev/hdb5"
vga=788
read-only
other=/dev/hda1
label="Win2000"
table=/dev/hda
other=/dev/fd0
label="floppy"
unsafe


Thanks!
 
Old 02-07-2004, 08:21 AM   #9
snacky
Member
 
Registered: Feb 2004
Distribution: Debian
Posts: 286

Rep: Reputation: 30
Use "lspci" to find out what ide controller you have.

One of the lines of output will look something like:
Code:
00:xx.x IDE interface: Manufacturer controllername blah blah blah
This will probably help you decide what to enable in the kernel configuration. I have no idea why the PIIXn chipset is always enabled by default. It's been that way for many kernel versions. You can safely turn that off, though it makes little difference either way...
 
Old 02-07-2004, 09:31 AM   #10
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975
Daliz, please do not hijack other irrelevant threads, your question is not related to the initial question, and is just confusing things.

I have no idea if this old thread (which was quite happily dead) was resolved or not, but you may well want to enable the amd74xx module or similar, i need this module in order to have DMA on my nforce2 board.
 
Old 12-04-2004, 12:56 AM   #11
deadslota
LQ Newbie
 
Registered: May 2004
Distribution: ubuntu
Posts: 7

Rep: Reputation: 0
I'm having similar problems with DMA on my nforce2 board, I tried to enable scsi emulation but get the error:
FATAL: Module ide_mod not found.
when it attepts to set hdc and hdd to scsi

I tried loading the amd74xx module before this, no dice.

my main hd is SATA, it runs fine, I just can't get my optical drives to enable dma (both pioneer DVDs)

cheers for any ideas guys
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Enable DMA on DVD drives puppy Ubuntu 5 09-08-2005 07:09 PM
Failed to enable DMA after upgrade to a DVD writer samael26 Debian 3 09-05-2005 12:31 PM
DVD playing Choppy Change DMA CouchMaster Ubuntu 4 05-24-2005 02:10 PM
How do I enable DMA for my DVD jbasement Debian 2 10-14-2004 07:55 PM
can not enable dma on laptop cd/dvd megaspaz Linux - Laptop and Netbook 2 09-08-2003 09:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration