LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-21-2004, 04:50 AM   #1
TroelsSmit
Member
 
Registered: Feb 2004
Location: Denmark
Distribution: Debian / Suse
Posts: 223

Rep: Reputation: 30
sleep


Hi,

when running X, after not having touched my computer for a while the computer enters somekind of sleep mode, and later it cuts the power to the screen.

Which program controls this ?
What is the command for entering sleep mode ?

Im using XF86, Debian, 2.6.5, Blackbox

Thanks
 
Old 05-21-2004, 05:23 AM   #2
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 54
Could be Xscreensaver,david
 
Old 05-21-2004, 05:33 AM   #3
TroelsSmit
Member
 
Registered: Feb 2004
Location: Denmark
Distribution: Debian / Suse
Posts: 223

Original Poster
Rep: Reputation: 30
When running a 'ps -e' I get the following which, I think, rules Xscreensaver out.

PID TTY TIME CMD
1 ? 00:00:03 init
2 ? 00:00:24 ksoftirqd/0
3 ? 00:00:00 events/0
4 ? 00:00:40 kblockd/0
5 ? 00:00:00 khubd
7 ? 00:00:06 pdflush
9 ? 00:00:00 aio/0
8 ? 00:00:00 kswapd0
10 ? 00:00:00 saa7134[0]
11 ? 00:00:00 kseriod
12 ? 00:00:00 i2oevtd
13 ? 00:00:17 kjournald
332 ? 00:00:00 dhclient3
336 ? 00:00:00 portmap
427 ? 00:00:04 syslogd
430 ? 00:00:02 klogd
443 ? 00:00:00 cupsd
486 ? 00:00:00 exim4
491 ? 00:00:00 famd
496 ? 00:00:00 inetd
507 ? 00:00:00 mysqld_safe
542 ? 00:00:00 mysqld
578 ? 00:00:01 nmbd
580 ? 00:00:00 smbd
588 ? 00:00:00 sshd
600 ? 00:00:00 xfs
668 ? 00:00:00 ksh
669 ? 00:00:00 ksh
670 ? 00:00:00 Xprt
673 ? 00:00:00 ksh
703 ? 00:00:00 rpc.statd
730 ? 00:00:00 ntpd
734 ? 00:00:00 atd
737 ? 00:00:00 miniserv.pl
738 ? 00:00:00 cron
744 ? 00:00:00 apache
752 tty1 00:00:00 tcsh
753 tty2 00:00:00 getty
754 tty3 00:00:00 getty
755 tty4 00:00:00 getty
756 tty5 00:00:00 getty 757 tty6 00:00:00 getty
758 ? 00:00:04 apache
759 ? 00:00:01 apache
760 ? 00:00:05 apache
761 ? 00:00:01 apache
762 ? 00:00:01 apache
765 ? 00:00:00 fetchmail
773 tty1 00:00:00 startx
784 tty1 00:00:00 xinit
785 ? 00:02:29 XFree86
790 tty1 00:00:01 blackbox
791 tty1 00:00:05 bbpager
792 tty1 00:00:01 xbuffy
793 tty1 00:00:31 gaim
794 tty1 00:00:00 bbkeys
795 tty1 00:00:02 wmtime
796 tty1 00:00:01 wmmemload
797 tty1 00:00:03 wmweather
798 tty1 00:00:02 wmix
799 tty1 00:00:06 ipac
862 ? 00:00:00 ssh-agent
863 tty1 00:00:00 lineakd
1617 ? 00:00:01 apache
1731 ? 00:00:06 pdflush
1984 ? 00:03:04 amule
2024 tty1 00:00:00 aterm
2029 pts/12 00:00:00 tcsh
2490 ? 00:00:00 sh <defunct>
2543 pts/12 00:00:00 move
2883 ? 00:00:01 apache
3236 ? 00:00:00 apache
3237 ? 00:00:00 apache
3238 ? 00:00:00 apache
3350 tty1 00:00:00 gconfd-2
3478 ? 00:00:00 identd
3490 tty1 00:00:00 led
3510 tty1 00:00:00 xterm
3511 pts/22 00:00:00 mutt
3518 pts/22 00:00:00 urlview
3519 pts/22 00:00:04 mozilla-bin
3546 tty1 00:00:00 aterm
3547 pts/23 00:00:00 tcsh
3552 pts/12 00:00:00 sleep
 
Old 05-21-2004, 05:34 AM   #4
TroelsSmit
Member
 
Registered: Feb 2004
Location: Denmark
Distribution: Debian / Suse
Posts: 223

Original Poster
Rep: Reputation: 30
(the 'sleep' is a simple script currently using that command)
 
Old 05-21-2004, 06:59 AM   #5
anandj
Member
 
Registered: May 2004
Distribution: Fedora Core 4
Posts: 92

Rep: Reputation: 15
Its probably 'dpms' settings in your XF86config
check
http://reviewed.homelinux.org/quicktips/screenblanking/
 
Old 05-21-2004, 08:32 AM   #6
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
Check the KDE control center under Power management. There is an option for Monitor power saving.
 
Old 05-21-2004, 02:38 PM   #7
TroelsSmit
Member
 
Registered: Feb 2004
Location: Denmark
Distribution: Debian / Suse
Posts: 223

Original Poster
Rep: Reputation: 30
I don't have KDE installed :-S
 
Old 05-21-2004, 03:45 PM   #8
anandj
Member
 
Registered: May 2004
Distribution: Fedora Core 4
Posts: 92

Rep: Reputation: 15
Its immaterial if you are running KDE or not.
Its a setting in XF86Config

check the website I mentioned earlier.

or search for 'dpms' on google if you feel its not clear.
 
Old 05-21-2004, 03:47 PM   #9
anandj
Member
 
Registered: May 2004
Distribution: Fedora Core 4
Posts: 92

Rep: Reputation: 15
As a user you can turn on dpms by
xset +dpms
command.

or disable it by
xset -dpms

check xset manpages for more info.
 
Old 05-21-2004, 05:08 PM   #10
TroelsSmit
Member
 
Registered: Feb 2004
Location: Denmark
Distribution: Debian / Suse
Posts: 223

Original Poster
Rep: Reputation: 30
Perfect, gonna try it in the morning!
 
Old 05-22-2004, 01:17 AM   #11
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
Or you can try

xset dpms force off

This should blank your monitor until you press a key or move the mouse.

Just a simple test to see if you have dpms
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Searching for Server (BOOTP/DHCP) <sleep> <sleep> .. .. Eileen Linux - Networking 12 10-21-2005 01:14 AM
sleep() call prital Programming 2 06-27-2005 07:04 AM
Sleep Samoth Linux - General 1 05-01-2005 06:20 PM
sleep liguorir Linux - Software 1 08-10-2003 03:53 PM
to sleep or not hejduk Linux - General 3 03-28-2002 03:11 PM


All times are GMT -5. The time now is 09:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration