LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-10-2006, 08:34 PM   #1
meirbenezra
LQ Newbie
 
Registered: Jan 2006
Posts: 23

Rep: Reputation: 15
SLAX No Internet


I tried to use slax. I added some modules on it some of which are isc_dhcp and samba. I started up the live cd everything was fine till I found out I didn't have working internet connection nor could I connect to my modem settings. I have adsl connection with an ethernet modem it is also I think a router. I don't know much about these things though. I read something about dhcpcd and I saw on boot up when hotplug initiates it says "dhcpcd -d -t 10 eth0" then my mac address and ip address pops then again the same command with eth1. the strange thing there is I only have one ethernet card. Anyway when I try the same command when the system is booted totally I could only get the mac address but not the ip address. It waits waits and waits but nothing happens it then turns back to the "root~/>" (or sth like that) stuff. I also couldn't use samba because I cannot connect to my modem so I cant reach my network neither. I also tried netconfig tool but it didnt work as it forced me to write a name for a domain but I dont have one I just have an ADSL modem which is a local brand one but it is verisimilar to those of alcatel or any other router adsl modems and another computer running windows connected to it. I know it is a long thread writing but I want to give out every detail I know of so that you can help me better and easier. This is really important for me cause I loved the modules thing in slax and many many things in it but couldn't use internet what a luck huh? thanx in advance... btw when I write ifconfig only it gives info about only "lo" when I write ifconfig eth0 it doesnt give the ip info... (I couldnt understand what is happenning you people are my only chance please help )
 
Old 01-11-2006, 02:00 AM   #2
den15
Member
 
Registered: Oct 2005
Distribution: zenwalk
Posts: 88

Rep: Reputation: 15
try pppoe-setup or adsl-setup, then pppoe-start or adsl-start if i remember good... in either case do a search of this page and google looking for adsl connection setup.
 
Old 01-12-2006, 09:00 AM   #3
meirbenezra
LQ Newbie
 
Registered: Jan 2006
Posts: 23

Original Poster
Rep: Reputation: 15
I tried both but realized that my modem has the script inside so it connects itself all I have to manage is to link my pc with the modem. How will I do that?
 
Old 01-14-2006, 12:42 PM   #4
meirbenezra
LQ Newbie
 
Registered: Jan 2006
Posts: 23

Original Poster
Rep: Reputation: 15
guyss plssssss I need help if I could do this all by myelf why would I ask it on this forum where is the linuz help spirit if you wnat to learn anything more about the problem to be able to help ask but at least notice meee pls...
 
Old 01-14-2006, 01:06 PM   #5
dasy2k1
Member
 
Registered: Oct 2005
Location: 127.0.0.1
Distribution: Ubuntu 12.04 X86_64
Posts: 958

Rep: Reputation: 35
hmmmm
look at yoru router...
(the box that connects teh wall socket to the computer)

what make and model is it?

if it used DHCP then you must configure it on the network part of the isnatll allong with host neme... after that evertything should be fine..
i have installed slackware, mandrake and SUSE and all of tehase have worked first time when i have configured it correctky...
 
Old 01-14-2006, 01:57 PM   #6
meirbenezra
LQ Newbie
 
Registered: Jan 2006
Posts: 23

Original Poster
Rep: Reputation: 15
its an airties modem I mean the brand is airties rt-210 is the model it's in turkish though. I've set up everything right with the modem, it works perfect with Ubuntu. I havent installed it yet Im using it as live cd. I dont want to install it unless it works this way. Also before installing and using linux I want to learn some through the live cds. I tried net-config and it brought up a config wizard on which I did everything just as I do with any other distro but on this it didnt work. is it possible that slax modules or kernel or whatever it is cant recognize the router/modem's dhcp server?? (I'M just trying my best giving all the info I know to get hlp )
 
Old 01-14-2006, 03:22 PM   #7
dasy2k1
Member
 
Registered: Oct 2005
Location: 127.0.0.1
Distribution: Ubuntu 12.04 X86_64
Posts: 958

Rep: Reputation: 35
hmmm
not sure with live cds, ive never really played around with them!
 
Old 01-14-2006, 04:04 PM   #8
den15
Member
 
Registered: Oct 2005
Distribution: zenwalk
Posts: 88

Rep: Reputation: 15
check is your NIC recognized, and is there support (module) for it in /etc/rc.d/rc.modules
 
Old 01-14-2006, 06:59 PM   #9
meirbenezra
LQ Newbie
 
Registered: Jan 2006
Posts: 23

Original Poster
Rep: Reputation: 15
so I need to know the module which would make my modem recognized. what could the module be or what if I added all the modules that are related to metworking from slax website/modules would the modem be recognized?
 
Old 01-14-2006, 07:02 PM   #10
den15
Member
 
Registered: Oct 2005
Distribution: zenwalk
Posts: 88

Rep: Reputation: 15
i have not spoken about modem modules. i sad NIC that's your network interface card.
 
Old 01-14-2006, 07:18 PM   #11
meirbenezra
LQ Newbie
 
Registered: Jan 2006
Posts: 23

Original Poster
Rep: Reputation: 15
also I forgot to write what my ethernet card is its a CNET Pro200 Pci Fast Ethernet Adapter (this is not that I'm trying to advertise my card its what device manager in windows says) so I need to see if my ethernet or my nic card is recognized right?
 
Old 01-14-2006, 07:33 PM   #12
den15
Member
 
Registered: Oct 2005
Distribution: zenwalk
Posts: 88

Rep: Reputation: 15
here you can find driver for your nic:

http://list.driverguide.com/list/LIN...225/index.html
 
Old 01-14-2006, 11:14 PM   #13
meirbenezra
LQ Newbie
 
Registered: Jan 2006
Posts: 23

Original Poster
Rep: Reputation: 15
So I checked my rc.modules and it has support for my card but it has sth like modprobe dmfe command but it's commented out with # sign as all the other devices I tried to configure eth0 manually with "ifconfig eth0 x.x.x.x netmask x.x.x.x" but it didnt work also I need sth else anyone with sthelse in mind?
 
Old 01-14-2006, 11:22 PM   #14
meirbenezra
LQ Newbie
 
Registered: Jan 2006
Posts: 23

Original Poster
Rep: Reputation: 15
I also found the driver I need but it was for old kernels like latest 2.4 but the kernel slax 5.0.6 has is 2.6 and rc.modules file had the support but it cannot manage to create the link between the modem and the pc any more suggestions?
 
Old 01-15-2006, 11:41 AM   #15
meirbenezra
LQ Newbie
 
Registered: Jan 2006
Posts: 23

Original Poster
Rep: Reputation: 15
also a very strange thing slax recognizes my dhcp server with the rc.hotplug at boot up but after the system is up and running it somehow doesnt recognize anymore... when I write the same command as in the rc.hotplug "dhcpcd -d -t 20 eth0" it just gives out the mac address but not the ip adress it waits and waits and then finishes without the ip but in dhcpcd folder inside etc it is saved as a file with all the correct info about my network...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
slax jazztown Slackware 4 06-24-2005 09:52 PM
Trouble Using the Internet in Knoppix/SLAX SomeNewbie Linux - Wireless Networking 1 06-04-2005 05:28 PM
setting up internet for Slax JoeSwan Linux - Distributions 7 03-24-2005 01:56 AM
Slax sh0cker Slackware 5 12-25-2004 06:13 PM
slax, gimp, mozilla and internet wildflower General 1 09-10-2004 11:32 PM


All times are GMT -5. The time now is 04:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration