LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-08-2003, 11:51 PM   #1
garr0323
Member
 
Registered: Oct 2003
Distribution: Slackware9.1, Mandrake9.1
Posts: 70

Rep: Reputation: 15
Slackware9.1 Problems


Hello,
I have recently switched from Mandrake 9.0 to slackware9.1. first here are the specs on my pc:
256 mb of ram
1.3 ghz celeron

Now, I have two hard drives in my pc. One of the hhds had linux mandrake and the other one had windows 2000. I dont want to replace windows 2000, i just want to write over mandrake with slackware. But I dont know where how to install LILO. On mandrake the MBR was on the linux hhd. But now that is gone and I cant get into windows with a boot disk. I dont know if i worded that good enouch so if anyone needs more info let me. know.

My second problem was that i did install slackware successuflly. it loaded fine but it went to a command prompt after it was done loading. and i logged in as root and i dont know how to get into the desktop (gnome or kde). It asked me if wanted to set one as default in the setup but it wouldnt let me pick one. there were X's next to all of the selections. If anyone has any solutions to my problems, i would be most grateful.

Garrett
 
Old 10-09-2003, 03:53 AM   #2
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
Slackware, bless it, defaults to runlevel 3. If you want X, do 'xwmconfig' and cursor-down to the manager you want and hit enter. Then do 'startx'. If you (why, why?) must have a default GUI, edit inittab and change the line about default runlevel from 3 to 4.

On the other 'hhd' doesn't exist and I'm confused about the whole situation. Copy /etc/fstab and post it here first of all. And the output of 'fdisk -l' maybe. But I think you might be saying you had two drives, one with Mandrake and one with Windows and you installed LILO to the MBR on the same drive as Mandrake - the same drive you overwrote with Slack. So just reinstall LILO in Slack as you did Mandrake. Maybe the easiest way would to do 'pkgtool' and select 'setup' and select 'liloconfig'. Tell it what OSes you have where and that you want to install LILO to wherever it was before - the MBR of the Slack drive, I guess. I *am* guessing here, but that sounds like what you want.
 
Old 10-09-2003, 04:31 AM   #3
yapp
Member
 
Registered: Apr 2003
Location: Netherlands
Distribution: SuSE (before: Gentoo, Slackware)
Posts: 613

Rep: Reputation: 30
Re: Slackware9.1 Problems

Quote:
Originally posted by garr0323
it loaded fine but it went to a command prompt after it was done loading. and i logged in as root and i dont know how to get into the desktop (gnome or kde).
In everyday use, you shouldn't work behind your system as root. A normal user works fine (even better), and you, or a virus, can't harm your system. Type "adduser <name>", and the user account will be set-up for you.

You won't experience any problems with configurations, and installed programs that don't work for some reason. (like missing registry keys). Linux is build differently, and designed to be multi-user, and secure. The KDE desktop even prompts for your root-password if you want to change system-wide configurations. Other program configurations are just overruled by the configuration in your personal-directory (/home/yourname)

Running programs as root is insecure, because the program has a "license to kill" your entire system (even flash your bios, etc..). Dragging a /dev/ folder to another location is a little too easy too, but makes your system entirely unusable...!

Last edited by yapp; 10-09-2003 at 04:33 AM.
 
Old 10-09-2003, 05:18 AM   #4
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
I completely spaced on the 'logged in as root' thing. Good catch, yapp. Yeah, just set up your normal user and 'su' when you have to - my root account doesn't even have X setup at all.
 
Old 10-09-2003, 06:36 AM   #5
yapp
Member
 
Registered: Apr 2003
Location: Netherlands
Distribution: SuSE (before: Gentoo, Slackware)
Posts: 613

Rep: Reputation: 30
hehe thanks. you're welcome

I've started to notice how many new users use 'root' for everything, and this is clearly getting my attention But honestly, If I didn't have seen UNIX at school before, or known someone to point me these 'little basics', I would have made the same 'mistakes' too.

Maybe this is a good idea for a F.A.Q., or a sticky topic? Most people seam to think that you need to run your system as root, because an limited account is not workable. ... This is true of an Windows XP btw, so everyone is "administrator" at their XP workstations. (go figure)
 
Old 10-09-2003, 07:10 AM   #6
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
Well, it's primarily that Linux has to have root, new users first login as root, and a lot of installation and configuration requires root privileges. So creating a user account is a whole separate process and, indeed, nothing really works as user initially. So I think a lot of new users get rooted in bad habits. *g* But if you just adduser right off the bat and su a lot to get things fixed, once things are fixed you can have a very workable and still (I hope) reasonably secure box for normal use. So then you get in the habit of never logging on as root and rarely su'ing. As far as it being a sticky or a FAQ, every distro README or similar docs and every Linux book and most every help website explains it and people mention it on posting boards all the time. If people want to run as root after that, I don't suppose much will stop them.

But coming from a permissionless DOS/Win environment or crippled NT environment (me), it can take some getting used to and seem like a real pain. A typo in the ballpark of an 'rm -rf' or getting cracked is more of a pain though.

And Garrett, don't feel like this is pointed at you. It's perfectly acceptable (but unnecessary) to set up a nice environment for root and login that way if you need to do a lot of rootwork and doesn't mean you're doing anything wrong. Just talking generally about some new users in general and saying if you *were* doing everything as root, you shouldn't.
 
Old 10-09-2003, 09:45 AM   #7
garr0323
Member
 
Registered: Oct 2003
Distribution: Slackware9.1, Mandrake9.1
Posts: 70

Original Poster
Rep: Reputation: 15
Gnome and KDE

Thanks for helping out. I did the xwmconfig and startx. Then it started to go into a graphical mode and I saw differnent colored vertical lines on the screen. Then the computer froze. I am really confused. Thanks for the help.

This forum has really been a lot of help. I have been to other linux help sites and they usually never respond. Thanks for responding.
 
Old 10-09-2003, 09:56 AM   #8
yapp
Member
 
Registered: Apr 2003
Location: Netherlands
Distribution: SuSE (before: Gentoo, Slackware)
Posts: 613

Rep: Reputation: 30
Nope this shouldn't happen. What kind of graphics card do you have?

and how did the freeze happen? did the light at the keyboad flash? (which indicates a kernel panic, in all other cases, youy system hasn't really crashed)
 
Old 10-09-2003, 10:33 AM   #9
garr0323
Member
 
Registered: Oct 2003
Distribution: Slackware9.1, Mandrake9.1
Posts: 70

Original Poster
Rep: Reputation: 15
i have a 16mb graphics card
i have ran linux on this computer before and the lights on the keyboard were not flashing. but what if they were. what would i do about that?
 
Old 10-10-2003, 03:05 AM   #10
yapp
Member
 
Registered: Apr 2003
Location: Netherlands
Distribution: SuSE (before: Gentoo, Slackware)
Posts: 613

Rep: Reputation: 30
I'm not sure what could cause your problem, but I've noticed how your screen could mix up if you use invalid screen resolutions. If I'm correct, your screen just freezes, and the image is a little mixed up or something?

You could try to start X with a lower screen size. (resolution) XFree tries to use the highest available screen-size, and that's set to 1280x1024 by default. Your card might not support it. I think "that's all"

changing the display resolution
* Open a root console, and edit /etc/X11/XF86Config. You'll find a lot of comments/hints in that file (lines starting with a "#").
* The XF86Config file contains sections describing your input devices, monitors, graphical adapters, and finally, the combination of these devices; the "screen" and "serverlayout" sections.
* here is a sample screen section (from my config). The identifier can be referred to by other sections, and "display" sub sections describe the available modes. XFree will use the highest mode possible. If you remove certain modes there, and re-start your X server, you'll get a lower screen resolution.
Code:
Section "Screen"
    Identifier     "First_Screen"
    Device         "Sapphire_Graphics_Adapter"
    Monitor        "Typical_17Inch_Monitor"

    DefaultDepth   24
#   Option         "backingstore"

    Subsection "Display"
        Depth       24
        Modes       "1024x768" "800x600" "640x480"
#       ViewPort    0 0
#       Virtual     1280 1024
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier  "HAL9000_Layout"

    Screen      "First_Screen"
    InputDevice "Wheel_Mouse"         "CorePointer"
    InputDevice "CompaqEA_Keyboard"   "CoreKeyboard"
EndSection

tracing problems
Here are some ways to trace your problems:
* run "startx 2>&1 | tee output.log". This will display and log all messages and error messages to the file output.log
If you return to the console, type "less output.log to see the problems that XFree might have had during startup.
* browse the XFree log: less /var/log/XFree86.0.log
* to display the warnings and error messages from the log only:
grep -E "\((WW|EE)\)" /var/log/XFree86.0.log
it will help you understand your problem, and find a solution.

If I have problems with my graphical desktop, I open 2 consoles: one root console to edit XF86Config, and a second one to log-in as normal user, and run "X", or "startx". You can use Ctrl+Alt+Fx to change to other consoles, and Ctrl+Alt+Backspace to terminate your X server.


Once you have X and the KDE running, you can configure your display from the KDE Control center too... That was at least, my first amazing linux experience; my screen just worked, and I could set the resolution. (because I always read horror ststories about messing monitor-modelines, but this is history) I hope you don't mind playing a little with the configuration first, because it didn't work at once

* The tools xf86cfg and xf86config can be helpful too, you can use these to re-generate your /etc/X11/XF86Config.


FYI: about the flashing lights: if your keyboard lights are all flashing, you have a kernel panic. (ie your kernel got stuck, and stopped completely) This should never happen, but just in case... I've asked you about it As long as your system doens't have a kernel panic, all processes, programs, networking etc.. are running! (even if your display is locked up; your keyboard isn't) You could even login remotely, and fix the problem
 
Old 10-10-2003, 03:08 AM   #11
yapp
Member
 
Registered: Apr 2003
Location: Netherlands
Distribution: SuSE (before: Gentoo, Slackware)
Posts: 613

Rep: Reputation: 30
oh... after reading your first post again:

if the setup works in mandrake, look in their XF86Config (or XF86Config-4) what the difference is, and what drivers they've selected.
 
Old 10-11-2003, 12:19 AM   #12
garr0323
Member
 
Registered: Oct 2003
Distribution: Slackware9.1, Mandrake9.1
Posts: 70

Original Poster
Rep: Reputation: 15
thanks for still helping me. I tried the /etc/x11/xf86fconfig and it didnt work. it said permission denied and i was logged into root. Anyway, I looked at what errors i was given on the output.log files. one of the errors i came across was this:

(WW) Open APM failed (/dev/apm_bios) (No such device)

I dont know exactly what this means. But maybe someone does. When I "startx" it goes to a kind of colored screen. There are purple lines and there is absolutley no image to even be made out. Thanks.
 
Old 10-13-2003, 03:38 AM   #13
yapp
Member
 
Registered: Apr 2003
Location: Netherlands
Distribution: SuSE (before: Gentoo, Slackware)
Posts: 613

Rep: Reputation: 30
Quote:
Originally posted by garr0323
thanks for still helping me. I tried the /etc/x11/xf86fconfig and it didnt work. it said permission denied and i was logged into root.
How did you try to edit this file, or did you just type "/etc/X11/XF86Config"? It won't allow you to execute the file, because it isn't marked as executable, so you'll get a "permission denied". Type "pico /etc/X11/XF86Config", or use "nano ...", "emacs ...", or "vim ...". They are editors you can use to modify the file.


Quote:
Originally posted by garr0323

Anyway, I looked at what errors i was given on the output.log files. one of the errors i came across was this:
(WW) Open APM failed (/dev/apm_bios) (No such device)
The APM bios thing is quite harmless (as far as I know) APM and ACPI are power management features of your BIOS. If your system has ACPI, it will be used in favor of APM.

What other error messages did you get?

Try to edit the XF86Config file, and startx again. Make a copy first, so you can restore it is you mess things up; for example: "cp /etc/X11/XF86Config ~"
 
Old 10-13-2003, 08:13 AM   #14
garr0323
Member
 
Registered: Oct 2003
Distribution: Slackware9.1, Mandrake9.1
Posts: 70

Original Poster
Rep: Reputation: 15
Thanks everyone who helped. I figured it out. So far linux is up and running with internet but i need to find out where to get Wine and mount NT
 
Old 10-14-2003, 02:53 AM   #15
yapp
Member
 
Registered: Apr 2003
Location: Netherlands
Distribution: SuSE (before: Gentoo, Slackware)
Posts: 613

Rep: Reputation: 30
great good to hear.

Wine can be found at www.winehq.org, and http://www.frankscorner.org/ is a great site too. I haven't got wine working successfully however but I hope you have more luck on this.

mounting nt partitions isn't hard. As root, issue these commands:

fdisk -l (shows a list of partitions)
mkdir /mnt/winnt (create a mount point)
mount -t ntfs /dev/hd... /mnt/winnt

if this works, edit /etc/fstab, and add another line, for example
Code:
/dev/hda1  /mnt/hd/winxp  ntfs  auto,ro,utf8,uid=0,gid=304,umask=0227  0  0
If I type "mount /mnt/hd/winxp", the partition will be mounted with the other parameters from fstab. The user-id, group-id, and umask denies other users to browse the file system, except the "root (0)", and my "xpusers (304)" group members. NTFS access control lists are not honered by Linux (everyone could see all files), so that's why I've limited the access to a special group. By default, the permissions only allow the root user to browse the files.

The "auto" option causes the file system to be mounted at system boot, and "ro" is set to make the file system readonly; ntfs cannot be written correctly by the linux 2.4.x kernels.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
slackware9.0 printer Henry Slackware 11 03-31-2004 09:18 PM
Slackware9.1 InstallDisc2 ISO problems kwiksand Slackware 8 10-12-2003 08:45 PM
Anjuta and Slackware9 PJota Linux - Software 6 08-04-2003 09:24 AM
slackware9 q_re_us Slackware 8 07-14-2003 11:40 PM
Slackware9 and vmware4 Deceiver83 Linux - Software 1 04-30-2003 08:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration