LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-21-2007, 02:27 AM   #16
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled

If you're using USB, you'll need a driver for your modem instead of for your network card. That'll be the same with any distro, but perhaps Fedora and Mandriva include those drivers in their kernels (I don't know).
 
Old 07-21-2007, 02:53 AM   #17
General Failure
Member
 
Registered: Jan 2007
Location: Germany
Distribution: Slackware 13.37
Posts: 387

Rep: Reputation: 35
He already has that driver, it's CDCEther. Slemany, try to disable your onboard network adapter through BIOS. That would be the easiest way to solve the problem. Then run netconfig.

For runlevel 4, edit /etc/inittab to have it say
Code:
id:4:initdefault:
instead of
Code:
id:3:initdefault:
For the harddisks, edit /etc/fstab setting the user option for that drive.

Install firefox from either mozilla.com or your favorite slackware mirror.

Hope that helps...
 
Old 07-21-2007, 05:26 AM   #18
slemany
LQ Newbie
 
Registered: Jul 2007
Posts: 19

Original Poster
Rep: Reputation: 0
hi, i am glad to see that there are more people to help me now, i thank everyone.

my problems is i am not well familiar with linux, so when you say
Quote:
Slemany, try to disable your onboard network adapter through BIOS
i would kindly ask you for a brief guidance as how to do this.

and honestly i also don't know what runlevel4 is and where to type
Quote:
edit /etc/inittab
, is it going to be in a terminal or at the computer startup?, sorry but i need a bit of more explanations.

thank you
 
Old 07-21-2007, 06:06 AM   #19
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
You don't type "edit /etc/inittab", you do it (i.e. it's an instruction to edit the file /etc/inittab). You can use any text editor to do this (vi, Emacs, pico, Kate, KWrite for example). You'll need to become root before editing the file. In a terminal you can run "su" (without the quotes) and then enter your password when prompted. Then run "editor /etc/inittab", replacing editor with the whatever you want to use. Note that executable names are usually lowercase, so if you want to use KWrite, you'd run "kwrite /etc/inittab". Also note that if you don't have a graphical user interface running at the moment, you'll not be able to use KWrite or Kate (and you'll also not be able to use Emacs if you don't have the emacs-nox package installed).
 
Old 07-21-2007, 10:48 AM   #20
slemany
LQ Newbie
 
Registered: Jul 2007
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Nylex
You don't type "edit /etc/inittab", you do it (i.e. it's an instruction to edit the file /etc/inittab). You can use any text editor to do this (vi, Emacs, pico, Kate, KWrite for example)
thank you for the information but i am really confused because i triead the kwrite and was not sure what to type even in the terminal i typed su but nothing happened.

i would appreciate if someone could explain to me to do it correctly.
 
Old 07-21-2007, 10:54 AM   #21
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
After running su, did you enter your root password? What happens when you type "kwrite /etc/inittab" (without quotes and obviously, you need to press Enter!).
 
Old 07-21-2007, 10:55 AM   #22
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Post any error messages if they occur.
 
Old 07-21-2007, 02:43 PM   #23
lord-fu
Member
 
Registered: Apr 2005
Location: Ohio
Distribution: Slackware && freeBSD
Posts: 676

Rep: Reputation: 30
Hey guys thanks for stepping in.
 
Old 07-21-2007, 07:58 PM   #24
slemany
LQ Newbie
 
Registered: Jul 2007
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
root@slemany:~# su
root@slemany:~# kwrite/etc/inittab
bash: kwrite/etc/inittab: No such file or directory
root@slemany:~# Kwrite/etc/inittab
bash: Kwrite/etc/inittab: No such file or directory
ABOVE IS THE OUTPUT AS YOU SEE, I HAVE TRIED BOTH SMALL AND CAPITAL LETTER WHILST TYPING KWRITE JUST BECAUSE I WAS NOT SURE.

I ALSO WOULD LIKE TO SAY THAT THERE IS KWRITE INSTALLED ON MY SLACXKWARE11 SYSTEM INCASE YOU THINK IT IS NOT INSTALLED.
 
Old 07-21-2007, 08:01 PM   #25
slemany
LQ Newbie
 
Registered: Jul 2007
Posts: 19

Original Poster
Rep: Reputation: 0
I AS USUAL FORGOT TO TELL YOU THAT WHEN I TYPED SU NOTHING CAME UP AND DID NOT ASK FOR ANY PASSWORDS.
 
Old 07-22-2007, 01:47 AM   #26
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
You were already root, so you didn't need to type su (I suggest you add a user account for yourself for normal use and only use root when necessary). Secondly, I did say executables were lowercase You need a space between the executable and the filename, obviously otherwise the shell is going to think it's looking for "kwrite/etc/inittab". How does it know otherwise?

Please don't type in all capitals, as it looks like you're shouting.
 
Old 07-22-2007, 02:03 PM   #27
slemany
LQ Newbie
 
Registered: Jul 2007
Posts: 19

Original Poster
Rep: Reputation: 0
hi, i apologise for not paying good attentions to your post below
Quote:
did say executables were lowercase You need a space between the executable and the filename
this was because i did not notice the space between the file and the slash.

i have now come back with this output: see below please:

Quote:
#
# inittab This file describes how the INIT process should set up
# the system in a certain run-level.
#
# Version: @(#)inittab 2.04 17/05/93 MvS
# 2.10 02/10/95 PV
# 3.00 02/06/1999 PV
# 4.00 04/10/2002 PV
#
# Author: Miquel van Smoorenburg, <miquels@drinkel.nl.mugnet.org>
# Modified by: Patrick J. Volkerding, <volkerdi@slackware.com>
#

# These are the default runlevels in Slackware:
# 0 = halt
# 1 = single user mode
# 2 = unused (but configured the same as runlevel 3)
# 3 = multiuser mode (default Slackware runlevel)
# 4 = X11 with KDM/GDM/XDM (session managers)
# 5 = unused (but configured the same as runlevel 3)
# 6 = reboot

# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:

# System initialization (runs when system boots).
si:S:sysinit:/etc/rc.d/rc.S

# Script to run when going single user (runlevel 1).
su:1S:wait:/etc/rc.d/rc.K

# Script to run when going multi user.
rc:2345:wait:/etc/rc.d/rc.M

# What to do at the "Three Finger Salute".
ca::ctrlaltdel:/sbin/shutdown -t5 -r now

# Runlevel 0 halts the system.
l0:0:wait:/etc/rc.d/rc.0

# Runlevel 6 reboots the system.
l6:6:wait:/etc/rc.d/rc.6

# What to do when power fails.
pf:owerfail:/sbin/genpowerfail start

# If power is back, cancel the running shutdown.
pg:owerokwait:/sbin/genpowerfail stop

# These are the standard console login getties in multiuser mode:
c1:1235:respawn:/sbin/agetty 38400 tty1 linux
c2:1235:respawn:/sbin/agetty 38400 tty2 linux
c3:1235:respawn:/sbin/agetty 38400 tty3 linux
c4:1235:respawn:/sbin/agetty 38400 tty4 linux
c5:1235:respawn:/sbin/agetty 38400 tty5 linux
c6:12345:respawn:/sbin/agetty 38400 tty6 linux

# Local serial lines:
#s1:12345:respawn:/sbin/agetty -L ttyS0 9600 vt100
#s2:12345:respawn:/sbin/agetty -L ttyS1 9600 vt100

# Dialup lines:
#d1:12345:respawn:/sbin/agetty -mt60 38400,19200,9600,2400,1200 ttyS0 vt100
#d2:12345:respawn:/sbin/agetty -mt60 38400,19200,9600,2400,1200 ttyS1 vt100

# Runlevel 4 used to be for an X window only system, until we discovered
# that it throws init into a loop that keeps your load avg at least 1 all
# the time. Thus, there is now one getty opened on tty6. Hopefully no one
# will notice. ;^)
# It might not be bad to have one text console anyway, in case something
# happens to X.
x1:4:respawn:/etc/rc.d/rc.4

# End of /etc/inittab
i am in need of your help and i badly need internet connections on my slackware to have a proper taste of it.

many thanks
 
Old 07-22-2007, 02:08 PM   #28
slemany
LQ Newbie
 
Registered: Jul 2007
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by General Failure
He already has that driver, it's CDCEther. Slemany, try to disable your onboard network adapter through BIOS. That would be the easiest way to solve the problem. Then run netconfig.

For runlevel 4, edit /etc/inittab to have it say
Code:
id:4:initdefault:
instead of
Code:
id:3:initdefault:
For the harddisks, edit /etc/fstab setting the user option for that drive.

Install firefox from either mozilla.com or your favorite slackware mirror.

Hope that helps...
hi, i appreciate some more explanations about your post above because my lack of knowledge of using linux i could not properly understand what you have suggested.

thanks alot.
 
Old 07-22-2007, 06:14 PM   #29
slemany
LQ Newbie
 
Registered: Jul 2007
Posts: 19

Original Poster
Rep: Reputation: 0
hi, where are you friends? i am sure you can help me.

i am still waiting for your useful information.
thank you.

slemany.
 
Old 07-22-2007, 06:25 PM   #30
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
What don't you understand?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Internet Conection Sharing Bobymc Linux - Hardware 12 05-05-2006 11:10 AM
Problem with my internet conection oosswwaalldd Linux - Networking 2 08-28-2005 03:43 AM
Internet conection fireedo Linux - Newbie 2 02-26-2005 02:37 AM
Internet conection doesn't work New_To_RH_Linux Linux - Software 10 02-21-2005 01:50 PM
Internet Conection Sharing soulsniper Linux - Networking 6 07-12-2003 10:59 AM


All times are GMT -5. The time now is 10:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration