LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-19-2010, 07:19 PM   #1
jv2112
Member
 
Registered: Jan 2009
Location: New England
Distribution: Arch Linux
Posts: 719

Rep: Reputation: 103Reputation: 103
Slackware Virgin - Sound Card Issue - ! Programs at Once


I touch the plunge today and went from Linux Mint 10 to Slackware 13.1 64 bit in hopes of continuing my Linux education.

I overcame some new challenges and have many of the functions up and going. However, I have one challenge I am not sure where to start.Any time a I start a application that acceses the sound card then start another the second program can't access. (Example Amarok then Mplayer. So Mplayer won't work).

The error message-> Alsa Error : snd_pcmf_open failed. Device or resource busy.

Any thoughts ?
 
Old 12-19-2010, 07:54 PM   #2
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 308Reputation: 308Reputation: 308Reputation: 308
Install the gnomeslackbuild, http://gnomeslackbuild.org/ , and use pulseaudio like you did in Mint.
 
Old 12-19-2010, 08:28 PM   #3
jv2112
Member
 
Registered: Jan 2009
Location: New England
Distribution: Arch Linux
Posts: 719

Original Poster
Rep: Reputation: 103Reputation: 103
Is that the only option ? I wanted to get away from gnome. I a currently using XFCE.
 
Old 12-19-2010, 10:04 PM   #4
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mint, OpenBSD
Posts: 11,358
Blog Entries: 12

Rep: Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740
As root, run alsaconf to make sure your sound card is properly detected.

Then run alsamixer to configure your settings; it's muted by default.

Run alsactl store to save the settings.

I cannot recommend pulseaudio. I have it on my Ubuntu laptop, and I have never encountered the audio problems with Slackware and ALSA that I encounter regularly with pulseaudio. I put up with it--what's an occasional reboot that takes fewer than two minutes?--because the computer has a Broadcom wireless chip and the wireless works. I've fought the Linux wireless wars before.

Even the pulseaudio website reports that pulse cannot yet be considered stable.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
2 sound card issue johnh10000 Linux - Hardware 9 03-23-2010 09:41 PM
Sound Skips After Slackware 11.0 upgrade AC97 sound card using the snd-via82xx driver meetscott Linux - Hardware 3 11-08-2006 12:55 AM
sound card issue ricardof Linux - General 6 02-17-2005 02:55 PM
Sound card issue mpeavy Linux - Hardware 3 01-09-2005 12:55 AM
Sound Card Issue JSThePatriot Linux - Newbie 25 07-28-2004 08:35 PM


All times are GMT -5. The time now is 05:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration