LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-04-2006, 02:33 PM   #1
earnest
LQ Newbie
 
Registered: Oct 2006
Posts: 6

Rep: Reputation: 0
Slackware under Virtual PC blank screen leaving GUI


This is something of an annoyance rather than a critical problem, but I am new at this and don't know where to start looking.

I have tried installing several versions of Slackware into MS Virtual PC. The versions were 10.1, 10.2, and 11. All of these version have a display quirk. The command line runs. GUIs run. Run level was left at the default to not start X. When closing a GUI session the screen goes black. If I type 'reboot -n' or 'shutdown -r now' the virtual machine will reboot but nothing will be seen until the boostrapping from the reboot. This happens if I change the GUI to another using xwmconfig. For 10.1 I downloaded an installed Dropline Gnome and the behavior was the same.

If I am in the GUI and I type ctrl+alt+F2 the screen goes black, but the GUI desktop will reappear with alt+F7.

I am not sure where to start to look to troubleshoot this. Is it a issue with Slackware and the video card, which is Connect 3D Radeon X300, using PCI Express? Is is quirkiness dual to the virtual machine emulating an 8 MB card?

All of the postings that I have found with a similar blank screen issue seem to be the screen going blank at the starting of X, not at the closing.

Any direction would be appreciated.

FWIW I also tried Unbuntu 6.06.1 under Virtual PC and the display went crazy during installation, so I just killed off that attempt.

Last edited by earnest; 10-04-2006 at 02:36 PM.
 
Old 10-05-2006, 12:24 AM   #2
manwichmakesameal
Member
 
Registered: Aug 2006
Distribution: Slackware
Posts: 800

Rep: Reputation: 100Reputation: 100
If you are wanting to try out linux, is dual booting an option for you?
 
Old 10-05-2006, 07:41 AM   #3
earnest
LQ Newbie
 
Registered: Oct 2006
Posts: 6

Original Poster
Rep: Reputation: 0
It might be. What I am going to try today is burning the ISO to disk and installing the distro on a different machine. The only hardware that would be different is the monitor. This would also remove the OS from running hardware. We will see what happens with that experiment.
 
Old 10-05-2006, 12:30 PM   #4
earnest
LQ Newbie
 
Registered: Oct 2006
Posts: 6

Original Poster
Rep: Reputation: 0
On a different machine with the same hardware leaving the GUI to go back to the command prompt works. I tried it under KDE and blackbox. There must be something in the Virtual PC hardware emulation that simply does not like doing this for Slackware.
 
Old 10-05-2006, 04:21 PM   #5
zborgerd
Member
 
Registered: Mar 2004
Distribution: Slackware / Dropline GNOME
Posts: 378

Rep: Reputation: 30
This is normal Slackware behavior for runlevel 4 (with the GDM/KDM/XDM login screen). If you'd prefer it to not start to X11, and have prompts on all of your terminals, you will need to start the system in runlevel 3, otherwise you will only have a usable term on tty6 (F6). You can do this by editing /etc/inittab and changing the default runlevel... E.g.

# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:

to

# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:
 
Old 10-05-2006, 11:41 PM   #6
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
Quote:
Originally Posted by zborgerd
This is normal Slackware behavior for runlevel 4 (with the GDM/KDM/XDM login screen).
He starts in runlevel 3 (see opening post).
 
Old 10-06-2006, 01:19 AM   #7
manwichmakesameal
Member
 
Registered: Aug 2006
Distribution: Slackware
Posts: 800

Rep: Reputation: 100Reputation: 100
If you are in dire need of running it in a VM, have you tried using VMWare? From what I understand, VirtualPc may not be the most linux friendly(wink, wink, nod, nod).
 
Old 10-06-2006, 01:22 PM   #8
earnest
LQ Newbie
 
Registered: Oct 2006
Posts: 6

Original Poster
Rep: Reputation: 0
I am really just using it in Virtual PC to learn another environment while I am at work, so this is more of an annoyance than anything else. Using virtual PC was supposed to be easier and better than setting up another box, but since it is only being used to explore and learn, I will put up with the glitch.

Thanks for all of the help.
 
Old 10-06-2006, 01:41 PM   #9
zborgerd
Member
 
Registered: Mar 2004
Distribution: Slackware / Dropline GNOME
Posts: 378

Rep: Reputation: 30
Could be a matter of a problem with switching between different display types. Do you know if your kernel is using a framebuffer driver or not (e.g. does it start up with a Linux penguin in the top corner)?
 
Old 10-09-2006, 01:08 PM   #10
earnest
LQ Newbie
 
Registered: Oct 2006
Posts: 6

Original Poster
Rep: Reputation: 0
Yes. Tux is in the upper left corner.
 
Old 10-09-2006, 02:56 PM   #11
zborgerd
Member
 
Registered: Mar 2004
Distribution: Slackware / Dropline GNOME
Posts: 378

Rep: Reputation: 30
Quote:
Originally Posted by earnest
Yes. Tux is in the upper left corner.
Try switching it off. Open /etc/lilo.conf, change it to use "vga = normal" instead of a framebuffer, run "lilo" (unless you get weird errors) and restart.
 
Old 10-10-2006, 08:37 AM   #12
earnest
LQ Newbie
 
Registered: Oct 2006
Posts: 6

Original Poster
Rep: Reputation: 0
That worked. I exited and reentered the GUI in Slack 11 under both Blackbox and KDE. I don't have Dropline installed for Slack 11 yet. Thanks very much.

Below is the edited lilo.conf. My changes to the file are dated. Could you explain, or point me to a resource that will explain, what is not working correctly with the default lilo.conf set up?

Thanks again for the help.
Code:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda
message = /boot/boot_message.txt
prompt
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
  reset
# VESA framebuffer console @ 1024x768x256
#vga = 773 commented out 101006
vga=normal # added 101006
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/hda1
  label = Linux
  read-only
# Linux bootable partition config ends
 
Old 10-10-2006, 09:19 AM   #13
zborgerd
Member
 
Registered: Mar 2004
Distribution: Slackware / Dropline GNOME
Posts: 378

Rep: Reputation: 30
Hey. Cool. I love making those sorts of guesses and hitting the target.

Actually, I've seen some problems in the past on non-VM machines and certain videocards. I know that ATI's proprietary drivers (for a long time) could not handle switching between a virtual framebuffer and non-framebuffer modes without graphical glitches or other hangups.

The issue is that you are going from a virtual framebuffer console mode and switching back and forth to something else. In most cases, this works fine, but buggy drivers (or other issues, like running through a VM) aren't ideal operating environments.

The lilo.conf looks (even before modification) fine. Just out of curiosity, which driver are you using in the xorg.conf? I'm curious as to what might be the incompatible driver. Is it an emulated driver that the VM comes with, or is it a real driver?

Here is something that you might be able to do if you want to switch back to a higher res "VGA" framebuffer console. Modify your /etc/X11/xorg.conf to use the "fbdev" driver instead of the driver that it is currently using. It is my understanding that the Slackware default is to use this driver... At least it was for a while. Slackware has an xorg.conf-fdev config file in that same directory, that you can probably use without modification. That way, when your system boots to runlevel 4, and switches to X on tty7, it doesn't actually change modes. It will just use whichever setting you have in the lilo.conf that is used during startup.

The only bummer with using fbdev in X11 is that you don't have 3d accelleration. I'm not sure if this matters to you though, and the VM may not even have 3D support (I've never used it before). Something to consider though.

Last edited by zborgerd; 10-10-2006 at 09:26 AM.
 
Old 02-18-2010, 10:29 PM   #14
R Tanner
Member
 
Registered: Sep 2008
Posts: 96

Rep: Reputation: 15
So I hate to ask this question because it exposes how little I know about linux [right now] but what does tty6/tty7 actually mean? I'm having this same issue with my screen going black. It happened immediately after changing /etc/inittab default runlevel to 4 and rebooting.

Thanks in advance for clearing up my ignorance.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
virtual screen Slackware 10 Ed_999 Slackware 2 05-15-2006 06:37 AM
GUI trouble - screen goes blank walterbyrd VectorLinux 1 10-13-2005 06:44 PM
Second time i boot X on slackware 10.1 it gives a blank screen Occulum Linux - Software 3 08-16-2005 10:48 PM
Blank Screen on Startx with Slackware 10.1 07mackenzie Linux - Hardware 5 05-01-2005 03:01 PM
unable to start x -- blank screen--slackware 9.1 markpelletier Linux - Software 6 11-19-2003 09:56 AM


All times are GMT -5. The time now is 02:07 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration