LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 02-02-2009, 09:33 PM   #1
marcusmercado
Member
 
Registered: Jan 2009
Posts: 30

Rep: Reputation: 15
Slackware: Touchpad Dell D620 scroll not working


I used xorgconfig to autodetect my mouse but the scroll still isnt working. I think I've got synaptics installed as I checked Gslapt and I have this

Code:
/var/log/mount/slackware/x/xf86-input-synaptics-0.15.2-i486-1.tgz
I tried following this post

Code:
http://www.linuxquestions.org/questions/linux-laptop-and-netbook-25/synaptic-touchpad-issues-in-slackware-12.0-632958/
Yet still no luck.

Any idea how I can make it work?
 
Old 02-03-2009, 02:28 AM   #2
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,974

Rep: Reputation: Disabled
Can you post the mouse section of /etc/X11/xorg.conf? It should look something like this:
Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "imPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
The final option (ZAxisMapping) is the one that gets my scroll wheel working on the mouse.

Hint: when posting a link, as you did in your message, don't use the CODE tags but rather use the links button to insert a clickable link.
cheers,
jdk
 
Old 02-03-2009, 12:28 PM   #3
marcusmercado
Member
 
Registered: Jan 2009
Posts: 30

Original Poster
Rep: Reputation: 15
This is mine:

Code:
Section "InputDevice"

# Identifier and driver

    Identifier	"Mouse1"
    Driver	"synaptics"
    Option "Protocol"    "Auto"	# Auto detect
    Option "Device"      "/dev/input/mice"

# Mouse-speed setting for PS/2 mouse.

#    Option "Resolution"	"256"

# Baudrate and SampleRate are only for some Logitech mice. In
# almost every case these lines should be omitted.

#    Option "BaudRate"	"9600"
#    Option "SampleRate"	"150"

# Mouse wheel mapping.  Default is to map vertical wheel to buttons 4 & 5,
# horizontal wheel to buttons 6 & 7.   Change if your mouse has more than
# 3 buttons and you need to map the wheel to different button ids to avoid
# conflicts.

    Option "ZAxisMapping"   "4 5 6 7"

# Emulate3Buttons is an option for 2-button mice
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)

  Option "Emulate3Buttons"	"true"
    Option "Emulate3Timeout"    "50"

# ChordMiddle is an option for some 3-button Logitech mice

#    Option "ChordMiddle"

EndSection
I also added this following the other thread

Code:
Section "InputDevice"
Driver "synaptics"
Identifier "Touchpad"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "LeftEdge" "120"
Option "RightEdge" "830"
Option "TopEdge" "120"
Option "BottomEdge" "650"
Option "FingerLow" "14"
Option "FingerHigh" "15"
Option "MaxTapTime" "0"
Option "MaxTapMove" "110"
Option "EmulateMidButtonTime" "75"
Option "VertScrollDelta" "20"
Option "HorizScrollDelta" "0"
Option "MinSpeed" "0.3"
Option "MaxSpeed" "0.75"
Option "AccelFactor" "0.015"
Option "EdgeMotionMinSpeed" "200"
Option "EdgeMotionMaxSpeed" "200"
Option "UpDownScrolling" "1"
Option "CircularScrolling" "1"
Option "CircScrollDelta" "0.1"
Option "CircScrollTrigger" "2"
  Option "Emulate3Buttons"	"true"
Option "ZAxisMapping" "4 5"
EndSection
I also tried to copy and paste my vector linux xorg.conf to my slackware xorg.conf since VL has scroll working but even when I did I did use the xorg.conf from my VL scroll still isnt working. Could this be a driver problem or so?
 
Old 02-03-2009, 01:24 PM   #4
marcusmercado
Member
 
Registered: Jan 2009
Posts: 30

Original Poster
Rep: Reputation: 15
UPDATE

hmm... I think I found my solution here

http://www.telematica.polito.it/fiore/d620/

I wish there was a quicker way...
 
Old 02-03-2009, 02:08 PM   #5
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
The quicker way may be to run 'xorgsetup' as root when X is not running.
 
Old 02-03-2009, 06:41 PM   #6
marcusmercado
Member
 
Registered: Jan 2009
Posts: 30

Original Poster
Rep: Reputation: 15
Nah I tried xorgsetup too still no luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Touchpad of Dell E4200 not working ItsJustLoco Slackware 3 01-19-2009 03:26 PM
Dell latitude d630 touchpad not works well in Slackware 12.1 john.daker Linux - Hardware 1 11-05-2008 09:11 AM
DSL on Dell Laptop:mouse and touchpad not working same time bongski55 DamnSmallLinux 4 11-19-2007 11:30 AM
touchpad mouse for dell latitude d600 and slackware 10.2 D_O_Y_L_E Linux - Laptop and Netbook 3 03-27-2006 04:38 PM
Dell Inspiron 8600 Touchpad/Slackware 10 Smokey Linux - Laptop and Netbook 2 09-16-2004 02:06 PM


All times are GMT -5. The time now is 11:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration