LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-21-2011, 11:14 AM   #1
Edmis
LQ Newbie
 
Registered: Feb 2010
Distribution: Slackware
Posts: 9

Rep: Reputation: 0
Question Slackware total crash


Hello,
I don't understand why, but my Slackware is totally crash after ~10min work. My guess is Nvidia is fault. Which logs I could see where the problem is? X (startx) work fine. My video card is: geforce 240. installed slackware 13.37 64 bit.

sorry for english

best regards,
Edmundas
 
Old 05-21-2011, 02:03 PM   #2
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,971

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Hello Edmis,

could you please post your /var/log/Xorg.0.log file as an attachment of your post. And please describe in more detail what happened. I'd also recommend to post the output of the following command:
Code:
lspci -k | grep -iA5 video
or, if this gives no output,
Code:
lspci -k | grep -iA5 vga
Markus
 
1 members found this post helpful.
Old 05-21-2011, 03:10 PM   #3
Edmis
LQ Newbie
 
Registered: Feb 2010
Distribution: Slackware
Posts: 9

Original Poster
Rep: Reputation: 0
Hello Markush,

Added xorg.0.log.

Quote:
And please describe in more detail what happened.
Usually crash slackware when i try listen music or watch films or browse in web (noticed). When slackware is crash i need reboot my computer manually (turn of power).

Code:
edmis:/home/edmis# lspci -k | grep -iA5 vga
05:00.0 VGA compatible controller: nVidia Corporation GT215 [GeForce GT 240] (rev a2)
        Subsystem: Micro-Star International Co., Ltd. Device 8041
        Kernel driver in use: nouveau
        Kernel modules: nouveau, nvidiafb
05:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)
        Subsystem: Micro-Star International Co., Ltd. Device 8041
Thanks for replay
Attached Files
File Type: log Xorg.0.log (39.0 KB, 3 views)
 
Old 05-21-2011, 03:39 PM   #4
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,039
Blog Entries: 52

Rep: Reputation: Disabled
Code:
Kernel driver in use: nouveau
You might be better off with the NVidia driver. Get the latest one here:

http://www.nvidia.com/object/unix.html

Last edited by brianL; 05-21-2011 at 03:41 PM.
 
1 members found this post helpful.
Old 05-21-2011, 03:47 PM   #5
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,971

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
As brianL stated, you may (before starting the X-server) unload the nouveau module
Code:
rmmod nouveau
and load the nvidia-driver instead
Code:
modprobe nvidiafb
You may as well blacklist the nouveau module in the /etc/modprobe.d/blacklist.conf file.

Markus
 
1 members found this post helpful.
Old 05-21-2011, 04:01 PM   #6
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,039
Blog Entries: 52

Rep: Reputation: Disabled
The NVIDIA-Linux-whatevernumber.run file builds and loads the module for you.
 
1 members found this post helpful.
Old 05-22-2011, 04:58 AM   #7
Edmis
LQ Newbie
 
Registered: Feb 2010
Distribution: Slackware
Posts: 9

Original Poster
Rep: Reputation: 0
Thanks guys! I think it work fine!

Code:
root@edmis:/home/edmis# lspci -k | grep -iA5 vga
05:00.0 VGA compatible controller: nVidia Corporation GT215 [GeForce GT 240] (rev a2)
        Subsystem: Micro-Star International Co., Ltd. Device 8041
        Kernel driver in use: nvidia
        Kernel modules: nvidia, nouveau, nvidiafb
05:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)
        Subsystem: Micro-Star International Co., Ltd. Device 8041
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Total crash after modifying Cairo-Dock! gho6uuu Linux - Desktop 0 01-23-2009 05:17 AM
Random total system crash paju Linux - Hardware 3 03-23-2008 08:15 AM
Slackware Install by total newbie TrevorS Slackware 22 05-13-2006 08:30 PM
Total Kernel crash with alsa and midi OrbWeaver Linux - General 0 08-07-2004 06:44 AM
Americas Army 1.9 + Suse 9.0 = total crash! help! xyzo Linux - Games 0 11-21-2003 09:53 AM


All times are GMT -5. The time now is 04:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration