LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-18-2007, 09:26 AM   #1
contact.raj
LQ Newbie
 
Registered: Apr 2007
Posts: 1

Rep: Reputation: 0
Slackware startup with GUI


Hi,

I have installed slackware 10.1 on my machine. Upon booting, I got into the prompt mode. Then to make it startup with GUI, I tried entering "startx" at the command prompt. But I can see only a blank screen & the machine halts, no errors, no mouse pointer. Then I followed the following method found in a forum

Edited the file /etc/inittab. Found the line that says id:3:initdefault: and changed it to id:4:initdefault: Rebooted the system to startup with GUI but this time after booting up the blank screen appears directly & I couldn't proceed. Pls help me on this & let me know what to do to make slackware bootup with GUI & not to see the blank screen.

Thanks,
Raj
 
Old 04-19-2007, 12:46 AM   #2
Penguin of Wonder
Senior Member
 
Registered: Sep 2005
Location: West Virginia
Distribution: Gentoo
Posts: 1,249

Rep: Reputation: 45
Well, my first question then, and not to insult you, but did you actually install a "gui" to use?

If you've already installed X then your blank screen is probably the result of a bad xorg.conf configuration.
 
Old 04-19-2007, 12:57 AM   #3
vtel57
Member
 
Registered: Jul 2006
Location: Tampa, FL, USA
Distribution: Slackware64
Posts: 912

Rep: Reputation: 103Reputation: 103
If you can get back to a command line, use the xorgconfig command to set up your X.

Code:
(as Root) # xorgconfig
Before you do that, you might just want to type at the command line:

Code:
# whereis X
You should get some output like this:

Quote:
X: /usr/bin/X /usr/X11R6/bin/X /usr/bin/X11/X
If not, then you probably don't have the X Windows System part of Slack installed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GUI is freezing on startup marie@dk Linux - Laptop and Netbook 2 09-29-2005 01:44 PM
GUI startup David_Moses Red Hat 5 03-31-2005 04:04 PM
No GUI at startup - SuSE Quiber Linux - Software 3 01-11-2005 02:08 AM
how to startup in GUI mode vspurlin Linux - Software 2 08-17-2003 09:20 PM
gui startup--automatic hpglow Linux - Newbie 3 07-22-2003 01:07 PM


All times are GMT -5. The time now is 12:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration