LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-22-2002, 03:41 PM   #1
jamaso
Member
 
Registered: Oct 2001
Location: brasil
Distribution: mdrk 8.0,redht7.1,debianpotato
Posts: 615

Rep: Reputation: 30
Slackware sound instalation


When i booted the computer i got these lines :

es 1371 : version v0.30 time....
pci : found irq 10 for device 00:0f.0
pci : the same irq used for device 00:04.5
es 1371 : found chip vendor
es 1371 : found es1371 rev8 at io 0xcc0 irq 10
es 1371 : features joy...
ac 97_codec : AcC97 audio codec , id : 0x4352 : 0x5913 (cirrus logic cs 4297 A revA)

What i wanted to ask is :
1 Why does line "ac97 codec" shows up after i uncomment 1371 module if i have a sound blaster on ?
2 Can those two pci lines have something to do with a conflict (meaning two devices on same irq ) ?


Previously i asked about Kernel compiling information for i thought it was the last thing to do to get my sound card work on Slackware , man i was vain . I guess i'm far away in space to get this one done . Love Slak
tough.


et pluribus unum
 
Old 01-22-2002, 04:50 PM   #2
isajera
Senior Member
 
Registered: Jun 2001
Posts: 1,635

Rep: Reputation: 45
the es1371 soundcard (it's the one i have) needs the ac97_codec module to run properly. it should be autoloaded whenever the es1371 is loaded. do you have the es1371 specified in modules.conf?
 
Old 01-22-2002, 07:06 PM   #3
jamaso
Member
 
Registered: Oct 2001
Location: brasil
Distribution: mdrk 8.0,redht7.1,debianpotato
Posts: 615

Original Poster
Rep: Reputation: 30
Excuse my ignorance , but what is modules.conf ?
 
Old 01-23-2002, 12:16 AM   #4
isajera
Senior Member
 
Registered: Jun 2001
Posts: 1,635

Rep: Reputation: 45
it's a configuration file that lists the modules that the kernel will load for a given function - if i remember correctly, the line is

alias char-major-14 es1371

i think that's right. (someone correct me if i'm wrong!) the modules.conf file is located in the /etc directory. just use any text editor to find the line in the file - it's probably either commented out with a # or turned off - like this

alias char-major-14 off
#alias char-major-14 es1371

you just need to make sure that the correct modules is specified, and that should be all you need to get the sound working.
 
Old 01-23-2002, 04:55 AM   #5
jamaso
Member
 
Registered: Oct 2001
Location: brasil
Distribution: mdrk 8.0,redht7.1,debianpotato
Posts: 615

Original Poster
Rep: Reputation: 30
I got the followoing :
Quote:
alias : 'char-major-14' not found
Quote:
alias: 'es1371' not found
 
Old 01-23-2002, 05:16 AM   #6
jamaso
Member
 
Registered: Oct 2001
Location: brasil
Distribution: mdrk 8.0,redht7.1,debianpotato
Posts: 615

Original Poster
Rep: Reputation: 30
i went to jed on /etc/modules.conf and found only this two modules (?) :
Quote:
alias net-pf-4 off # we won't use pf ipx
Quote:
alias net-pf-5 off # we won't use pf appletalk
 
Old 01-23-2002, 05:21 AM   #7
jamaso
Member
 
Registered: Oct 2001
Location: brasil
Distribution: mdrk 8.0,redht7.1,debianpotato
Posts: 615

Original Poster
Rep: Reputation: 30
Should i insert the line that you said above?
 
Old 01-23-2002, 07:03 AM   #8
jamaso
Member
 
Registered: Oct 2001
Location: brasil
Distribution: mdrk 8.0,redht7.1,debianpotato
Posts: 615

Original Poster
Rep: Reputation: 30
I inserted the line
Quote:
alias char-major-14 se1371
and also i was told in another recent thread to chmod 755 /dev/mixer and /dsp but when i did i didn't get it to work . You know what? I remember a thread about not chmod 777 for being a serious security hole ( by SICKBOY), i did chmod 777 and it worked . Thanks a lot . I guess now i hope i can say goodbye to all other distros.


et pluribus unum
 
Old 01-23-2002, 02:37 PM   #9
isajera
Senior Member
 
Registered: Jun 2001
Posts: 1,635

Rep: Reputation: 45
chmod 777 is the command to set the mode on any file for full permissions to all users - it's not a good thing to have set to an important sbin executable, but it's not a serious security problem for an output device like /dev/dsp or /dev/mixer.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
iproute2 , kernel 2.4.24 , slackware 9.0 instalation problem varzosu Slackware 1 02-07-2004 08:48 PM
WUSB11 Driver Instalation on Slackware 9.1 wardyxpordy Linux - Networking 0 10-17-2003 06:26 PM
adding a hard disk after instalation (slackware) kyoukan Linux - Distributions 6 05-11-2003 09:48 AM
Slackware fails to boot after instalation. adaminferior Slackware 7 09-09-2002 12:21 PM
help for slackware instalation!! SiNaXe Linux - General 5 06-01-2002 01:11 AM


All times are GMT -5. The time now is 11:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration