LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-01-2004, 07:49 PM   #1
infamous41md
Member
 
Registered: Mar 2003
Posts: 804

Rep: Reputation: 30
slackware problem with aterm && mouse wheel


decided to give slack a go, and all is well except 1 puzzling problem and a stupid question as well.
dumb question: my mouse wheel doesn't do anything, i believe it's b/c i selected the wrong mouse. where can i reconfig that?
and the major problem im having is that aterm doesnt seem to work correctly. i can't use Ctrl-l to clear the screen in aterm, and when i try to use vi it doesnt work correctly. the file doesnt appear correctly, only the first line appears and its stuck halfway down the screen. i've always used aterm on debian and redhat without problems. both times i have intalled slack i had this problem and couldnt resolve it. i really need aterm and vi so i can get to hackin here, any help is much appreciated. thanks
 
Old 01-01-2004, 07:56 PM   #2
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 63
Hi infamous41md!!!

Yeah. The mouse wheel button won't work right away on Slackware. The solution is pretty simple though. Open and edit your /etc/X11/XFree86Config. Scroll it down until you find something like Imput Devices, or Pointer Devices and add the lines:

Code:
# Identifier and driver

    Option 	"Protocol"	"IMPS/2"

    Option	"ZAxisMapping"	"4 5"
    Option	"Emulate3Buttons"	"no"
Restart X Server. That would do it. About vim, I don't know. I use Aterm and Vim myself without problems. You may want to give gvim (a gtk version of vim) a shot though. Pretty good for programming and nice syntax highlighting

Regards!
 
Old 01-01-2004, 08:03 PM   #3
infamous41md
Member
 
Registered: Mar 2003
Posts: 804

Original Poster
Rep: Reputation: 30
mouse fix worked just as posted, cheers! i guess im going to have to dig deeper with this vim problem i guess; thanks for the help.
 
Old 01-01-2004, 08:04 PM   #4
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 63
My pleasure
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
You passed an undefined mode number & wheel mouse dave`2005 Linux - Newbie 8 08-28-2005 11:38 AM
(FreeBSD && Fedora Core 4 && Slackware 10.0) Filesystem Support taylor_venable *BSD 1 07-14-2005 02:24 PM
Phục hồi dữ liệu bị mất???, cứ pollsite General 1 06-27-2005 12:39 PM
Cordless Mouse & Mouse Wheel Issues! simsjr Slackware 6 04-22-2004 04:57 PM
USB keyboard & mouse problem in Slackware 9.1 Wonderer Slackware 12 10-28-2003 11:06 AM


All times are GMT -5. The time now is 05:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration