LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-19-2015, 08:22 PM   #1
fbnccst
LQ Newbie
 
Registered: May 2015
Location: Cairo, Egypt
Distribution: Slackware
Posts: 7

Rep: Reputation: Disabled
Question slackware only detects one core out of a core 2 duo processor


My thinkpad x200 is running on slackware 14.1. I am aware that my device is powered by a core 2 duo processor and Windows proved it to be so. But slackware says that my laptop only has 1 cpu. I became aware of it after configuring conky. Later on i checked it using lscpu and some similiar tools.
How can I fix it?
Thank you.
 
Old 05-19-2015, 09:17 PM   #2
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mint, OpenBSD
Posts: 11,359
Blog Entries: 12

Rep: Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740
Could you provide more detailed information, such as the manufacturer's specs and the output of the diagnostic tools that you ran?

The more detailed the information you provide, the easier it will be for others to try to help you.
 
1 members found this post helpful.
Old 05-20-2015, 12:10 AM   #3
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: Oregon, USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 5,193
Blog Entries: 3

Rep: Reputation: 695Reputation: 695Reputation: 695Reputation: 695Reputation: 695Reputation: 695
Hi...

Welcome to the forum

In addition to what frankbell has requested, please open a terminal and post the outputs of these commands...

Code:
lspci -nnk
Code:
cat /proc/cpuinfo | grep 'core id'
Thanks!
 
1 members found this post helpful.
Old 05-20-2015, 12:47 AM   #4
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,433
Blog Entries: 6

Rep: Reputation: Disabled
Here's some more commands you can run for information.

http://stackoverflow.com/questions/1...n-command-line
 
1 members found this post helpful.
Old 05-20-2015, 01:26 AM   #5
mralk3
Member
 
Registered: May 2015
Posts: 760

Rep: Reputation: 232Reputation: 232Reputation: 232
I recommend compiling a kernel tailored to your particular machine for improved performance. I just switched from Debian to Slackware and did exactly that. Now my laptop is running faster than it has in years using Slackware.

Slackware ships with kernels that are very generic. Slackware boots kernel-huge-3.10.17-2 by default. You could try switching to the generic kernel (also version 3.10.17) and creating a initrd (initial ram disk) to load necessary modules for your hard ware on boot. I found booting with a pre-packaged kernel to be slower and my system had poorer performance.

Take a look at the Slackware beginner's guide and more closely at this portion of the guide for switching to the faster generic kernel using a initrd..

Additionally, you may need to boot the machine with different boot parameters from the lilo prompt for it to load the correct drivers for your machine.
 
1 members found this post helpful.
Old 05-20-2015, 08:30 AM   #6
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
Both CPUs are detected and working on my X200 according to htop. Could it just be a problem with Conky (never used it myself)? See what htop says.

Last edited by brianL; 05-20-2015 at 08:34 AM.
 
1 members found this post helpful.
Old 05-20-2015, 09:12 AM   #7
mralk3
Member
 
Registered: May 2015
Posts: 760

Rep: Reputation: 232Reputation: 232Reputation: 232
Quote:
Originally Posted by brianL View Post
Both CPUs are detected and working on my X200 according to htop. Could it just be a problem with Conky (never used it myself)? See what htop says.

According to the conkyrc configuration settings, for variable:

Code:
variable:  top_cpu_separate

If true, cpu in top will show usage of one processor's power. If false, cpu in top will show the usage of all processors' power combined.
 
1 members found this post helpful.
Old 05-20-2015, 09:03 PM   #8
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mint, OpenBSD
Posts: 11,359
Blog Entries: 12

Rep: Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740
FWIW, the generic Slackware kernel (3.18.11 SMP) does detect my CPU properly.

Code:
$ lscpu
Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                4
On-line CPU(s) list:   0-3
(snip)
 
1 members found this post helpful.
Old 05-24-2015, 05:42 PM   #9
fbnccst
LQ Newbie
 
Registered: May 2015
Location: Cairo, Egypt
Distribution: Slackware
Posts: 7

Original Poster
Rep: Reputation: Disabled
Smile

Thank you very much seniors. I've been meaning to reply and provide you all with sufficient details about the problem, but my internet was down. I could barely open linuxquestion.org page.

I think the problem is solved now, i recompiled the kernel and enabled SMP.
Much obliged!
 
Old 05-24-2015, 08:45 PM   #10
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,433
Blog Entries: 6

Rep: Reputation: Disabled
Quote:
Originally Posted by fbnccst View Post
Thank you very much seniors. I've been meaning to reply and provide you all with sufficient details about the problem, but my internet was down. I could barely open linuxquestion.org page.

I think the problem is solved now, i recompiled the kernel and enabled SMP.
Much obliged!
Did you find that you didn't have SMP originally enabled?

I've read where recompiling does wonders.-
 
Old 05-24-2015, 10:27 PM   #11
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: Oregon, USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 5,193
Blog Entries: 3

Rep: Reputation: 695Reputation: 695Reputation: 695Reputation: 695Reputation: 695Reputation: 695
Quote:
Originally Posted by fbnccst View Post
Thank you very much seniors.
You're welcome but I'm only 43.

Glad you were able to fix the problem.

Regards...
 
Old 05-25-2015, 04:36 AM   #12
fbnccst
LQ Newbie
 
Registered: May 2015
Location: Cairo, Egypt
Distribution: Slackware
Posts: 7

Original Poster
Rep: Reputation: Disabled
Smile

Quote:
Originally Posted by Ztcoracat View Post
Did you find that you didn't have SMP originally enabled?

I've read where recompiling does wonders.-
When googling about recompiling kernel i found SMP related articles, later on i found it was not enabled in my kernel configuration.
 
Old 05-25-2015, 04:40 AM   #13
fbnccst
LQ Newbie
 
Registered: May 2015
Location: Cairo, Egypt
Distribution: Slackware
Posts: 7

Original Poster
Rep: Reputation: Disabled
Smile

Quote:
Originally Posted by ardvark71 View Post
You're welcome but I'm only 43.
, without mentioning experience and knowledge in linux, that is still 20 years my senior
 
Old 05-25-2015, 10:08 PM   #14
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mint, OpenBSD
Posts: 11,359
Blog Entries: 12

Rep: Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740Reputation: 2740
I'm only ten in Linux years, but I'll take the "old timer."

I've waited all my life the be a grumpy old man and I've finally made it!

And congrats, fbnccst, on fixing this. Nice job of diagnosis and cure.

Last edited by frankbell; 05-25-2015 at 10:10 PM.
 
1 members found this post helpful.
Old 05-26-2015, 12:07 AM   #15
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,433
Blog Entries: 6

Rep: Reputation: Disabled
Quote:
Originally Posted by fbnccst View Post
When googling about recompiling kernel i found SMP related articles, later on i found it was not enabled in my kernel configuration.
Glad you discovered the issue. Bet your glad:-

I'll except the title "Senior" I'm close to 50-

-:-Have a good rest of the week fbnccst and enjoy your Slackware-:-
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Core duo processor rombin Linux - Newbie 3 01-25-2009 09:18 PM
Help Regarding Motherboard for Core 2 Duo Processor. anant.vyas Linux - Hardware 1 03-03-2008 02:13 PM
Kernel Panic on Intel Core 2 Duo E6700 Dual Core Processor nwongrat Linux - Hardware 2 01-08-2008 11:13 PM
Fedora on Core 2 Duo Processor cjediknight Linux - Hardware 1 02-14-2007 01:49 PM
Intel Core Duo Processor mtzo81 Linux - Laptop and Netbook 7 06-15-2006 02:34 PM


All times are GMT -5. The time now is 09:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration