LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-09-2006, 08:24 PM   #1
sah
LQ Newbie
 
Registered: Jul 2006
Posts: 4

Rep: Reputation: 0
Slackware new install - how to start gui?


I am a complete linux newbie. I just installed Slackware linux 10.2. During the install, I chose the xfce gui. However, when slackware rebooted, it is booting to the command prompt and not the gui.

1. How do I manually start the gui?
2. If I decide I want the gui to start automatically when it boots, how do I set that up?
3. How do I switch between guis?

thanks!
 
Old 08-09-2006, 08:31 PM   #2
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,960

Rep: Reputation: 333Reputation: 333Reputation: 333Reputation: 333
You need to edit your /etc/inittab file.

Look for this part:
Code:
# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:
Change the 3 in that line to a 4.
 
Old 08-09-2006, 08:31 PM   #3
Okie
Member
 
Registered: Mar 2002
Location: Oklahoma
Posts: 977

Rep: Reputation: 36
check if xwmconf is set to xfce, then type in startx
 
Old 08-10-2006, 10:25 AM   #4
sah
LQ Newbie
 
Registered: Jul 2006
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Okie
check if xwmconf is set to xfce, then type in startx
Where do I find/edit xwmconf? Thanks!
 
Old 08-10-2006, 10:38 AM   #5
faref
LQ Newbie
 
Registered: Jan 2004
Distribution: Slackware, Ubuntu
Posts: 25

Rep: Reputation: 15
type it at the command line.
 
Old 08-10-2006, 11:04 AM   #6
Chromezero
Member
 
Registered: Nov 2004
Location: Arizona
Distribution: Slackware, RHEL, others
Posts: 470

Rep: Reputation: 40
Code:
startx
at the command line will start the x server. However, you'll want to edit /etc/inittab if you choose to use gui on a regular basis.
 
Old 03-24-2013, 06:18 PM   #7
hmazuji
LQ Newbie
 
Registered: Dec 2005
Posts: 3

Rep: Reputation: 0
i have the same problem

i got the change runlevel from 3 to 4. why does it ship out of the box to runlevel 3 ? is it like, the first thing you need to learn is how to edit the inittab file ? also, how to do that at the command prompt ? is vi intuitive ? this is a complaint, not a request for information. thanks. thank you for the solution.
 
Old 03-24-2013, 06:55 PM   #8
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 4,429

Rep: Reputation: 1348Reputation: 1348Reputation: 1348Reputation: 1348Reputation: 1348Reputation: 1348Reputation: 1348Reputation: 1348Reputation: 1348Reputation: 1348
Quote:
why does it ship out of the box to runlevel 3 ?
Two reasons are: 1) Not all Slackware installs are used from a GUI and 2) it allows a user to experiment with settings in /etc/X11/xorg.conf for graphics devices that require additional configuration.
Quote:
how to do that at the command prompt ? is vi intuitive ?
You may prefer to use nano, which has on-screen help.
 
Old 03-24-2013, 10:29 PM   #9
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mint, OpenBSD
Posts: 11,333
Blog Entries: 12

Rep: Reputation: 2729Reputation: 2729Reputation: 2729Reputation: 2729Reputation: 2729Reputation: 2729Reputation: 2729Reputation: 2729Reputation: 2729Reputation: 2729Reputation: 2729
xwmconfig is a Slackware utility for changing your GUI. It displays a list of installed DEs/window managers and allows you to change them without having to edit inittab directly.

It is the preferred way to change your DE/window manager in Slackware.
 
Old 03-24-2013, 10:54 PM   #10
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,960

Rep: Reputation: 333Reputation: 333Reputation: 333Reputation: 333
Quote:
Originally Posted by hmazuji View Post
this is a complaint, not a request for information.
It's just a hunch, but I think that you may have chosen the wrong distro...

Slackware doesn't hold your hand or spoonfeed you the way some others do.

You'll find that most people here like it that way, because that's what makes it so powerful and flexible.

You can complain all you like, but you should know that there are technical reasons for not booting into the GUI by default.

If that doesn't suit you, then you are always welcome to try Ubuntu.
 
Old 03-25-2013, 12:23 AM   #11
JWJones
Member
 
Registered: Jun 2009
Location: Cascadia
Distribution: Slackware
Posts: 922

Rep: Reputation: 276Reputation: 276Reputation: 276
Hmm, this thread is originally from 2006. Four posts... something tells me "sah" has moved on.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Start w/ GUI SLP Slackware 6 01-31-2006 11:42 AM
cant start GUI adamherb Mandriva 1 08-10-2005 12:30 AM
First Linux install (Slackware), not off to a good start Feminista Linux - Newbie 12 02-04-2005 08:35 PM
Cant Start GUI hexx Debian 7 08-19-2003 11:36 AM
Slackware 9, full install, gnome won't start because system "can't find fonts" sketelsen Slackware 2 08-01-2003 11:14 AM


All times are GMT -5. The time now is 06:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration