LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-23-2009, 08:04 AM   #46
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled

Hmm, I'm not sure. Are you sure that's the correct network? Did you check the MAC address (click "Properties" for the network and then "Information")? Could you also post your config file, /etc/wicd/wireless-settings.conf? Obviously, please remove any keys present in said file.
 
Old 12-23-2009, 08:11 AM   #47
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Original Poster
Rep: Reputation: 146Reputation: 146
Quote:
Originally Posted by Nylex View Post
Hmm, I'm not sure. Are you sure that's the correct network? Did you check the MAC address (click "Properties" for the network and then "Information")? Could you also post your config file, /etc/wicd/wireless-settings.conf? Obviously, please remove any keys present in said file.
I am for sure that it isn't a User error, my connection has 100% signal strength while the others one don't even reach 20%.

I will go and grab that information for you. Will the password be a hash or cleartype?

EDIT: I will also check the MAC. But I think it is right.

Oh, and two things: my networks name is "Access Denied," so don't let that influence your intrepretation of the log file.

The other thing is I just confirmed that using a passphrase instad of a PSK did not change much. The connection still failed; with same error.

Thanks Again for your help; I know this is an odd case.

Last edited by lupusarcanus; 12-23-2009 at 08:15 AM.
 
Old 12-23-2009, 08:13 AM   #48
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Quote:
Originally Posted by leopard View Post
I am for sure that it isn't a User error, my connection has 100% signal strength while the others one don't even reach 20%.
OK, fair enough.

Quote:
I will go and grab that information for you. Will the password be a hash or cleartype?
The passwords will be in plain text (which I assume you mean by "cleartype").
 
Old 12-23-2009, 08:18 AM   #49
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Original Poster
Rep: Reputation: 146Reputation: 146
Quote:
Originally Posted by Nylex View Post
OK, fair enough.



The passwords will be in plain text (which I assume you mean by "cleartype").
Yes that is a correct assumption, sorry.
Oh and I edited the post above; please take another glance at it, its important.
All right then, I'll be back in a minute.

Oh and let me Thank you for your hard work.
 
Old 12-23-2009, 08:25 AM   #50
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Original Poster
Rep: Reputation: 146Reputation: 146
Ok, I was just using Windows for a moment to check the MAC address of my router. I'll make sure I compare that to the MAC listed in Linux
 
Old 12-23-2009, 08:47 AM   #51
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Original Poster
Rep: Reputation: 146Reputation: 146
Here is the wireless settings:
Code:
[00:23:69:FF:44:DD]
afterscript = None
bssid = 00:23:69:FF:44:DD
postdisconnectscript = None
dns_domain = None
quality = 100
gateway = None
use_global_dns = 0
strength = -30
encryption = True
bitrates = 1 Mb/s
ip = None
beforescript = None
hidden = True
channel = 6
essid = <hidden>
psk = was a hash
has_profile = True
netmask = None
key = was plain text
predisconnectscript = None
enctype = wpa
dns3 = None
dns2 = None
search_domain = None
use_settings_globally = 0
use_static_dns = 0
apsk = was plain text
encryption_method = WPA2
mode = Master
automatic = True
dns1 = None
The Physical Address (looks like a MAC) that Windows System Tray Icon for WLAN -> Support -> Details is not the same one listed in this file. I don't know, however, if the Physical Address and the MAC are the same thing or not.

Just a question...

Does Slackware come with aircrack-ng?

Thanks.
 
Old 12-23-2009, 08:54 AM   #52
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
What if you change "enctype = wpa" to "enctype = wpa-psk"? You may need to restart wicd for this to take effect, which you can do with "/etc/rc.d/rc.wicd restart".

Other than that, I'm not sure I'm afraid.

As for aircrack-ng, Slackware doesn't have a package for it, but you can get a SlackBuild script for it from www.slackbuilds.org. SlackBuild scripts are used to build Slackware packages.

Edit: also, perhaps report your thread and ask for it to be moved to the Slackware forum - you're likely to get better help if someone in there sees it.

Last edited by Nylex; 12-23-2009 at 08:55 AM.
 
Old 12-23-2009, 08:58 AM   #53
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Original Poster
Rep: Reputation: 146Reputation: 146
Well, I was thinking of using aircrack-ng to see whether or not the MAC listed in that files is correct or not; but I forget if this wireless card supports monitor mode.

I will be sure to try changing the enctype = wpa to enctype = wpa-psk.
Also, what if I changed it to: enctype = wpa2-psk
Would that help?
 
Old 12-23-2009, 09:01 AM   #54
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
The documentation (man page for wicd-wireless-settings.conf) says

Quote:
enctype = <encryption_template>
This can take the value of any encryption template shown in
/etc/wicd/encryption/templates/.
Since there is no file called wpa2-psk in that directory, I assume you'd get some kind of error.
 
Old 12-23-2009, 09:03 AM   #55
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Original Poster
Rep: Reputation: 146Reputation: 146
Worth a shot. I'll be back in a minute
 
Old 12-23-2009, 09:13 AM   #56
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Original Poster
Rep: Reputation: 146Reputation: 146
No, it didn't work :/
 
Old 12-23-2009, 09:25 AM   #57
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Unfortunately, I'm out of ideas . Hopefully when this gets moved to the Slackware forum, someone will have an idea.

Having said that, what I would do is to try and connect without wicd. So, you'll want to stop the wicd service (/etc/rc.d/rc.wicd stop). Then, you'll need to edit the config file for WPA Supplicant, /etc/wpa_supplicant.conf (in there, it tells you where you can find a sample config file to see the options you can use). Once you've done that, do

ifconfig wlan0 up
wpa_supplicant -c/etc/wpa_supplicant.conf -Dwext -iwlan0

If the wpa_supplicant command gives promising output, then do

dhcpcd wlan0

to get an IP address. You'll probably need to run dhcpcd in another terminal, because of wpa_supplicant.
 
Old 12-23-2009, 11:07 PM   #58
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Original Poster
Rep: Reputation: 146Reputation: 146
Quote:
Originally Posted by Nylex View Post
Unfortunately, I'm out of ideas . Hopefully when this gets moved to the Slackware forum, someone will have an idea.

Having said that, what I would do is to try and connect without wicd. So, you'll want to stop the wicd service (/etc/rc.d/rc.wicd stop). Then, you'll need to edit the config file for WPA Supplicant, /etc/wpa_supplicant.conf (in there, it tells you where you can find a sample config file to see the options you can use). Once you've done that, do

ifconfig wlan0 up
wpa_supplicant -c/etc/wpa_supplicant.conf -Dwext -iwlan0

If the wpa_supplicant command gives promising output, then do

dhcpcd wlan0

to get an IP address. You'll probably need to run dhcpcd in another terminal, because of wpa_supplicant.
I tried to do that. Every time I tried to run my script it wouldn't accept my password because it wasn't the right kind.

In the help file that the .conf file pointed me too, there was only a short snippet about using wpa_passphrase to generate the special kind of password, but it didn't say how I implement it into the script.

Last edited by lupusarcanus; 12-23-2009 at 11:09 PM.
 
Old 12-23-2009, 11:12 PM   #59
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Original Poster
Rep: Reputation: 146Reputation: 146
I also tried to run dhcpcd wlan0 in a terminal while wicd ran and it hung for a long time (much longer than before) then it connected with O% signal strength, then lost the connection again. (fairly quickly).
 
Old 12-23-2009, 11:48 PM   #60
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Original Poster
Rep: Reputation: 146Reputation: 146
Is this a can-do-with-lots-of-work or is it a straight out cant-do-period?
I can not stand using Windows anymore. Should I just use Ubuntu and wait for a new Slackware with a newer kernel to come out before I try it again?
I have tried to install Debian too, and it had similar problems.
I think these more stable, slow-to-release Linux distros just haven't got the newer kernel I need to run my system.
If this last piece of info is of any use at all, I am for sure that my Ubuntu install used the ath5k driver for wireless and atl1c for Ethernet. Thanks...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
File system errors when booting up galapogos Mandriva 5 03-06-2009 01:38 AM
Can i know the Linux os which can be installed on system with any errors ?? nomisvic Linux - Hardware 10 05-28-2008 10:45 AM
File System with errors nardz Linux - General 4 11-29-2007 06:57 AM
Installed Slackware 10.2 cannot get internet access davscott666 Linux - Networking 3 04-05-2006 11:59 AM
File system with errors naski666 Linux - Newbie 18 06-25-2003 07:30 AM


All times are GMT -5. The time now is 06:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration