LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-24-2005, 10:33 AM   #1
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 59
slackware: how to shutdown (seriously)


in my slackware install there is no 'shutdown' button or something like this, normally there is in other distros. there is a logout button, which exits X and then brings me to the initial console. that i guess would be fine if i can just type one command to shutdown the computer, but it doesnt seem to be the case.

i have tried commands like shutdown, shutoff, poweroff, but they dont work. the only one that does something is 'powerdown' (only when root) and this still doesnt work. this command seems to work at first.. it gives output like 'sending term signal to all...' etc etc... and finally says 'Powerdown.' but stays there (over 8hours, i left it like that all night). so every tiem i have done a hard shutdown at this screen... and i dont think this is the way it should be done.

so, right now i have to: click logout, wait for x to exit, login as root, type powerdown, wait for that to finish, then hard shutdown the computer... when all i normally would have to do is click shutdown from a gui.

any help appreciated.
 
Old 04-24-2005, 10:47 AM   #2
hussar
Member
 
Registered: Oct 2003
Location: Heidelberg, Germany
Distribution: Slackware 11.0; Kubuntu 6.06; OpenBSD 4.0; OS X 10.4.10
Posts: 345

Rep: Reputation: 30
Try:

su -c "shutdown -h now"

and let us know (after your reboot) if it works.

Also, look at the ACCESS CONTROL section of the shutdown manpage. It will explain how to set up CTL+ALT+DEL so you can use this key sequence or `shutdown -a` as a user to shut down the machine.
 
Old 04-24-2005, 10:50 AM   #3
Boow
Member
 
Registered: Feb 2004
Distribution: Slackware 10.2
Posts: 669

Rep: Reputation: 32
I use the 2.6 kernel and acpi and acpid. I modprobe button then i can shutdown the pc by pressing the button.
 
Old 04-24-2005, 11:01 AM   #4
hussar
Member
 
Registered: Oct 2003
Location: Heidelberg, Germany
Distribution: Slackware 11.0; Kubuntu 6.06; OpenBSD 4.0; OS X 10.4.10
Posts: 345

Rep: Reputation: 30
Whoops! I think I misunderstood the question. Re-reading your initial post, it seems that you are already able to use shutdown to go through the shutdown sequences. The problem is that the machine is not turning itself off.

Have you used another distro on that machine, and did shutdown or hitting a shutdown button shut the machine down and turn it off?
 
Old 04-24-2005, 11:44 AM   #5
simon_w
Member
 
Registered: Jun 2004
Location: UK
Distribution: Debian Etch
Posts: 71

Rep: Reputation: 15
Re: slackware: how to shutdown (seriously)

Quote:
Originally posted by nadroj
in my slackware install there is no 'shutdown' button or something like this, normally there is in other distros.
Have a look around in the Control Center (I'm running KDE 3.4), somewhere there's an optional to add this button to the K-menu. I only found it a couple of days ago
 
Old 04-24-2005, 02:55 PM   #6
nitrousoxide82
Member
 
Registered: Apr 2005
Location: Rio de Janeiro, Brazil
Distribution: Ubuntu 9.04 (Jaunty), Arch Linux 2009.08
Posts: 83

Rep: Reputation: 17
Re: slackware: how to shutdown (seriously)

Quote:
Originally posted by nadroj
in my slackware install there is no 'shutdown' button or something like this, normally there is in other distros. there is a logout button, which exits X and then brings me to the initial console. that i guess would be fine if i can just type one command to shutdown the computer, but it doesnt seem to be the case.

i have tried commands like shutdown, shutoff, poweroff, but they dont work. the only one that does something is 'powerdown' (only when root) and this still doesnt work. this command seems to work at first.. it gives output like 'sending term signal to all...' etc etc... and finally says 'Powerdown.' but stays there (over 8hours, i left it like that all night). so every tiem i have done a hard shutdown at this screen... and i dont think this is the way it should be done.

so, right now i have to: click logout, wait for x to exit, login as root, type powerdown, wait for that to finish, then hard shutdown the computer... when all i normally would have to do is click shutdown from a gui.

any help appreciated.
Is apmd running on your machine when you do that? apmd is the APM (Advanced Power Management) daemon for Linux which manages that function (and sends the power down command to the motherboard when requested by the system). You might want to check that out. Also check to see if APM is enabled in your BIOS settings.
 
Old 04-24-2005, 03:48 PM   #7
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Solus
Posts: 2,254

Rep: Reputation: 47
halt
 
Old 04-24-2005, 04:38 PM   #8
mrcheeks
Senior Member
 
Registered: Mar 2004
Location: far enough
Distribution: OS X 10.6.7
Posts: 1,690

Rep: Reputation: 51
they made some changes in kernel 2.6.X.

you want to add the option acpi=force to your lilo options in lilo.conf or grub.conf/menu.lst.

add the option right after for example root=/dev/hdaX

this will shutdown the system.
 
Old 04-24-2005, 05:01 PM   #9
chutsu
Member
 
Registered: Nov 2003
Location: UK
Distribution: Debian Lenny
Posts: 255

Rep: Reputation: 31
Ok I had The exact problem and I solved it....I think what you mean is when you type in a command say...halt....in the command line and then the computer starts to make a string of outputs saying shutting down this and that and then its stops at the end asaying power down when it doesn't....

This is easy...all you have to do is remove the leading '# ' in the line ' /sbin/modprobe apm ' in file /etc/rc.d/rc.modules.
and for this session type :#modprobe apm

summery:
1./ type in pico or gedit in gnome.....
so it will be pico /etc/rc.d/rc.modules or
gedit /etc/rc.d/rc.modules
2./ remove the leading '# ' in the line ' /sbin/modprobe apm

3./ and add #modprobe apm a line below
 
Old 04-24-2005, 05:02 PM   #10
chutsu
Member
 
Registered: Nov 2003
Location: UK
Distribution: Debian Lenny
Posts: 255

Rep: Reputation: 31
this will enable your computer to shut down with out you needing to push the power button to finish it off.....however every time you shut down you have to type in halt in the command line when X is not started
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 10.1 shutdown skitzo2005 Slackware 12 08-07-2005 12:51 PM
Slackware 10.0 and shutdown snutz411 Slackware 6 01-15-2005 08:37 PM
Slackware 10.0 random shutdown plamensl Linux - Security 9 11-03-2004 05:00 AM
how do I shutdown httpd after i started it? under slackware babyboss Slackware 3 10-02-2004 02:42 AM
Slackware shutdown jamaso Linux - General 16 11-28-2001 11:27 AM


All times are GMT -5. The time now is 06:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration