LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-26-2004, 08:37 AM   #1
decimal3
LQ Newbie
 
Registered: Jun 2004
Posts: 7

Rep: Reputation: 0
slackware entry in lilo


I just installed mandrake onto a separate partition from my slackware install. I let it overwrite my boot partition and now I am just trying to get my slackware partition reconfigured in lilo. Can someone please let me know what I need to find on the old slackware partition to get the correct lilo parameters?

This is what I tried and I get "Kernel Panic ... try using init=". It was just a guess mostly though.

image=/boot/vmlinuz
label="Slackware_10.0"
root=/dev/hda2
initrd=/boot/initrd
append="devfs=mount acpi=ht resume=/dev/hda3 splash=silent"
read-only


Thanks in advance!!
 
Old 09-26-2004, 09:39 AM   #2
MathewT
LQ Newbie
 
Registered: May 2004
Location: Russell Island Q.L.D
Distribution: Slackware 12
Posts: 28

Rep: Reputation: 15
decimal3 try something like this,

image=/mnt/hda2/boot/vmlinuz-2.6.7
label="Slackware_10.0"
append="/dev/hda2 splash=silent"
vga=788

if the boot device for slackware is hda3 then put that where i have hda2 and the kernel des -2.6.7 with the correct one. it appears to me that youare trying to mix params for both systems, check the grub/lilo params for slackware and add them to append, remove splash=silent if it is not in slacks params. Check the vga= and alter accordingly.

HTH

Mathew
 
Old 09-26-2004, 04:20 PM   #3
decimal3
LQ Newbie
 
Registered: Jun 2004
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks, this is what ended up working for me:

image=/mnt/hda2/boot/vmlinuz
label="Slackware_10.0"
root=/dev/hda2
read-only
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need a Fedora Core 3 lilo entry... rrfish72 Linux - General 4 12-10-2004 04:46 PM
Need Red Hast lilo entry... rrfish72 Linux - General 7 11-21-2004 03:17 AM
Installed Red Hat 9 - need help with lilo entry.... rrfish72 Red Hat 1 11-21-2004 03:02 AM
How do i find out the fedora entry for the lilo config xiato Linux - Newbie 3 05-05-2004 02:50 PM
How to add entry for Windows in lilo Wynd Linux - General 2 09-04-2003 04:58 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration