LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-22-2005, 04:08 PM   #1
linda
Member
 
Registered: Apr 2001
Location: New Jersey
Distribution: Slackware
Posts: 222

Rep: Reputation: 30
Slackware, Debian, Suse Grub question


I'm stumped, but that's not hard to do... I have /boot residing on the second partition of my sata hard drive hd0. Suse kernel 2.6 is on /dev/sda12 and boots fine. I installed Grub with this install of Suse.
Debian with a 2.6 kernel is on /dev/sda14 boots fine also.
Slackware with a 2.4 kernel is on /dev/sda15 and won't boot with grub, but boots fine with its own floppy disk made during setup (syslinux?) I thought maybe the problem was the fact it is a 2.4 kernel, but would that matter? It does boot properly without grub.

So, my question is, why won't Slackware boot with grub? I did install grub on Slackware, at least I think i did. I used pkgtool and it installed grub to /boot... All of the files mentioned in my menu.lst are residing in /boot.

This is the message I get when i try to boot Slackware:
VFS: Cannot open root device "sda15" Please append a correct "root=" boot option. Kernel panic: VFS: Unable to mount root fs.

Here is a portion of my menu.lst:

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- SUSE LINUX 9.3
kernel (hd0,2)/vmlinuz root=/dev/sda12 showopts ide=nodma apm=off acpi=off vga=normal noresume selinux=0 barrier=off nosmp noapic maxcpus=0 3
initrd (hd0,2)/initrd

###Don't change this comment - YaST2 identifier: Original name: linux###
title Debian
kernel (hd0,2)/vmlinuz-deb-2.6.8-2-386 root=/dev/sda14 vga=0x314 selinux=0 splash=silent resume=/dev/sda14 showopts
initrd (hd0,2)/initrd.img-2.6.8-2-386

###Don't change this comment - YaST2 identifier: Original name: linux###
title Slackware
kernel (hd0,2)/vmlinuz-slack-2.4.31 root=/dev/sda15 vga=0x314 selinux=I0 splash=silent resume=/dev/sda15 showopts
 
Old 11-22-2005, 05:03 PM   #2
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 -current
Posts: 1,152

Rep: Reputation: 60
Quote:
VFS: Cannot open root device "sda15" Please append a correct "root=" boot option. Kernel panic: VFS: Unable to mount root fs.
Are you sure you have slackware installed on root=/dev/sda15? Your error message seems to suggest that. Post the output of

Code:
fdisk -l
Quote:
###Don't change this comment - YaST2 identifier: Original name: linux###
title Slackware
kernel (hd0,2)/vmlinuz-slack-2.4.31 root=/dev/sda15 vga=0x314 selinux=I0 splash=silent resume=/dev/sda15 showopts
I would also suggest you comment out everything starting from "vga" for the slackware entry...those entries are specific to every kernel and may not be supported by slackware's vanilla kernel.

Tux,
 
Old 11-22-2005, 06:10 PM   #3
linda
Member
 
Registered: Apr 2001
Location: New Jersey
Distribution: Slackware
Posts: 222

Original Poster
Rep: Reputation: 30
Ok, I booted into Suse, and got this for fdisk -l
I also mounted sda15 to look at the files (using Konqueror) to make sure it was Slackware, and it is. But I saw that the folder /boot is listed under my /slackware folder, so maybe grub wasn't installed in the right /boot? Will that matter, since I already have a working grub install? Do I have to install grub in each Linux? Can't I just edit the menu.lst and point to the kernel and root, and copy the kernel file to /boot like I did?

Disk /dev/sda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 1 765 6144831 7 HPFS/NTFS
/dev/sda2 893 30401 237031042+ f W95 Ext'd (LBA)
/dev/sda3 * 766 892 1020127+ 83 Linux
/dev/sda5 893 3788 23262088+ b W95 FAT32
/dev/sda6 3789 9273 44058231 b W95 FAT32
/dev/sda7 9274 12715 27647833+ b W95 FAT32
/dev/sda8 12716 16540 30724281 b W95 FAT32
/dev/sda9 16541 20365 30724281 b W95 FAT32
/dev/sda10 20366 23946 28764351 b W95 FAT32
/dev/sda11 23947 24073 1020096 82 Linux swap / Solaris
/dev/sda12 24074 25921 14844028+ 83 Linux
/dev/sda13 25922 27835 15374173+ 83 Linux
/dev/sda14 * 27836 29110 10241406 83 Linux
/dev/sda15 29111 30401 10369926 83 Linux

Partition table entries are not in disk order

Disk /dev/hda: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 894 7181023+ 7 HPFS/NTFS
/dev/hda2 1022 4865 30876930 f W95 Ext'd (LBA)
/dev/hda3 895 1021 1020127+ 83 Linux
/dev/hda5 1022 1887 6956113+ b W95 FAT32
/dev/hda6 1888 2948 8522451 b W95 FAT32
/dev/hda7 2949 3137 1518111 b W95 FAT32
/dev/hda8 3138 3998 6915951 b W95 FAT32
/dev/hda9 3999 4865 6964146 b W95 FAT32

Partition table entries are not in disk order
linux:/home/linda #
 
Old 11-22-2005, 06:28 PM   #4
perfect_circle
Senior Member
 
Registered: Oct 2004
Location: Athens, Greece
Distribution: Slackware, arch
Posts: 1,783

Rep: Reputation: 52
You are on a sata hard disk. As far as I know 2.4 kernels DO NOT support sata.
this is from the slackware 10.2 announcement:
Quote:
Slackware 10.2 includes the Linux 2.4.31 kernel, with Linux 2.6.13 available in the /testing directory. For the first time, a 2.6 kernel with support for SCSI, RAID, and SATA is offered as a boot option in the installer (called "test26.s").
You should have chosen the 2.6 kernel for Slackware...
 
Old 11-22-2005, 06:36 PM   #5
linda
Member
 
Registered: Apr 2001
Location: New Jersey
Distribution: Slackware
Posts: 222

Original Poster
Rep: Reputation: 30
Well, that was what I thought too, but then how is it that I can boot Slack 2.4 off of the floppy? Would that make a difference?
 
Old 11-22-2005, 06:42 PM   #6
perfect_circle
Senior Member
 
Registered: Oct 2004
Location: Athens, Greece
Distribution: Slackware, arch
Posts: 1,783

Rep: Reputation: 52
Are you sure it's a 2.4 kernel. I don't have sata and haven't tryed the 10.2 installer. I just did an update from 10.1.
You mean you can boot from the floopy and your slackware root directory mounts just fine?
Can you do that again and then try a "uname -r" to make sure you use the 2.4 kernel?
 
Old 11-22-2005, 06:45 PM   #7
linda
Member
 
Registered: Apr 2001
Location: New Jersey
Distribution: Slackware
Posts: 222

Original Poster
Rep: Reputation: 30
Sure, that sounds like a great idea... I'll be right back.
 
Old 11-22-2005, 06:54 PM   #8
linda
Member
 
Registered: Apr 2001
Location: New Jersey
Distribution: Slackware
Posts: 222

Original Poster
Rep: Reputation: 30
Well, I booted with my floppy, the one made during the Slack install, and uname says the kernel is 2.4.31
 
Old 11-22-2005, 06:58 PM   #9
perfect_circle
Senior Member
 
Registered: Oct 2004
Location: Athens, Greece
Distribution: Slackware, arch
Posts: 1,783

Rep: Reputation: 52
hmmm....Strange. then try a line like this in grub:
kernel (hd0,2)/vmlinuz-slack-2.4.31 root=/dev/sda15 ro
 
Old 11-22-2005, 07:25 PM   #10
linda
Member
 
Registered: Apr 2001
Location: New Jersey
Distribution: Slackware
Posts: 222

Original Poster
Rep: Reputation: 30
So erase everything after vga= like Tuxrules said. Well, I don't know why that would work, but I'll try it...
 
Old 11-22-2005, 07:25 PM   #11
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 -current
Posts: 1,152

Rep: Reputation: 60
Quote:
kernel (hd0,2)/vmlinuz-slack-2.4.31 root=/dev/sda15 ro
Shouldn't that be

Code:
kernel (hd0,2)/vmlinuz-ide-2.4.31 root=/dev/sda15 ro
I think slackware does not provide a vmlinuz-slack-2.4.31 by default...that is to say linda is using the stock install. I may be wrong...

Tux,
 
Old 11-22-2005, 07:28 PM   #12
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 -current
Posts: 1,152

Rep: Reputation: 60
Quote:
Originally posted by linda
So erase everything after vga= like Tuxrules said. Well, I don't know why that would work, but I'll try it...
Don't erase it...you could just comment it. I didn't mean it would stop the kernel from booting but it could cause problem later on during the boot process. Especially the splash= option since slack does not have a splash screen in stock install. Comment it out for now and you can tweak it later once you are able to boot slack correctly.

Tux,
 
Old 11-22-2005, 07:45 PM   #13
linda
Member
 
Registered: Apr 2001
Location: New Jersey
Distribution: Slackware
Posts: 222

Original Poster
Rep: Reputation: 30
I went and erased it already... But i can always put it back when Slack boots. And, it didn't boot, i got the same error. I really think those few lines of code are okay, though, because I did get the cute little Penguin picture on my console when the code was there, up until the kernel panic that is.

Not to muddy the waters here, but this could be related. As you can see from the above, i also have an ide hard drive, hdb. On it, i have an old XP install. Grub menu.lst has 2 different lines for booting my new WinXP on (hd0,0) and old WinXP (hd1,0) Both entries boot the same thing, the new XP on hd0,0. Weird. And maybe it's a seperate problem, but maybe not. I just figure I'll post all the information i can... You can ignore it if it is a seperate problem because I am going to remove that drive anyway.

And I do appreciate all of the input received so far!
 
Old 11-23-2005, 03:32 PM   #14
linda
Member
 
Registered: Apr 2001
Location: New Jersey
Distribution: Slackware
Posts: 222

Original Poster
Rep: Reputation: 30
I was just getting ready to wipe out my Slack install and do a new install with the test26.s kernel. But I remembered I used the sata.s kernel with my original install, so I am thinking that the kernel should be fine for my sata drive. My problem probably isn't that, so does anyone else have any suggestions?
 
Old 11-23-2005, 03:47 PM   #15
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 -current
Posts: 1,152

Rep: Reputation: 60
Try this
Code:
kernel (hd0,2)/vmlinuz root=/dev/sda15 ro
If you were able to boot after install then check out the /boot directory and see what kernel names you have there. If none of that works, I guess you can go ahead with test26.s but read up on slackware
release notes

Here's excerpt from the release notes
Quote:
Also, the kernel module packages for 2.6.13 are not part
of the standard installation, so if you install using the test26.s
kernel you'll have to install those packages when you're done.
They can be found under testing/packages/linux-2.6.13/ (or ISO
number two under /linux-2.6.13), the alsa-driver and
kernel-modules packages.
Tux,
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
grub(SuSE)/Lilo(Slackware) chain loader problems The Chain Linux - Newbie 32 10-12-2006 05:24 PM
use suse/grub to boot slackware ? muddywaters SUSE / openSUSE 2 08-18-2005 01:10 PM
rh9 debian migration grub question virgin Linux - Newbie 1 05-13-2005 04:50 PM
debian grub question greenmeanie Debian 2 02-24-2005 10:26 PM
Installing Debian and Red Hat together (Grub question) oswald21 Linux - Newbie 4 03-17-2003 02:26 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration