LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-05-2014, 03:03 AM   #1
starplateena
LQ Newbie
 
Registered: Jun 2014
Posts: 4

Rep: Reputation: Disabled
Slackware ./configure error


I'm new to slackware.

i'm trying to install freetds on my slackware 14.0 but i get this error when i run ./configure

config.log say:

gcc: error: unrecognized command line option '-V'
gcc : fatal error: no input files
gcc: error: unrecognized command line option '-qversion'
gcc : fatal error: no input files
...
...
error: C compiler cannot create executables
 
Old 06-05-2014, 03:43 AM   #2
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
Get the SlackBuild. Be sure to read the HOWTO page.
http://slackbuilds.org/repository/14...pment/freetds/
 
Old 06-05-2014, 04:25 AM   #3
starplateena
LQ Newbie
 
Registered: Jun 2014
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by brianL View Post
Get the SlackBuild. Be sure to read the HOWTO page.
http://slackbuilds.org/repository/14...pment/freetds/
already did that.. and the error still the same...
 
Old 06-05-2014, 04:31 AM   #4
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
Have you done a full installation of Slackware?
 
Old 06-05-2014, 04:33 AM   #5
starplateena
LQ Newbie
 
Registered: Jun 2014
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by brianL View Post
Have you done a full installation of Slackware?
no...
i only have slackware disc 1...
my server did't have dvd...
is that a problem...
i already run slackpkg update && slackpkg upgrade
 
Old 06-05-2014, 04:55 AM   #6
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
You need CD2, that's got GCC and other development tools.
Another way to get a full install, without using another CD:
Quote:
If you want to install all uninstalled Slackware packages onto your system, use the following command instead of the install-new action:
slackpkg install slackware.
From the slackpkg manual page.
 
Old 06-05-2014, 05:23 AM   #7
starplateena
LQ Newbie
 
Registered: Jun 2014
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by brianL View Post
You need CD2, that's got GCC and other development tools.
Another way to get a full install, without using another CD:

From the slackpkg manual page.
i will try slackpkg install slackware
and update to you tomorrow(Kuala Lumpur timezone) .

Last edited by starplateena; 06-05-2014 at 05:27 AM.
 
Old 06-05-2014, 10:08 AM   #8
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,654

Rep: Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255
gcc used to have a -V option for version reports. It now uses -v, and provides the configuration options used when the compiler was built.

You package is a bit dated and doesn't reflect that fact.

BTW, the -qversion option was merged into the -v...

Last edited by jpollard; 06-05-2014 at 10:10 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
configure: error: utf8_mime2text() has new signature (Slackware 12) laurisnet Slackware 0 12-18-2012 01:44 AM
[SOLVED] Mono 2.6 - configure error on slackware 12.2 BoatX Linux - Software 2 12-18-2009 08:20 AM
Error Installing Firestarter on Slackware Linux @ ./configure Various Linux - Software 6 03-29-2009 03:11 AM
Error when I ./configure GRUB (Slackware Linux) Dark Jirachi Linux - Software 4 07-08-2007 12:32 PM


All times are GMT -5. The time now is 12:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration