LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-04-2004, 07:55 PM   #1
NaTaS
LQ Newbie
 
Registered: Oct 2003
Location: Rhode Island, USA
Distribution: Slackware 9.1
Posts: 28

Rep: Reputation: 15
Slackware and X help


I'm a linux newb, and figured it would be best to try one of the quote "harder" distro's, instead of using Mandrake that will hold my hand through the whole thing. Well I just finished installing Slackware, and man was that easy, but I can't run X. I ran xf86config, and configured everything. When i try "startx" at the command line, my screen goes black and then back to the command line giving me an error. This part of the error is what I think is behind it all:

"(WW) Radeon: No matching Device section for instance (BusID PCI:2:0:1) found

(EE) No devices detected"

I have a Radeon 9600, and it's an AGP card. I'm guessing that X is trying to look in my PCI slots for the card. So what do I need to do/configure so that X knows my card is in an AGP slot?
 
Old 04-04-2004, 07:59 PM   #2
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
This sounds like a driver problem. Have you tried the drivers from ATI?
 
Old 04-04-2004, 08:04 PM   #3
NaTaS
LQ Newbie
 
Registered: Oct 2003
Location: Rhode Island, USA
Distribution: Slackware 9.1
Posts: 28

Original Poster
Rep: Reputation: 15
Seeing as I only have access to the Command Line, and im a complete newb, how would I go about downloading the driver? ATI tells me how to install it, but now how to download it
 
Old 04-04-2004, 08:12 PM   #4
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
You can use wget to download from the internet so the command would be

wget http://www2.ati.com/drivers/linux/fg...3.7.6.i386.rpm

This will download the driver to the directory your in.

Or you could download it in windows, and access the windows partition from linux using the mount command.
 
Old 04-04-2004, 08:27 PM   #5
NaTaS
LQ Newbie
 
Registered: Oct 2003
Location: Rhode Island, USA
Distribution: Slackware 9.1
Posts: 28

Original Poster
Rep: Reputation: 15
I tried the wget, but i got "Resolving www2.ati.com... Failed: Host not found"



I can't try the second option, because im using windows on a different machine than the one with Slackware on it. So why isn't it letting me download the driver?
 
Old 04-04-2004, 09:31 PM   #6
NaTaS
LQ Newbie
 
Registered: Oct 2003
Location: Rhode Island, USA
Distribution: Slackware 9.1
Posts: 28

Original Poster
Rep: Reputation: 15
I typed "ifconfig" and it gives an IP and Netmask for eth0, both of which are correct. "/sbin/lspci" has both my nic's. I tried pluging the cable in both nics, but it won't work with either?
 
Old 04-05-2004, 08:28 AM   #7
NaTaS
LQ Newbie
 
Registered: Oct 2003
Location: Rhode Island, USA
Distribution: Slackware 9.1
Posts: 28

Original Poster
Rep: Reputation: 15
I tried to put the RPM on a floppy, but it is too big. Is there any way (using Windows) to maybe convert it to a different format so that it will fit on a floppy?
 
Old 04-05-2004, 04:20 PM   #8
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
You could try compressing it with zip, and unzipping it with unzip in Linux.

But there appears to be something wrong with your internet connection. Also check to see if there not already on your CD's
 
Old 04-05-2004, 04:26 PM   #9
Chris H
Member
 
Registered: Aug 2003
Location: Farnborough, UK
Distribution: Zenwalk
Posts: 288

Rep: Reputation: 30
NaTaS, could be that you need to manually edit your XF86Config file. You'll find it under /etc/X11

If you can post it's contents here.
 
Old 04-05-2004, 05:52 PM   #10
NaTaS
LQ Newbie
 
Registered: Oct 2003
Location: Rhode Island, USA
Distribution: Slackware 9.1
Posts: 28

Original Poster
Rep: Reputation: 15
I got X working, I used VESA drivers instead of the Radeon ones, and I have KDE up and running. Only problem is still the internet, and sound. Could the internet problem be because of having 2 NIC's? One onboard, and one PCI one.

Sound problem: When I start up KDE, I get this

"Error while initialize sound driver:
device /dev/dsp can't be opened (no such device)"
 
Old 04-05-2004, 06:17 PM   #11
shane25119
Member
 
Registered: Aug 2003
Location: Illinois
Distribution: Linux Mint XFCE
Posts: 647

Rep: Reputation: 52
disable the onboard one, you just need to configure your NIC, i do not know the command in slack to do that, you could google it
 
Old 04-05-2004, 06:27 PM   #12
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
The sound problem probably means the system can't find your sound card. Try selecting diffrent hardware options in KDE. control Center->Sound & Multimedia->Sound System Under the Hardware Tab. Maybe your trying to use ALSA, when your kernel only supports OSS. or similar. If this doesn't work, Maybe you need to install drivers for your sound card.
 
Old 04-05-2004, 08:40 PM   #13
NaTaS
LQ Newbie
 
Registered: Oct 2003
Location: Rhode Island, USA
Distribution: Slackware 9.1
Posts: 28

Original Poster
Rep: Reputation: 15
There is no "hardware" tap, all I see is "aRTs", "Sound I/O", "Mixer", and "MIDI"

Under I/O, the I/O method is set to autodetect, i'll try other methods to see if they work.

But I'm having trouble finding commands for the nic. Im guessing all I would have to do is disable the onboard NIC(no clue how) and then run netconfig?
 
Old 04-06-2004, 06:32 PM   #14
NaTaS
LQ Newbie
 
Registered: Oct 2003
Location: Rhode Island, USA
Distribution: Slackware 9.1
Posts: 28

Original Poster
Rep: Reputation: 15
I tried "dhcpcd eth0" because it had been suggestion in other people's problems, and it worked! Now does this mean that every time I start up, I'll have to enter this in order to get online?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
About Slackware 9.1 boot disk?? ftp://ftp.kpn.be/pub/linux/slackware/slackware-9.1-is AL3OMDAH Slackware 4 04-18-2007 10:54 AM
Dual boot windows/slackware, but slackware installed first? Cryptic_K Slackware 3 11-20-2006 01:49 PM
Slackware 10 RC2 released; Slackware 10 imminent... SBing Slackware 22 06-22-2004 08:53 AM
Newer Slackware Packages on older slackware version pengStudent Slackware 2 11-12-2003 01:47 PM
wine and winesetuptk working well with slackware 9.0 and slackware 9.1 oobe Linux - Software 0 10-19-2003 01:29 PM


All times are GMT -5. The time now is 06:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration