LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-10-2011, 07:49 PM   #1
pyrotiger
LQ Newbie
 
Registered: Sep 2011
Location: Tucson, AZ
Distribution: Slackware, LFS, Kubuntu, Mandriva, Mac OSX, Ex Windows
Posts: 13

Rep: Reputation: Disabled
Slackware


I have a pressing issue at this point with my Slackware install. I have configured the install to blacklist radeon. I tried setting the lilo.conf to pass the proper vga number to the kernel. However, it keeps spitting out undefined video mode: 305. I understand my card doesnt support this video mode, and have accordingly adjusted my lilo.conf to use 776, yet it spits out the same thing.....
 
Old 09-10-2011, 08:45 PM   #2
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Hi pyrotiger, Welcome to LQ. Did you try passing

Code:
vga = normal
in lilo?

Good luck. ;-)
 
Old 09-10-2011, 09:21 PM   #3
pyrotiger
LQ Newbie
 
Registered: Sep 2011
Location: Tucson, AZ
Distribution: Slackware, LFS, Kubuntu, Mandriva, Mac OSX, Ex Windows
Posts: 13

Original Poster
Rep: Reputation: Disabled
Looking around the net, found out that unlike Grub of which i had become accustomed to with other distro's, lilo must be reconfigured after each change to the lilo.conf. ran lilo in shell and restarted and it worked like a charm.
Effective way to set up linux box to work with your radeon card:
A-Download proprietary ATI driver for your card
B-Run pkgtool to build the ATI driver (for my system, there was no need to run the install option as the build did that for me automatically somehow, after spitting an error stating i need to make first when i used buildandinstall option)
C-be sure to blacklist the generic radeon driver or you will never be able to boot into the X window effectively and be staring at a black screen. If your runlevel is set to runlevel4 you're *** out of luck and would have to externally access the linux filesystem to reconfigure)
D-open up /etc/lilo.conf and uncomment #vga=ask (remove #) and comment out (add #) the other modes so you can see the actual options that are available for you that is supported by the card when you reboot
run lilo in shell
E-reboot system, and then note all the available options and pick out best video mode for you (play with the modes by selecting whichever mode is listed)
F-After finding the mode that fits you, edit /etc/lilo.conf once again and comment out vga=ask and uncomment the particular mode that suits you and your video card.
G-run lilo in shell and then reboot to verify it works. If it runs straight to the runlevel (whichever is set) then you have chosen the proper mode. If it prompts again, then you have chosen a displayed video mode that the video card does not support. Repeat steps F and G.

If you want to set up your system to run straight to a graphical login screen, you will need to change the runlevel option to 4. It is easy but vital to follow the steps laid out.
-Open /etc/inittab and read all the available runlevels laid out in that file, in Slackware, there are 7 runlevels available.
-Note id:3:initdefault: With a stock Slackware install, this will be the default which tells the kernel to load the command line console login. Most other distro's will have 4 as the default which loads the default session manager. Which session manager depends on what desktop manager is set as the default. ::BEWARE:: DO NOT SET YOUR DEFAULT RUNLEVEL TO 0 OR 6. ::WARNING:: Using 0 will just tell the system to stop running after it loads the kernel image. Using 6 will send the system into an endless reboot loop. ::BEWARE::
-Change id:3:initdefault: to id:4:initdefault: and then save and close the file. and reboot to verify it loads the session manager automatically.
 
Old 09-10-2011, 09:24 PM   #4
pyrotiger
LQ Newbie
 
Registered: Sep 2011
Location: Tucson, AZ
Distribution: Slackware, LFS, Kubuntu, Mandriva, Mac OSX, Ex Windows
Posts: 13

Original Poster
Rep: Reputation: Disabled
Peacedog: Ah that would have disabled the frame buffer, i would like to have that. My issue was that i did not run lilo to reconfigure the bootloader after altering the file. My problem is i do things without fully reading the usage of certain commands
 
Old 09-11-2011, 12:57 AM   #5
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Glad you got it sorted.

Good luck. ;-)
 
Old 09-11-2011, 02:12 AM   #6
pyrotiger
LQ Newbie
 
Registered: Sep 2011
Location: Tucson, AZ
Distribution: Slackware, LFS, Kubuntu, Mandriva, Mac OSX, Ex Windows
Posts: 13

Original Poster
Rep: Reputation: Disabled
Icon

Quote:
Originally Posted by Peacedog View Post
Glad you got it sorted.

Good luck. ;-)
Hmm... i notice u have a slack logo under ur profile info beside Tux... is there a certain requirement i must pass to have that?
 
Old 09-11-2011, 02:14 AM   #7
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
Quote:
Originally Posted by pyrotiger View Post
Hmm... i notice u have a slack logo under ur profile info beside Tux... is there a certain requirement i must pass to have that?
No, that is the browser icon that designates what browser the poster is using when he/she posted their post.
 
Old 09-11-2011, 05:51 AM   #8
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
Quote:
Originally Posted by corp769 View Post
No, that is the browser icon that designates what browser the poster is using when he/she posted their post.
To be correct, it reads the
"general user agent" string set in your browser, and reads which distribution or OS you are using.
To set the string:
For firefox
https://www.linuxquestions.org/quest...ml#post4306025
For google-chrome
https://www.linuxquestions.org/quest...ml#post3993000
There is a testing thread for this
https://www.linuxquestions.org/quest...-issue-745067/

Kind regards

Last edited by repo; 09-11-2011 at 05:53 AM.
 
Old 09-11-2011, 05:21 PM   #9
pyrotiger
LQ Newbie
 
Registered: Sep 2011
Location: Tucson, AZ
Distribution: Slackware, LFS, Kubuntu, Mandriva, Mac OSX, Ex Windows
Posts: 13

Original Poster
Rep: Reputation: Disabled
Got it! Thanks
 
Old 09-11-2011, 05:22 PM   #10
pyrotiger
LQ Newbie
 
Registered: Sep 2011
Location: Tucson, AZ
Distribution: Slackware, LFS, Kubuntu, Mandriva, Mac OSX, Ex Windows
Posts: 13

Original Poster
Rep: Reputation: Disabled
Hmm worked in another thread, didnt work this time
 
Old 09-11-2011, 06:18 PM   #11
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156Reputation: 3156
Slackware 13.37 has Firefox 4 ( Or later.)

Then it is : general.useragent.override

Mozilla/5.0 (X11; Linux x86; rv:1.0) Gecko/20100101 Firefox/5.0/ Slackware Linux

..
 
Old 09-11-2011, 06:56 PM   #12
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
Quote:
Originally Posted by repo View Post
To be correct, it reads the
"general user agent" string set in your browser, and reads which distribution or OS you are using.
To set the string:
For firefox
https://www.linuxquestions.org/quest...ml#post4306025
For google-chrome
https://www.linuxquestions.org/quest...ml#post3993000
There is a testing thread for this
https://www.linuxquestions.org/quest...-issue-745067/

Kind regards
Pretty much the same thing
 
Old 09-12-2011, 02:17 PM   #13
pyrotiger
LQ Newbie
 
Registered: Sep 2011
Location: Tucson, AZ
Distribution: Slackware, LFS, Kubuntu, Mandriva, Mac OSX, Ex Windows
Posts: 13

Original Poster
Rep: Reputation: Disabled
hmm restarted pc, the string removed itself somehow. Reinserted the string and testing now.
 
Old 09-12-2011, 02:19 PM   #14
pyrotiger
LQ Newbie
 
Registered: Sep 2011
Location: Tucson, AZ
Distribution: Slackware, LFS, Kubuntu, Mandriva, Mac OSX, Ex Windows
Posts: 13

Original Poster
Rep: Reputation: Disabled
Didnt work, and confirmed the string is in the config...
My browser is firefox 6, Slackware 13.37...
 
Old 09-12-2011, 02:24 PM   #15
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,131
Blog Entries: 2

Rep: Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833Reputation: 4833
I clearly can see the icons on your posts, reload the page after posting and you will see it yourself.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NDISwrapper works for Slackware 13.0 x86 but not Slackware 13.0 x64 - Belkin F5D8053 thewizkid Slackware 0 01-14-2010 07:18 AM
LXer: Making Slackware and Slackware Derivative Linux Distros Speak Your Language LXer Syndicated Linux News 0 01-29-2009 01:30 AM
About Slackware 9.1 boot disk?? ftp://ftp.kpn.be/pub/linux/slackware/slackware-9.1-is AL3OMDAH Slackware 4 04-18-2007 10:54 AM


All times are GMT -5. The time now is 01:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration