LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-04-2003, 04:09 AM   #1
jadukor_bd
Member
 
Registered: Aug 2003
Location: Bangladesh
Distribution: Slackware9.1
Posts: 61

Rep: Reputation: 15
Slackware 9.1..Heeeeelp!!!!


Dear every1

I m a newbie using RH9 desktop and trying my best 2 switch 2 any other distro if possible.....recently i installed Slackware9.1 (on experimental basis)
on a 20GB HDD which already had Win98 installed. At
the end of installation it gave me an option 2 configure LILO, but having no proper idea about LILO/GRUB (or any other bootloder) i choose the automatic configuration but looks like its not working cos it still boots directly into Win98 (i don't know what idid wrong)....
Fortunately i had a bootdisk made.... and it's seems 2 b working.... but it boots into command prompt... i typed "startx" but X server won't start; is something wrong?? I m powerless without X Server; i can't even edit a text file... i tried 2 use vi editor
with the help of a book & found it 2 b the most difficult program i have ever operated in my entire LIFE!!( Gurs ..plz don't take any notice my comments..:-> it's just newbie frustrations) I mean how can a text editor b so damn complicated... it could easily win the AWARD of being the most unfriendly Application ever... So i m stuck really bad
over here with Slacky... some1 please help me... at least 2 get my X server up & running..

Thanks.....
 
Old 11-04-2003, 06:13 AM   #2
daveo
Member
 
Registered: Sep 2003
Location: Holland
Distribution: Gentoo 1.4, Slackware
Posts: 196

Rep: Reputation: 30
It might be a good idea to post the lilo.conf file here ..... Do that first before doing what I've mentioned below. Maybe there's an error in your lilo.conf..
-- option2 --
Try to boot at de Slackware cd-rom. Then try to mount the root file system where the files are located on your disk. Try the following:

1. mount -t rootfilesystemtype /dev/partion-number(e.q. hda1/2/3) /mnt
2. chroot /mnt
3. liloconfig

Now make the new mbr (master boot record) and run lilo manually when done
exit
You'll be back on CD
Reboot

Hope this helps,

Last edited by daveo; 11-04-2003 at 06:31 AM.
 
Old 11-04-2003, 06:27 AM   #3
koyi
Member
 
Registered: Jul 2003
Location: Osaka, Japan
Distribution: Arch, Ubuntu
Posts: 421

Rep: Reputation: 31
X is not configured automatically during installation. You hav to configure it yourself.

After you log into slack, su to root, run the command

# xf86cfg -textmode

and a x configuration utility starts, follow the steps and you should be fine.

About the bootloader, maybe you can run

# lilo -v

to install it again. If that doesnt work, post /etc/lilo.conf here so that we can look at it together.

p/s There was a time when I thought vi is very difficult to use. But as you get used to it, it is the most
powerful text editor. I use it mainly to edit system config files, and I use emacs for others.

Last edited by koyi; 11-04-2003 at 06:29 AM.
 
Old 11-04-2003, 08:47 AM   #4
yapp
Member
 
Registered: Apr 2003
Location: Netherlands
Distribution: SuSE (before: Gentoo, Slackware)
Posts: 613

Rep: Reputation: 30
Re: Slackware 9.1..Heeeeelp!!!!

Quote:
Originally posted by jadukor_bd
typed "startx" but X server won't start; is something wrong?? I m powerless without X Server; i can't even edit a text file... i tried 2 use vi editor
well obviously there is something wrong. The first time I typed startx my X server was just working, and I could even change the resolution from some KDE control panel.

Please give us the error message; or simply log the output of the X-Server:
Code:
startx 2>xerrors.log
startx 2>&1 >xoutput.log
(the second one also includes the normal output.


If you get your screen working, you could boot into a graphical login screen by default:
* open /etc/inittab in an editor.
* change runlevel at the initdefault line from 3 to 4.
* reboot, or just type "telinit 4" to enter runlevel 4.


And please, don't forget to create a user account for yourself. You shouldn't login as root for normal work. In fact, the KDE will give you a root password box if you need root permissions for something. (or you can open a console, and type "su" to become root, and use "exit" to leave the root-console.)


The VI editor was a nightmare for me too, but vim (vi improved; installed with slackware) seams to be quite nice. type vimtutor to get a nice vim tutorial. When I edit files, I even get colors for certain keywords. (because I've added "syntax on" to ~/.vimrc)

here are some simply vi commands:
:w = write / save
:q = quit.
:q! = quit, don't save
:wq = write+quit
:syntax on = enable colours.

just move with the arrows, and home/end key.
i = insert, use escape to quit insert mode.
I = insert at begin (esc to quit)
a = append (esc to quit)
A = append at end of the line (esc to quit)
x = delete character.
dd = delete paragraph
3dd = delete 3 paragraphs
w = move to next word

But here are some powers of the vi editor:
cw = change word
3cw = change 3 words
C = change remaining of the line
dw = delete word.
3dw = delete 3 words
D = delete remaining of the line.

etc... there are basics that make your life easier; and if you know more combinations, you'll work a lot faster. I even start to notice that I'm typing 3cw in the Microsoft Visual Studio at work

Last edited by yapp; 11-04-2003 at 08:55 AM.
 
Old 11-04-2003, 10:12 AM   #5
jadukor_bd
Member
 
Registered: Aug 2003
Location: Bangladesh
Distribution: Slackware9.1
Posts: 61

Original Poster
Rep: Reputation: 15
Hello every1

1) I want 2 thank Dave for the command "liloconfig" i used it 2 configure my LILO & its working like charm (first time i ever configured LILO or anything like that). I had 2 install it on my MBR but it was was warning me that it may b risky & unsafe to do that... so i m still a little bit nervous...... it would b helpful if some1 could shed some more light on this issue....

2) thanks to koyi... for the command "xf86cfg -textmode"... my Xserver is up and running like a horse....

3)thanks 2 yapp for the help with vi editor and for advice on creating user acount and about the /etc/inittab.

So i m back with more questions.....

How do i switch 2 gnome?

RedHat had a nice GUI for setting up IP & hostname.... how do i do it in Slacky?

My mouse wheel dosen't work.... i heard that u have 2 add a z-axis or something like (i read it some where) but i actually have no idea what to do or howto do it....

Thanks-a-lot again to all of u...
 
Old 11-05-2003, 04:23 AM   #6
yapp
Member
 
Registered: Apr 2003
Location: Netherlands
Distribution: SuSE (before: Gentoo, Slackware)
Posts: 613

Rep: Reputation: 30
Quote:
How do i switch 2 gnome?
Slackware has an xwmconfig tool, this will create an ~/.xinit file that launches GNOME. However, if you launch the graphical login, you can choose between the desktop environments from a menu To enter runlevel 4, type:
Code:
telinit 4
You'll get the gdm login, and change /etc/inittab to make this the default runlevel at the next reboot..


Quote:
My mouse wheel dosen't work.... i heard that u have 2 add a z-axis or something like (i read it some where) but i actually have no idea what to do or howto do it....
These settings are defined in /etc/X11/XF86Config. The KDE also has a graphical X configuration program, but it will re-create your entire XF86Config file... perhaps you want to create a backup first

Here is my mouse section, I think you'll find something useful in it. Please note that I've changed the identifier.. (it should correspond with the value used in the ServerLayout section!)
Code:
Section "InputDevice"
    Identifier                 "Wheel_Mouse"
    Driver                     "mouse"

    Option "Protocol"          "ImPS/2"       # PS/2 with wheel ("auto" is supported too)
    Option "ZAxisMapping"      "4 5"          # wheel mouse
    Option "Device"            "/dev/mouse"   # device file

    Option "Resolution"        "256"

#   Option "Protocol"          "Xqueue"
#   Option "BaudRate"          "9600"    # Logitech
#   Option "SampleRate"        "150"     # Logitech

    Option "Emulate3Buttons"
    Option "Emulate3Timeout"   "50"
#   Option "ChordMiddle"                 # Logitech
EndSection
( type /mouse to search for text in vim, and use "n" to go to the next match.. type :set ignorecase, or :set ic for an incase-sensitive search )



Quote:
RedHat had a nice GUI for setting up IP & hostname.... how do i do it in Slacky?
Slackware doesn't offer much gui (only default KDE panels); it's purely Linux, and honestly, I love this. To change your inet address, you should edit /etc/rc.d/rc.inet1.conf, and re-execute the script that enabled your network in the first place:
Code:
vim /etc/rc.d/rc.inet1.conf
/etc/rc.d/rc.inet1 stop
/etc/rc.d/rc.inet1 start
btw, in /etc/rc.d you'll find all boot scripts. You can modify then, or disable certain scripts with the chmod command. (chmod -x removes executable permissions for a program/script, chmod +x adds them)

By default, Slackware seams to start quite some network services. Try one of the netstat commands below to find the running services. (if you execute it as root, you'll get the program name too) Then disable the boot-scripts responsible for the services.
Code:
netstat -lnpt         # listing, as numeric, programs, tcp
netstat -anpt         # all, numeric, programs, tcp
netstat -anpA inet    # all, numeric, programs, All from inet family (tcp+udp)

/etc/rc.d/rc.... stop
chmod -x /etc/rc.d/rc....
You might want to disable every network service, except ssh. ssh allows you to login remotely over a secure channel. (ie: a secure telnet) and you can use PuTTY if you're working in Microsoft Windows.

Before I forget; please download the latest patches and fixes:
Code:
swaret --update
swaret --upgrade
happy slacking

Last edited by yapp; 11-05-2003 at 04:30 AM.
 
Old 11-05-2003, 06:46 AM   #7
jadukor_bd
Member
 
Registered: Aug 2003
Location: Bangladesh
Distribution: Slackware9.1
Posts: 61

Original Poster
Rep: Reputation: 15
hello every1....
I have run in2 new troubles.... i reistalled my Slacky9.1 and now it says something like

"Kernal panic: init not found. Try passing init= option" ( pretty much like that)

What do i do???? i m stuck again

thanks.....
 
Old 11-05-2003, 07:20 AM   #8
jadukor_bd
Member
 
Registered: Aug 2003
Location: Bangladesh
Distribution: Slackware9.1
Posts: 61

Original Poster
Rep: Reputation: 15
guys.........
When LILO asks me piont out the linux partion..... which 1 should i point 2
1)/
2)/root
OR the /boot partition..... which i made

thanks and hurry if u can.. plz
 
Old 11-05-2003, 07:25 AM   #9
yapp
Member
 
Registered: Apr 2003
Location: Netherlands
Distribution: SuSE (before: Gentoo, Slackware)
Posts: 613

Rep: Reputation: 30
why did you reinstall slackware? most problems can be solved without reinstalling.

I think the root device is set incorrectly in your boot manager. (did you change the partitions, or forget to run lilo again?) /sbin/init is the first program your kernel starts; it will start the bootscripts from /etc/inittab. Without /sbin/init, your a linux system won't work, and there are other reasons for the existance of init too.


If you see the lilo prompt, you can specify another harddrive as root partition too. Select the correct kernel from the lilo menu, and type " root=hda1" before you hit return..
(replace hda1 into your actual partition, for example, hda3 if you've installed slackware on the third partition, and hda = first disk, hdb = second disk)

I've been told that the second slackware 9.1 cd can be used as live/rescue cd-rom. If anything fails, you can use this disk too.

Last edited by yapp; 11-05-2003 at 07:30 AM.
 
Old 11-05-2003, 11:25 AM   #10
jadukor_bd
Member
 
Registered: Aug 2003
Location: Bangladesh
Distribution: Slackware9.1
Posts: 61

Original Poster
Rep: Reputation: 15
hello again.....

it been 1 hell of a day...i had 2 reinstall Slacky 3 times before i found out what the problem with LILO was..... all this time i was configuring LILO manually... no matter how care full i was with the partition numbers... it kept on malfunctioning.... until i choose automatic configuration..... now it is working fine..... and i just found out that KDE has a nice GUI for configuring LILO...... although it seems a bit buggy.... it keept crashing!! anyway finally i have got the LILO part figured out at least.......
Now i m going 2 try out what yapp suggested and find out if i can get my IP,Host name & mouse in order.....
1 last thing..... i m using the "netconfig" command for this but it keeps asking for domain name.... what should i put there?
 
Old 11-05-2003, 11:27 AM   #11
daveo
Member
 
Registered: Sep 2003
Location: Holland
Distribution: Gentoo 1.4, Slackware
Posts: 196

Rep: Reputation: 30
If you are not part of a domain, just enter a nice name you like.
 
Old 11-05-2003, 02:12 PM   #12
jadukor_bd
Member
 
Registered: Aug 2003
Location: Bangladesh
Distribution: Slackware9.1
Posts: 61

Original Poster
Rep: Reputation: 15
ok every1

i just setup my IP and Host name using "netconfig" but i think the connectio eth0 has not been activated.... how do i activate it in slakeware9.1... it was totaly GUI in RH9.... so i m stuck.....; alos is there anything i can do 2 setup the preferences for eth0..
thanks....
 
Old 11-05-2003, 03:01 PM   #13
jadukor_bd
Member
 
Registered: Aug 2003
Location: Bangladesh
Distribution: Slackware9.1
Posts: 61

Original Poster
Rep: Reputation: 15
ok guys...
I have got it's "ifconfig eth0 up".... i actually found it in 1 of the threads... and mu inet is working fine now
thanks a lot...
 
Old 11-05-2003, 04:35 PM   #14
jadukor_bd
Member
 
Registered: Aug 2003
Location: Bangladesh
Distribution: Slackware9.1
Posts: 61

Original Poster
Rep: Reputation: 15
hello every1
I can't get my three button single wheel A4 TECH(PS/2) optical mouse 2 work... well actually it works, except for the scrool wheel. i took yapp's advice & edited the following lines in xf86config file under the Section "InputDevice"

1) Option "Protocol" "PS/2" to-----------> Option "Protocol" "ImPS/2"

2) I also added the following line...which caused my Xserver not 2 start..... and so i had 2 remove it using vi editor and now it's working fine again but no wheel again........ the line is

Option "ZAxisMapping" "4 5"

So what did i do wrong this time......??

Thanks....
 
Old 11-06-2003, 06:30 AM   #15
yapp
Member
 
Registered: Apr 2003
Location: Netherlands
Distribution: SuSE (before: Gentoo, Slackware)
Posts: 613

Rep: Reputation: 30
Quote:
which caused my Xserver not 2 start
and what did it tell you? Linux software tells you a lot, but we can't help you right now.


please try the startx logging thing I've posted here

and there is another way to get all useful messages from the xfree log file:
Code:
grep -E "\((WW|EE)\)" /var/log/XFree86.0.log
---

if you get X working again, change the mouse protocol version in /etc/rc.d/rc.gpm too. Using two different mouse protocols for the same mouse causes your mouse to jump across the screen. (ImPS/2 and PS/2 really differ) rc.gpm is the bootscript that enables your mouse in the console.

Last edited by yapp; 11-06-2003 at 06:52 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
About Slackware 9.1 boot disk?? ftp://ftp.kpn.be/pub/linux/slackware/slackware-9.1-is AL3OMDAH Slackware 4 04-18-2007 10:54 AM
Dual boot windows/slackware, but slackware installed first? Cryptic_K Slackware 3 11-20-2006 01:49 PM
Vsfptd, Heeeeelp mkyb14 Linux - Software 3 08-21-2005 12:15 PM
Multiboot HEEEEELP blu_la Linux - Newbie 3 03-27-2004 04:12 AM
Newer Slackware Packages on older slackware version pengStudent Slackware 2 11-12-2003 01:47 PM


All times are GMT -5. The time now is 12:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration