LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-04-2013, 02:23 PM   #1
rogcg
LQ Newbie
 
Registered: Apr 2013
Posts: 2

Rep: Reputation: Disabled
Slackware 14 can't connect via dhcp


I'm very newbie to Slackware. I have worked before with Ubuntu. I just installed it, and the internet is not working. When running ifconfg I've seen that I have only eth0 and lo. I've followed the documentation and tried with netconfig and setting up dhcp.

I've set the hostname as, userpc, the domainname as home, than I chooose dhcp and the hostname I've left blank.

after that I run /etc/rc.d/rc.inet1 eth0_start.

Than I connected the cable and once it said it was connected, but I couldn't navigate to any page. And now it says the connection failed.

I'm posting this from another computer.

This is the data in rc.inet1.conf

Code:
# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""

GATEWAY=""
And here is ifconfig:

Code:
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
    inet6 fe80::ba70:f4ff:feef:300c prefixlen 64 scopied 0x20<link>
    ether b8:70:f4:ef:30:0c txqueuelen 1000 (Ethernet)
    RX packets 524 bytes 34095 (33.2 KiB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 62 bytes 13161 (12.8 KiB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: ... I dont think this interface matters. Am I right?
If you need any more data, I'll post here.
 
Old 04-04-2013, 03:02 PM   #2
vigi
Member
 
Registered: May 2009
Location: australia
Distribution: slackware
Posts: 184

Rep: Reputation: 28
The process is automated in version 14...check you have the package wicd.txz if not install it. Then plug in your internet ethO cable.
 
Old 04-04-2013, 03:09 PM   #3
rogcg
LQ Newbie
 
Registered: Apr 2013
Posts: 2

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by vigi View Post
The process is automated in version 14...check you have the package wicd.txz if not install it. Then plug in your internet ethO cable.
i run pkgtool and check if i have this wicd.txz installed. I've seen only a package called wicd-kde-0.3.0. is it correct?
 
Old 04-04-2013, 03:24 PM   #4
Habitual
LQ Addict
 
Registered: Jan 2011
Location: Youngstown, Ohio
Distribution: LM17.1/Xfce4.11.8
Posts: 7,190
Blog Entries: 10

Rep: Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983
This should help.
It did for me.
http://wiki.linuxquestions.org/wiki/...king#Slackware
 
Old 04-04-2013, 08:13 PM   #5
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 4,434

Rep: Reputation: 1354Reputation: 1354Reputation: 1354Reputation: 1354Reputation: 1354Reputation: 1354Reputation: 1354Reputation: 1354Reputation: 1354Reputation: 1354
For your networking, I suggest this section at SlackDocs
http://docs.slackware.com/slackware:...e_your_network

If you are new to Slackware, there is a lot of useful information at SlackDocs.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
connect to DHCP manz00r Ubuntu 3 02-07-2009 02:09 PM
how to connect to non DHCP theangler Linux - Wireless Networking 6 04-18-2007 12:54 AM
slackware 10.2 wont connect to DHCP ichiroboston Linux - Newbie 2 06-29-2006 11:47 AM
can't connect linksys+dhcp newbe45 Linux - Networking 0 09-05-2004 09:32 AM
Problem withInternet, DHCP, connect with eth0 down work, connect with eth0 up not zowey Linux - Networking 1 03-12-2004 11:05 AM


All times are GMT -5. The time now is 09:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration